A little PC knowledge for installing the game - using WINE (no don't hang up!)

I know it’s an old game, I know it’s not supported on Macs and I know this is a long shot but I thought I’d try.

I have an iMac ( late 2013) so it’s old. I have NWN:EE working perfectly but then its for the Mac. However, I also have the toolset working perfectly using WINE. I have also bought a number of other PC games which mostly work ( including Witcher 1 and 2). So WINE is a decent option.

In the current GOG sale for NWN2 I decided to take the plunge and buy NWN2, knowing its not intended for Macs but determined to try it using WINE.

Well, it worked (nearly!).

It downloaded properly, launched fine ( by clicking Launch on the final installer screen) and I played with it for about 5 minutes, changed a couple of settings with no issues. I then saved the game and closed it.

When I came back and looked to restart it I first tried the desktop icon created by the installer ( but which has the icon of Gimp - I wasn’t too worried about this as even in NWN:EE icons can be a little mucked up). I set it to open using WINE which is the normal way I get the NWN:EE toolset to open but no joy.

So, I decided to look through the files that were downloaded and came across what I think is the issue.

I don’t seem to have an nwn.exe, NWNmain.exe or other similar file which I can use to open it directly into WINE.

I have


and loads of other files!

Being a Mac user I have no idea if any of these could be used to launch the game or if they could be slightly altered to do so…

It seems to work on the Mac as I’ve just reinstalled it and once I hit launch on the Installer it opens the game and I can play it as normal - or at least 5 minutes which is all I’ve tried.

I’m assuming a normal PC download would have something like an NWN2.exe or an NWN2main.exe or an NWN2launcher.exe file but I don’t seem to have any of these.

As I said I know it’s a long shot but any help would be appreciated.


I will spare you the “MAC? - Get a PC!” jokes … well, maybe one. :wink:

Or maybe just one more.

Anyway, a long shot …

Uninstall the game … and make sure to delete the entire ATARI folder to allow a reinstall.

Reinstall the game, and start again (as you did before) … but see if you can determine which file was used to start the game from your initial install … and try to “keep” that file (and a copy) in a safe place, so that you can use it again.

EDIT: You could also just try double clicking on any of these .exe to see if it helps.

EASIEST FIX: Buy a PC. Sorry, could not resist it. :blush:

Let me know how this pans out for you.

Thanks for the seven suggestions, Lance, even though six of them bore a striking resemblance to each other ! :grinning:

I’ll do as you say. Before I changed the game to full screen I did notice that the WINE icon that appeared in the dock ( ie being used to open it) was a WINE64 one that I hadn’t seen before or, sadly, since.

I’ve tried all those exe files already and they don’t seem to do the trick. It’s not vital. I’m more than happy with EE but was just wanting a look at the NWN2 game to see how it had moved on from 1 - and whether the toolset was as difficult as some have said.


If you can, look to see if it is a different .exe that was created (and then lost) between playing. It may be that the MAC is deleting them somehow?

I don’t know how a MAC works when switching between apps and locating files, but maybe it can be done like that as we do on a PC?

Let us know if you succeed or if it is a complete loss? :hushed:

Will do. A help would be to know what the name of the file is that you would open the game with. Is it NWN2.exe?

It could be that the Mac has deleted it or is hiding it.


Personally, I link to “C:\Program Files (x86)\Atari\Neverwinter Nights 2\NWN2Launcher.exe” to open the launcher for toolset and playing.


But there are also (which may be direct calls):-


Ok, thanks. I’ll try a few things. I can keep my Activity monitor app open while I reinstall the game. Meanwhile I’ve found what WINE does use to enable it to work - if not the file to launch.

Usage: /Applications/Wine Stable.app/Contents/Resources/wine/bin/wine64-preloader wine_binary [args]


Also, are these links any help to you … (Maybe more knowledgable about such matters) … From a Google search for … running NWN2 in WINE

Yes, thanks, I had a look at those pages but they are from years ago and it is a much newer version of WINE now. The fact that I got the game running suggests to me that maybe I don’t need to do as much tinkering as they are suggesting.

Off to install it now. Will let you know.

1 Like

So, I solved the initial problem. Instead of clicking “Launch” when the game had installed I selected “Exit”. Lo and behold, when I navigated to the NWN2 folder all the .exe files were still there. Promptly set NWN2.exe to open using WINE and bingo ! Game opened perfectly, selected character changed some of the settings lower and started original campaign. Attack on village was announced, got ready with equipment and dragged spells into quickbar - all easy and worked well. Sorted out the villains who charged through my door and after a victory lap clicked to move outside.

. . . and I’m still waiting. Alas, the game will not load the second area. Whereas the original one loaded quickly the outside of the house area didn’t even start. So, i’m guessing there are bigger problems which will render this unplayable for me. Short of embracing suggestions 1-6 above I’m skooshed ( grand old Scottish word) ! Tried the toolset but it didn’t even look like opening.

Anyway, thanks for the help, Lance. it was just a whim and I’m really needing to get back into NWN1 just in case the school course I’m helping with restarts anytime soon.

1 Like

i think @Kaldor_Silverwand uses a Mac …

I tried to get NWN2 running using a Wineskin a number of years ago. Here is my blog post on it http://bbellina.blogspot.com/2015/11/installing-nwn2-complete-from-gog-into.html

I was never satisfied though and so play NWN2 by rebooting into BootCamp.



Thanks for this. I’ll have a look. Seems it’s not gonna be great whatever method,

Edit: Just had a quick look. It seems pretty straightforward so I’ll give it a go tomorrow.

As I said I have an iMac from late 2013 running Mojave. You’ve indicated it wasn’t really satisfactory but I’m not keen to shell out for a copy of Windows which is why I use WINE.

How did you find it ran in general and which, if any settings did you lower?

@Kaldor_Silverwand. I’ve gone through your instructions but have ended up with the same problem in one of the comments on your blog.

First of all, apologies for dragging you into this. I’m sure it must be tedious for you going over old ground and troubleshooting.

I’m on Mojave.

I used your wineskin so am ignoring step 1

I created a new folder on my desktop and moved the Wineskin plus all three GoG setup files into it. so I’m essentially trying to keep everything in the same folder.

Double clicked the installer, clicked install software chose Setup Executable then clicked on the set-up complete .exe file and selected Choose.

I don’t get any further as it then throws up the "No new executables found " message plus the message to make sure all software must be installed on the c drive.

In your reply to the poster you mention they might be trying to install outside the wrapper. If you open the wrapper then select the correct setup file and choose is that enough to install within the wrapper ? I’m not sure how you COULD install it anywhere else. FWIW, the wrapper in the folder is greyed out so couldn’t be selected even if there was a step to choose where you wanted to install it. . Steps as below:

the installer - i choose top option

  1. dont understand this

for some reason when it starts to try to install the game it creates a new Wineskin logo in the dock? Don’t know if this is relevant.

I’m happy to install it anywhere, keep the wineskin and the game setup files in separate folders, try step 1 to make my own or anything that would help make it easier.

FINAL THOUGHT: I notice that my game setup file .exe is already setup to open with WINE. Could that be an issue because if I’d just downloaded it it wouldn’t be associated with WINE.

Definitely final thought ! When I look at the Wineskin package contents I see Program files/Users/Windows. I already have all the NWN2 game files unzipped from a previous attempt. It is possible to just manually place them inside one of these folders and when I try to open the game with NWN2.exe it would automatically open it using the wineskin. ( sorry if that’s a laughable suggestion - don’t know much about Windows) !

I don’t think you are doing anything wrong. It no longer works for me either. I get the same error. I guess something has changed. You can fight with trying to get it to run for a long while, but in the end the best experience will be to just buy Windows and use BootCamp. I have a blog post on installing it on Windows 10 here: http://bbellina.blogspot.com/2020/06/installing-nwn2-complete-on-windows-10.html


for what it’s worth, you don’t have to pay for win10 - it’s basically free. just download the media creation tool from microsoft and don’t enter a license key during installation. win10 will nag about that, and will remind you about activating the product, but it will work. the only thing not functioning will be the personalization like color scheme and background image, although the background can still be changed through right clicking an image.

1 Like

Sounds great, although in the “too good to be true category”. I’ll have a look, 'though. Thanks.

If I can get a copy of windows 10 cheaply I might just shell out for it although with the demise of Boot Camp it’s not straightforward. I’m not up at the moment on what the alternatives are likely to be. I’ll maybe do a bit of reading.

Hmm, seems it is legit free for using with Boot Camp as we’re not altering it in any way, just using it as a conduit as it were. Surprising but useful.

Well, I took @Kaldor_Silverwand’s advice and I now have a flawless version of NWn2 running on my Mac through Boot Camp.

So easy to do as well. Thanks for the tip, Kaldor!

It’s bizarre to be playing a sequel to NWN that I’ve never played before. A lot of improvements- but also some areas where I reckon NWN 1 is better.

Btw, cant get the toolset working which is disappointing. it tried to install something called Framework.net which my Mac didn’t like. However, small issue which won’t spoil my enjoyment. Definitely enjoying the outside tilesets.


@Kaldor_Silverwand, thanks for your help. I now have a full functional game working on Boot Camp on my iMac and am enjoying the game a lot.

I’ve got it working on full resolution and although my iMac is late 2013 the game runs smoothly on almost top settings.

However, I just can’t get the toolset to open. The launcher for the toolset opened and told me immediately it had to download a couple of files. It downloaded and installed both perfectly but when I went to open it, the window appeared half screen for a second but immediately disappeared. I ran it in Administrator mode and this time the small toolset splash screen appeared for a few seconds then disappeared. Tried getting the diagnostic window to tell me what was wrong but it simply said it had tried other settings but still wouldn’t open.

Was there anything else you had to do to get it working? Just today I managed to get full screen at maximum resolution working. Could it be that the toolset wouldn’t like that? I read somewhere that it could take a while to open the first time but I gave it 4/5 minutes and nothing happened.

Also, something I can’t get my head around. I’ve go NWN2 complete. It says there is the original campaign plus three expansions- MOTB, Storm of Zehir and Mysteries of Westgate. Yet the one I’m playing is the first which is about the shards yet seems to be called Storm of Zehir ?

1 Like

You get the Storm of Zehir splash screen regardless of which campaign your playing.