A little PC knowledge for installing the game - using WINE (no don't hang up!)

Ah, thanks.

Have you installed DirectX? If not, go to the GoG Games/NWN2 Complete folder and run DXSETUP.

Nope. No items matched the search and visually there is no such file in the GoG Gsmes folder… Could try installing it directly from Microsoft but don’t know what version I’m after.

Strange it didn’t download it with the other files. There are enough of them. I take it the game doesn’t use Direct X to run as it’s working perfectly?

It should be in the NWN2 Complete folder inside the GOG Games folder. Look for directx_Jun2010_redist.exe or DXSETUP.exe. That is what is required. And yes, the toolset requires it, not the game.

DirectX 9.0c

.NET 3.5

(those particular versions of each are required)

i think the game needs Dx9.0c and perhaps it installed auto when the game was installed.

the toolset uses the 2.0-3.5 .NET framework extensively.

ps. I’m not familiar with Mac or Bootcamp, but there should be ways to check what you’ve got installed …

Boot camp means you are essentially running Windows natively so all actions would be the same as if on a PC. The Mac OS is on a separate partition.

How would I check if they were installed on a PC? I know very little about PCs.

I’ve checked again and there are no files in GoG games folder to do with Direct X .

well this is awkward. My Start|ControlPanel|Programs and Features doesn’t show .net 3.5

but it does show in my Registry

see also:

( some versions of Windows come with .net 3.5 installed but disabled )

if you are running Win10, it sounds like the Dx9.0c comes installed already

google “what version of directx 9.0c”

(note, running ‘dxdiag’ from Start|Run… displays only the highest version)


but some say not so fast, and added it:

Overall, I suspect that your Dx9c is okay and to get the toolset running you should concentrate on .net 3.5

ps. Welcome to Windows … o.O

I’m beginning to see what you mean…

Well, I followed the instructions, I think, and now I seem to have some kind of indication that .net is installed. See pic below.

However, there were only these two boxes to be checked and it still doesn’t work. I’ve also found a text file chronicling the installation of Direct X so I think it’s right that that is probably installed. so, i’m at a a loss. However, you’ve all been very helpful so unless you have a bringing light of revelation about what it might be short of reinstalling the whole game and toolset, don’t worry. I’m happy just now playing the game. It looks gorgeous at top resolution. I’m also loving some of the advances on NWN1 - the story evolving in the ( often quite lengthy) cutscenes, the attempt at character development, the real need to think a bit more about party composition, the gorgeous tilesets with realistic changes in elevation etc. Better story as well - I’m at the trial and that’s just a bit different.

I’m amazed at how well Boot Camp is working compared with WINE. The game is lightning quick and no crashes so far ( hides).

Final thought. If I were to re-download the whole .net 3.5 and install it would that replace what is there or screw up my whole game playing career?

one more thing i can think to try -> goto your Nwn2 installation folder and set the properties of NWN2ToolsetLauncher.exe


check Run as Administrator, and choose Compatibility Mode xp sp3


pls consider installing Nwn2Fixes to your <documents>Nwn2 /override folder – note that folder hierarchies are allowed and encouraged in nwn2/override

there are game-breaking bugs in the OC. A good idea is to make, and keep, saves at least once per realtime day.


uh, no. Iirc, you’d first have to uninstall your highest .net version and uninstall each version down to 3.5, then reinstall them back up to whatever version … if windoze would even let you do that … ie. bad idea

( .net isn’t the cleverest thing the Wizards at microsoft did – on the other hand you can be pretty confident its working ‘as intended’ ) repeat, don’t even try that. Because there IS a brutal versioning bug when reinstalling although i forget what it is … /shrug

Ps. yeah, Nwn2 did some things right but other things not so well, I still like it a bit more than 1

If you have problems with the camera i can set you up with something

Sorry, still no dice with the toolset. Strange one as @Kaldor_Silverwand seems to have managed it with Bootcsmp. Anyway, I’ve downloaded and am using the fixes. Thanks for those although I didn’t have any issues so far.
However,I now seem to have found one. In Act 2 in Tavorick’s manor I’ve sorted out the hostile sand am trying to make a break for the crypt with the old geezer. However as you can see from the pic my way is blocked by a ring of blue flames which I can’t cross so I can’t get to the crypt. I’ve reloaded a couple times with same result- the flames seem to appear early in the battle . Is this a known bug or am I just being silly?

Ok, stupidity personified. It appears I was heading the wrong way to the crypt. Ignore previous post.

Don’t know how I’ve got this far … :see_no_evil:

I think the Tavorick estate is my favorite part of the OC. It very much creates a mood and I love the guards that are sent to assist you. I remember always going out of my way to make sure they all lived because I thought they were fantastic.

Sorry. Random aside that has nothing to do with your problems. I am glad it was just an issue of going the wrong way.

Yeah, there have been three or four bits of this campaign which I’ve felt added a little something to the narrative.

I even like the growing sense from soldiers of respect for what I’ve achieved. It’s not in your face praise- it’s them being willing to fight alongside you. I enjoyed the trial - the night before when all my pals came to chat and offer to fight for me etc. through the faces in the crowd to the decisions at the end of the fight where I didn’t know if not killing him straight away would come back to bite me. Moonsea had the arena but I dont think it was as well done. It feels like a genuine party of friends I’m leading and I’ve started to feel sorry, like a football manager, when I can’t take someone with me !


Spoiler : example bug

you’ll be going to a castle. There will be a battle in the courtyard. Black Garius will be there and initiate a dialog. There are friendly archers on the walls. If an archer tags and hits Black Garius, his dialog breaks. That dialog NEEDS to finish

Nwn2Fixes should have it covered. But it also does stuff like tweak models etc etc

Heh. I almost always end up taking the people I think of as friends the most rather than who would actually be any good in the situation I am going into. And it does feel odd sometimes picking and choosing at all.

When you get to the first expansion, you will meet the companion that I bonded with so much I could never bring myself to play the evil storyline, despite many telling me it was great.