A tileset issue with Oriental_Rural (RESOLVED - SORT OF)

Hi everyone,

Recently I just discovered one of my areas in my module has a tileset issue regarding the beach sand and the rice field.

In the pics below…they both look normal in the tooset, but in game there are these dark patches on the beach sand and one on each side of the rice field/paddy…a type of shadow. These issues are found in the Oriental_Rural tileset. Never had them before…does the CEP 2.67 have a Oriental Rural tileset that could have overridden my tileset that is old and caused this issue?

hmm…my print screen of the pic I took in game is in tga format and I can’t upload it here.

But the above toolset image looks normal but the in-game has square dark square patches all over the sand.

Any idea what could be causing it to look like that in game? I tinkered around with shadows but nothing changed…and beaches in other areas with the same tileset does not have this issue…just this one area I found so far.


You can use NWN Crunch (or XnConvert) to make png or whatever from tga - worthwhile additions to every modder’s toolkit.

1 Like

Or ImageMagick! (yeah, command line tool)

BTW, I always share game screenshots as jpegs; they have the best quality-to-filesize ratio among the “normal” allowed image types (i.e. not based on video codecs).


Or just load it into your image editing software and “save as”/export as whatever format you want. I do tend to use XnConvert myself though. As far as formats go I tend to use png although I have tried gif which as far as I’ve seen produces good, really small (byte-wise) images of NwN stuff too.


1 Like

Whats the name of the area?

1 Like

Hi Mmat,

Thanks for asking…I know you have a copy of my module and haks. The name of the area is: “Hinomoto Island (10 miles from Omitsu Wan Village)”. I know mouthful.

If you look in the toolset it looks normal…but in game you will see the beach sand has these dark shadow squares and the ricepaddy right beside it now has a dark shadow square on each side.

Hi Proleric,

I downloaded the NWN:EE Crunch from the vault here:

I tried to execute the .exe…but it won’t…

And thanks too for letting me know about this. I just have to figure out how to get it to work and convert images…but I did not read how it converts tgas to jpeg…because when I do a “print screen” in game it converts it into a tga in my screenshot folder.

Also, is it possible that the Oriental_Rural tilset uses some tileset parts from other tilesets that a CEP tileset could of overridden?. Remember I do not have tileset packages (haks) that sit on top of each other. I have 12 haks. Each hak has its own stuff in it.


From the manual

That means you need to run Command Prompt then enter e.g. convert_png as a command.

I can’t open this program is what I meant. What you said above I do not understand…lol. For example when I downloaded a program like “TGA Flipper” it created a desktop icon…where I can click on it and then it would open up a program where I can use it. When I click on the nwn_crunch.exe…no desktop icon pops up to run a program.

Command Prompt is a Windows utility.

You can Google simple descriptions of how to use it.

No need for command prompt. Just put the images to convert into the “in” folder and then double click on the convert_png batch file that comes with it.



Ok…I will try that…thanks Tarot_Redhand

The converted files should appear in the out folder when it’s finished.


Excellent…it worked!!..I had to create a “in” folder first then it created an “out” folder. In went a tga from my screenshot folder…then I clicked on the “convert_png.bat”

bam out came the .png

Thanks Tarot_Redhand

here is what the area looks like in-game -compare to toolset image up at top:

Also note the weird look in the rice paddy field…the fan-like spokes in the water and the shadows on the sides:

Mmmmh …

For me, everyting looked quite nice (ingame). There was just one thing missing, that’s the boy who serves cold drinks.

But then I detectect this effect:

As you can see, on the beach is nothing. But A puddle on top of the hill, which can only be seen near this position and perspective? Weird. This requires further investigation.

What the snot? Really? in my game it looks like the image above…but then again I made some new changes since I sent the link to my onedrive. hmmm…I’ll have to ask my other players if they see what you see or what I see.

lol…that puddle at the top looks like your keyhole feature.

Want me to send you a link to the new module and haks on my onedrive? I do have them now compressed (RAR) format…

Thanks for looking at it though

By now I’m engaged in the CEP-Project and don’t have the time for intensive searches of this kind anymore. Sorry. Maybe somebody else might have a look.

As for the tileset-issue: Installed on a fresh module, there are no issues with this tileset, no black patches on the beach or puddles on the hill (I’m working with NWN 169 though). At last we can not be sure, that there are incompatibilities with the EE.

The only thing I found out, is that the autor dropped a note in the readme, concerning some unsolved shadow problems. Well look for yourself.

Mmat, are you testing using NWN: EE? If so, your pic just looks like the normal keyholing with that version and not “water”. IE, its looking beneath the hill edge into nothingness. Gah … nevermind, just actually read your last post. LOL

Ok…so when you looked in my module in that area you saw no such black patches then? You look in it with 1.69 or NWN:EE when you loaded my module? Just to make sure I understand.