Altered pause1-animation leads to wrong angles for the other animations - how so? [SOLVED]

I’m porting a Witcher 1 Noonwarith atm. For this I’d like to have a fitting animation: They are floating (most of the time). My first try was to scale c_fairy and basically that worked for “non action-“ animations. But many of the fairy attack animations don’t work when scaled to human size: Flies super large curves, flies into the ground, …
So I remembered an alternative flying human model: The CEP flying succubus (wg_succubus2.mdl). In the Witcher game, the wariths (and some other) float upright during the IDLE-animation (NWN1: pause1), whereas the CEP flying succubus has a more horizontal position. I want to change that.First try was to copy in my scaled upright c_fairy pause1-animation. That basically worked, except that now ALL other animations are flipped 180°. I was not able to find the reason to this, so I took another approach:
I altered the pause1-animation of the original CEP wg_succubus2.mdl to be an upright position and it (kind of) worked:

Strange thing is, that the walking animation is not horizontally anymore (as it should be), but at an about 45° angle:

That looks pretty well and I like it, but problem is now the dead-animation is at a wrong angle (meaning all other original animations are at a wrong angle, but NOT the altered pause1):

Opening the model in Blender or Gmax (tried both - exported from both) show the right angle when choosing the according animation (example: walk):

Remark: I set all animroot-entries to rootdummy.

Can someone explain that behaviour to me? I mean, I altered the rotation of the pelvis in the pause1-animation to get the model upright (that angle is recorded in a key). That seems to influence all the other angles.
Any idea how to fix that?

Sounds like the rootdummy got rotated when you adjusted the animations, throwing all the others off. What I would do is go back to the model before you tweaked anything, select the rootdummy, hide all other meshes, and watch to see how the rootdummy moves when you run the animation cycle. Then do the same for your adjusted model and see if the rootdummy changes orientation.


Yes, that was it! Thanks! I somehow always manage to grab other objects while tweaking/adding animation keys! The hint with the “hide all other objects” is a good one, which I never did before - probably the reason why I tend to miss-select an object…
Anyways, I got it (after some more fights and wrongly placed key-values…) all fixed now! Couldn’t resist to try the Witcher 1 Wraith (which uses its original Witcher 1 weighting following the process I decribed in my tutorial)! It’s not finalized, but here is a WIP screen (mesh is using the succubus2-bones):