Animation question (is it a bug?)

I have a scene where the whole party is supposed to be digging. I’m using shovels from here:

https://neverwintervault.org/project/nwn2/model/mwm-shovel-club-hak

For some reason when I play the shoveling animation, it looks good on the PC but not on the companions. It looks like in this picture here (the companions are not holding the shovel right):

I wonder why this is, and can anything be done about it? Thanks for your time!

Are the companions non-human? Is the item type set to club in the blueprint?

1 Like

All are human but one, who is a gnome. The item type (if you mean Base Item in Properties of the blueprint, that is) is set to club, yes.

EDIT: I use the function EquipNewItem that’s in the include script ginc_item, and then I have scripted it like this:

void PlayCustomAnimationVoid(object oObject, string sAnimation, int iLoop = 0, float fSpeed = 1.f)
{
	PlayCustomAnimation(oObject, sAnimation, iLoop, fSpeed);
}

void PlayShovelAnimations()
{

	object oPC1 = GetFirstPC();
	object oFM = GetFirstFactionMember(oPC1, FALSE);

	while(GetIsObjectValid(oFM))
	{
		PlayCustomAnimationVoid(oFM,"shoveling",1);
		oFM = GetNextFactionMember(oPC1, FALSE);
	}


}

Only human-based creatures can use the shovelling animation correctly, gnomes and dwarves are too small.

OK, but all the companions looks wrong with this (as you see in the picture), not just the gnome.

EDIT: I thought it might have to do with me changing the size somewhat to 0,95 on one of these human characters, but when changing all to 1;1;1 the animation (or holding the shovel that is) looked the same as in the pictures, so apparently that had nothing to do with it.

You might be better off making your own shovel item. Then you just need to equip it and run the ‘shoveling’ animation on the characters.

To create a shovel item…
Right-click anywhere in your blueprints panel.
Select ‘create blueprint’ and ‘module’ or ‘campaign’.
A new blueprint with the name ‘item1’ is now available. Click on it to see the properties.
Change the ‘base item’ property to ‘Shovel’ (or rake if you want another tool).
Set the ‘icon’ property to something that looks like a shovel. Maybe one of the widget ones?
Make sure the identified property is TRUE.
Set the localized name to Shovel.
Set the resource/tag/resref to i_shovel or whatever you want.
Right click on the item in the blueprint panel and select ‘Save to file…’. Save it over the same-named file.
Now just add it to the character and equip it. Then run the shoveling animation.

1 Like

Eh…that’s what I’ve already done.

Only, I didn’t quite do it the way you described. I instead copied another custom item of mine and changed everything sort of the way you described.

The only difference is that the base item is Club, since I thought that was what was required for the MWM Shovel to appear ingame. But sure, I could try that too, I guess (even though I think I might have already tried that, I don’t remember).

Oh, sorry, the size of the shovels threw me.

I tried changing to shovel as base item, but now my characters can’t use them since the apparent size of the shovels (probably also what you meant in your post). Maybe one can choose another sort of base item?
I’ll try with Quarterstaff and see what that does…

EDIT: Choosing Base Item Quarterstaff makes the shovel model not appear ingame…ok, I’ll try and investigate further.
EDIT2: Seems that the model is set to club and only appears if you choose club as Base Item. Maybe I could change that in the baseitems.2da…

EDIT3: Seems like I only (I believe) need to rename the MDB file that is now called w_club76.mdb to something that makes the thing show up as number 76 under model under another base item…but I don’t know what to call it. Maybe just w_quarterstaff76.mdb or something? Maybe @4760 knows about this?

EDIT4: Ah, it seems that it is to be named w_staff76.mdb. I’ll try that.

EDIT5: Ok, tried it and it sort of worked. I could choose model 76 and use Quarterstaff as base item, but the animation still looks the same. It looks great with the PC but for some reason the companions won’t grip the shovel with both hands. And this time the gnome didn’t have a shovel at all, whereas before he had it the same as the others, probably because it was a club and not quarterstaff before.

Is it because a club is a one handed weapon ? Maybe the animations were sorted for a human to treat it as two handed weapon but not the rest of the races.

And your gnome is lazy too.

1 Like

Again, my companions are all human, except for one at the moment, and yet the animation only looks right on the PC. If I change it to quarterstaff, which is two handed, the animation still doesn’t look right. It looks the same as in the picture. The animation works but they are only holding the staff in one hand during the animation, though when just holding it they are using two hands.

Sure, my gnome is lazy. All gnomes are lazy.

It’s frustrating since I thought it would work when I had changed the mdb file to w_staff76.mdb and the model showed up in the toolset, but things are never this easy in the world of building for NWN2.

Alright, now this is actually comical. I found another usable shovel on the vault here:

https://neverwintervault.org/project/nwn2/model/usable-shovel

Now, with this one, it looks good on all the companions, the gnome included, but now it’s the PC not holding the shovel right. So what I’ll do is make a shovel with the mnm_shovelclub for the PC and the others get the other kind of shovel. It’s weird, but this way I’ll be able to solve this at least.

This is how it looks now (the PC has a much larger shovel than the others, but who cares, as the animations work this way now):

2 Likes