Animations in Conversations (Resolved.)

OK, I feel like I should not need to ask this, but due to the hit and miss results I have, I decided it was worth the question … How do you “add” animations in a NWN2 conversation that work reliably?

As I say, I have had mixed results. I can even setup a “duplicate” animation on two different NPCs (one human and another an elf) and one will work and another will not. I have tried adding via the drop down within “node” and even tried adding via the dedicated “animations” tab. (I have found the latter works with some.)

However, I find I am struggling to have any animations work with an elf character I am currently writing for. Are we to assume every elf has a “Spock” like personality?

Perhaps I am missing something very simple, so any advice to make these conversation animations work reliably, and you have my thanks.

EDIT: OK, I know the elf can do the animation, as I applied one via the ga_play_animation command. So why do the conversation command elements not apply the animations?


I’ve found that animations work for the most part for me. Then again, there have been bugs of course. In the latest module I’m currently working on I’ve used custom scripts for animations. For example, in a dialogue I had one of my characters duck. The script is a simple one and looks like this:

void PlayCustomAnimationWrapper(object oTarget, string sAnim, int bLoop)	//so it returns a void
void main()
object oPC = GetObjectByTag("loreen");
PlayCustomAnimationWrapper(oPC,"idlecower", TRUE);
DelayCommand(0.8, PlayCustomAnimationWrapper(oPC, "%", FALSE));


And in another dialogue I used the animations node (or what it’s called) under the conversation and I used the “salute” animation. This was a companion elf by the way that did the salute. No problems there.
And then I’ve used custom animations from 4760 with (seems to me at least) quite complicated scripts that he also made. Those animations work almost without any issues too. Well, there can be timing issues when they have had to move to certain places before beginning the animations, but mostly there are no bugs here.

I don’t know if this answers any of your questions but at least that’s what I’ve experienced.

1 Like

Hi andgalf,

Well, I think I got to the bottom of the issue … well, for now anyway …

It seems that because I had had the NPC walk up to the PCs, the forced walk script somehow “locks” the conversation method of initiating animations thereafter. However, once I had played at least one animation via the “ga_play_animation” scripted method (similar to your own script there), I found that the conversation animations thereafter started to work again! Hoorah!

So, your own comment appears to reinforce my own findings, so thanks for your feedback! :slight_smile:

There must be something about the fire and forget usage of an animation via script that thereafter unlocks the animation ability within the conversation animation section.

Cheers, Lance.