Armor Set - color wont change


#1

I have this thing that has eluded me for a while now. I have an air genasi character. Her skin color is blue. When she wears certain clothes I want her skin tone to be blue all over, not just the face. So when choosing Armor Set I change the color in the first slot. However, this wont show up in game. I don’t know if there is some other things I need to do for this to work. I’ve even tried with Apply To All.


I have even tried to create custom armor and change every slot I could find in the blueprint for the item, to change the color of the skin for the hands and what-not, but nothing seems to work…


#2

Ok. I guess I’ll just have to settle with changing the skin tone instead. It’s not as good, since it affects the face also, making it slightly darker, but at least I can have shoulders and hands that are somewhat of a similar color as the face when doing it that way.


#3

She’s not wearing any armor set parts, so those extra colors aren’t going to do anything. Try the tint in the other two slots; that armor doesn’t have a tint map in the first (red) band. Also, if you’re running this in Windows 10, the color may not show up right away in the render window – try selecting another blueprint then go back to that one.

armor


#4

Yes, the other two slots always change the color the way they should but not the first. So, if the armor doesn’t have a tint map in the first it wont do anything then? I just found it strange that in Armor Set the color does change the color of the hands when changing the color in the first slot. I thought it shouldn’t do that if what you are saying is true. But maybe that’s just a glitch in the toolset.


#5

I think it’s a design limitation of the engine. The body uses multiple parts with different tint maps. In the armor/skin case it looks like they collide tint-map-wise, so the tints have been limited for each. (If you look at the Properties tab for the creature there are two tints for armor and one for skin; hence using all three red-green-blue colors in the tint maps.) Not sure why they did it that way, unless it was to address some sort of memory issue. The armor and skin maps are probably the largest texture files for creatures.


#6

So when choosing Armor Set I change the color in the first slot. However, this wont show up in game. I don’t know if there is some other things I need to do for this to work. I’ve even tried with Apply To All.

could you please explain what you did there exactly? because that’s not how the engine works. the red tinting channel should be overwritten with the selected skin tint. this won’t show up in the toolset but ingame. this works with equippable items and the creature’s armor tab, both for pcs and npcs.

the left genasi wears an equippable monk’s outfit with activated gloves (naked) - the red channel is tinted white. the genasi in the middle wears no item, instead the armor is manually set to naked with activated gloves and the red channel tinted white too. on the right the armor is also set to naked but the red channel of the gloves is tinted red. all three npcs show up ingame with the correct skin color.


#7

This has probably got to do with that I don’t know exactly how the engine works, with the tint maps and everyting. I probably should have read in the manual about this :slight_smile:
I’ve just fiddled with the toolset here and I was just baffled by what I saw in the Armor Set and that it didn’t match what I saw in game.
Maybe the thing is that I used Default(Cloth) and not using Naked? I don’t know. Maybe I could try it.
I’m also using a face from this guy: https://neverwintervault.org/project/nwn2/hakpak/original-hakpak/faces-neverwinter-project
Maybe that has got something to do with it.
As usual when fiddling around with the toolset I don’t exactly know what I’m doing, but I’m still having fun :smiley: (at least most of the time).


#8

I’ve just fiddled with the toolset here and I was just baffled by what I saw in the Armor Set and that it didn’t match what I saw in game. Maybe the thing is that I used Default(Cloth) and not using Naked?

what did you actually see ingame? did the hands match the skin color? i still don’t know which parts of the armor you tinted in your second picture. you set the red channel of the chest armor to blue which should not change the color of the gloves. did you tint them also?

btw this has nothing to do which base armor type you chose in the armor set tab. the gloves are a separate model and can be set to work alongside the chosen armor appearance.

in case you didn’t know: the armor set tab of a creature does not equal the armor they’re wearing. it’s just changing the visual appearance of the model. if you want to give your npcs an armor you have to equip those items through the inventory setting.


#9

This I know.

Yes, the hands did match the skin color (them being default white) since I didn’t want to change that, since if I do that, I think I already said that in one of my other posts, the skin tone of the already blue face gets to be a darker blue. I did not however change the color of the gloves, so that could be it in this particular case. The Default Cloth in my picture was just an example. What I really wanted was to be able to use that first slot to change the color, so that all skin that is not covered by armor would show as the blue color I chose (in all kinds of armor that I chose, I would then create an armor that looked like how I wanted, create a new item and put it in the inventory and equip the character with it). As for instance in this picture here:

However, when I opened the toolset just now to show this picture, the first slot was white although I had changed it to blue before, so I think that might be a glitch in the toolset the way that rjshae described it. I think the only way one should or could do this is by changing the skin color, and that shows up in game, unlike what’s seen in the picture that doesn’t show up in game. As you might understand by this picture and this particular armor I want both the chest area and the hands to have this blue color, thus changing just the gloves color wont do it here.

Here’s what it looks like when the first slot is white…


#10

What I really wanted was to be able to use that first slot to change the color, so that all skin that is not covered by armor would show as the blue color I chose

then you don’t have to do anything besides choosing the skin tint. actually you can’t change the red channel of armors and gloves (perhaps boots too), because that channel is reserved for the skin tone and will be overwritten.
that’s no glitch with the toolset, that’s how the engine works to guarantee flexibility.

custom content creators have to use the red channel for exposed skin so that the system works correctly.
if there’s no skin visible, they better not include a red channel in the tint map, because this will always be influenced by the skin color, therefore changing the appearance of the armor.


#11

Yes, and there in lies the problem because then the face gets to be a darker blue, and I don’t want that, but I guess there’s just no way around it.


#12

Yes, and there in lies the problem because then the face gets to be a darker blue, and I don’t want that, but I guess there’s just no way around it.

that’s because the majority of content creatores don’t factor in tinting. they fully color their textures which may look nice by default, but hampers the ability to recolor drastically. a simple fix would be to open the face texture of the used head with an image editing software and desaturate it to make it look more washed out / neutral.


#13

Yes, you’re totally right about that. I actually did that with a face in my previous module (that hopefully will be released as soon as a friend has beta (or maybe it’s an alpha) tested it) but I’m not sure I want to go through all the trouble this time around. I think I’ll just use some clothes that don’t show any skin and maybe use gloves.

Anyway, thanks for trying to help!