Avoiding The "Black" World Map


#1

Hi All,

UPDATE: This FIX also works for Windows 10. It’s just been a long time since I last needed to do this, and I have even updated from Windows 7 to Windows 10 in that time. :slight_smile:

While working on my latest module, I was reminded of a problem I hit a few years back (when last working on it), and the workaround I discovered at the time. The following info comes from an old blog post of mine back in June 2010, which others may find useful: -

If you have ever tried to view a TGA or DDS world map image with the map editor, and you are using Windows Vista or Windows 7/10, then the chances are you will only have seen an empty black image. I noticed this myself after I switched to using a Windows 7 computer instead of Windows XP. (And still have it with Windows 10.) This is a problem, because you need to be able to see the map in the editor to place map icons on it in the correct place. Here is the workaround to be able to see the map in the editor:

  1. Load the NWN Toolset. (Do NOT load the module yet.)
  2. Load your world map in the editor. (You will still not see the map image yet.)
  3. Reload the map image you are using into the map editor. (The image should now show.)
  4. Load the module and continue working on it.
  5. You will need to repeat this process each time you load a new map into the editor.

Cheers, Lance


#2

This ALSO applies to WIndows 10.


#3

Hi VIC,

That’s what I am using nowadays. I found the same fix I used when switching from Windows XP to Windows 7 also still works in my Windows 10 setup. It’s been that long since I worked on this area of the campaign. :blush: I have updated my original post to reflect the fact that it fixes the same issue in Windows 10 now.

Cheers, Lance