Bake Problem... Maybe?

Running into an odd issue… I’ve finally gotten back to and a bit beyond where I was when the toolset crashed and corrupted the mod I’m building back in October. But now, I’m at a point where when I try to bake the current area I notice some odd behavior of the toolset.

I tell it to bake and get the pop up saying it can take a long time, do I want to continue? Yes, I confirm the command to bake. Here’s where it get weird, I always get to the same point:

Phase 3 - Stitching placeable walk meshes (515 of 723)

And it just stops… That’s it, it just cuts out and ends. The toolset locks up for about 5 to 7 minutes then functions normally again. I am able to run the mod afterwards and enter it with a character, no problem. The only fault I can notice is that there’s an area in the mod where I’ve painted some grass and weeds in an open area, but these don’t show up in game.

Is this a known issue? Or just another toolset gremlin that has been plaguing me from the start of this build?



No I’ve never run into a problem specifically like that. 723 is pretty huge though – I get 94 for a sample 32x32 exterior area. How big is your area, if I may ask?

@rjshae, thanks but it seems to have resolved itself (fingers crossed!) I tested it this morning and the area looks fine. It is a fairly large area, 24 x 22 IIRC. However it is VERY, VERY, VERY densely packed with placeables, trees and undergrowth in particular. Additionally, I’ve used the walk mesh cutter to put in specific paths to walk on, so the whole area is not open and the player can only follow certain designated walking trails. I’ll post a few screens when I get home from work later today. However, as of this morning it seems to have become a non-issue.
Thanks again.

You should ask @raymondsebas about this.

i am just guessing here, but it sounds like what you’re doing is really taxing the engine. if i am wrong, then please ignore the following:

  • convert as much placeables as possible to environmental objects. everything that isn’t needed for interaction or blocking sight is a good candidate.
  • outdoors use walkable/non-walkable brush texturing rather than walkmesh cutters for the majority of the area. this directly uses the terrain mesh on a simple triangle basis.
  • use walkmesh cutters only where a detailed walkmesh is needed. like around circular placeables which don’t really fit or are misaligned with the terrain’s grid.

I saw that @Ariane has invoked my name on the subject…

I can confirm that @Semper is 100% totally right.

95% of your placeable stuff should be converted to Environmental Object {EO}, unless they have a direct purpose or interaction withs players (like a chest for example…).

You can build an entire citadel with the BCKII and the vanilla object, turn them all in EO, make sure all corner are walkmesh cutt, just leave the frontdoor that contain the gate in a placeable and even then everything should work like a charm.

See this post exchange that I have with @FaerzressSparkles to have a better idea if my explanations are not clear. :


@Ariane, @Semper, & @raymondsebas, TY! I’m still very much a noobie to using the toolkit. The pointers and advice are very much appreciated. Next time I work on the mod, I’ll convert as much as I can to environmental objects. After this area I only have to more interior areas to build. Then a few rounds of testing it will be ready to post.

Thanks again!


while this visually works, there won’t be any collision meshes around to block sight. afaik that leads to some silly occurrences like spells or arrows flying right through them. of course this only happens with enemy encounters in the area.
one workaround could be to use collision boxes with the right scale to cover those environment objects.

Indeed, only leave the placeable that have a “direct impact” on the gameplay as you just said (the example you just gave is a good one). This is what I do in all my modules. You can see this on my BG City, Beregost, Candelkeep, Friendly Arm Inn areas (and so on) I which I made available on the vault here. Have a nice day and take care ! :grinning:

1 Like

Agree with above, per Semper. Also, when I use interior walkmesh cutters I try to fit multiple objects within the same outline and minimize smaller concave walk areas where possible. You should really only need 2-3 cutters per grid square at most. There’s a hard limit of ~127-128 walkable mesh faces per grid square, and complex cutters will chew those up.

1 Like


Thanks very much for the advice! I worked on the mod a bit last night and converting most of the placeables to environmental objects worked like a charm! But now I have a few more questions… I think I’ve figured out NOT to convert any placeables that have scripts attached to them, seems like the scripts will be lost and the functionality of the object will be eliminated.

I’ve noticed that I cannot convert shrubs to environmental objects, true? What about objects like chests or barrels that may have contents? Can they be converted without loosing their content? How about placed effects like lightning bugs or placed sounds…? Are they convertible?

Sorry for the ton of questions, but like I said, noobie here and trying to learn what I can to use the toolset to the best of my admittedly limited ability.

Thanks again for all the help,



Anything that has scripts or objects inside it is objects that interact with players and you don’t have to convert them. But if you put a barrel as a decoration (there’s nothing in it, it’s just there for the appearance), then you convert it and walkmesh around it after.

No tree, store, wp, sound or light are not placeable, so no conversion. You can’t do it anyway.

1 Like

note that if a Placeable is converted back to a non-environmental object its vars get wrecked …

eg: 0 hitpoints causes probls. (scripts won’t run on it, etc)

so give it some Hp at least if converting back

there could be other things that need tweaking such as the Static property …


Indeed, a small important detail for those not used to the NwN2 ToolSet. :grinning:


That issue always sends shivers down my spine!

NEVER FORGET … but I sometimes do, (because it is done rarely) and it becomes a real pain!

Cheers, Lance.


I’ve solved the bake problem with the help of the community but now a new one has cropped up… I can no longer open the area I’m working on. Every other area opens just fine and the mod runs perfectly, I just can’t get into the area I need to. The toolset just crashes every time I try to open it.

Any suggestions?


I’ve only seen this happen in big areas and generally speaking areas with a ton of placeables and trees. I have the problem in my main city area and usually, what will work, is restart my PC and open the area without any other programs running. Also, don’t do anything while it is opening. Drink a coffee or something but don’t try to surf or whatever.

It could be nonsense, what I’m saying above but hey, it works for my area :blush:

Edit: if you manage to open it, do NOT close it by right click it and picking the save option. The toolset will 100% crash. Instead, save your module. The area will be saved with it. Then close the toolset and reopen before doing work on other areas. Any time it crashes you risk corrupting files in my experience.

1 Like

If none of the above work . . . Export that one area, start a new project and then import your area. Add a start point and see if it opens.