Beamdog HD Pack with Fixes

The Beamdog HD Pack has been updated to 1.4. This is only compatible with NWN: EE.

We have a Project wiki page which details all the alterations, and information about installation and what is in each builders version.

Feel free to post here or contact me if you want to help or join us on Discord. The project is only cleaning up the existing models Beamdog released, but if you want to add new “HD” models to a future additional pack separate from this one we are looking at doing that as well.



  • Horse phenotypes fixed (note this is done by duplicating 14K files, around 685MB extracted but very little added to zip size). userpatch.ini has an additional .hak file for this. - Jasperre
  • Phenotype positional fixes for most female and “fat” models that should fix the alignment issues between parts - Tjured
  • Fixes to various models with gaps in their geometry (such as Dwarf and Elf, females) - Tjured
  • cloakmodels.2da adjusted to match base game functionality regarding showing shoulder pads for some appearances where the shoulder is uncovered - Jasperre
  • Robe shadows added for all models (copied from the base game robes) - Jasperre
  • Some female human phenotype 2 robe oddities fixes that may solve some phenotype oddities - Jasperre
  • Several PLT Fixes where layers were wrong - Winternite
  • A few Gnome and Halfling “fat” heads added generated from the normal versions since they were omitted by Beamdog - Winternite
  • Helmet PLT fixes so they correctly display colours chosen for them - Wolf and Winternite
  • Tattoo 1 now defaults to brown eyes for NPCs to go along with the tattoo 1 = eye colour improvement on head models - vapidchap


  • Tjured’s shadows (except robes/cloaks)
  • Tjured’s model adjustments (female heads, pelvis positioning/sizing, phenotype 2 resizing)
  • Jasperre’s model fixes - hundreds of minor issues (classification fixes, non-existent or broken MTR references, bitmap reference issues, ambient corrections, correcting some gnome skinmesh heads back to trimesh, some robes, and many, many more).
  • Jasperre’s file cleanup - over 200 redundant files removed. This includes most 2da files except cloakmodel.2da. (others include unreferenced models, test items erroneously included, and extra hand models - available in the Additional Zip)
  • Jasperre’s compile - compiled all the models again to bake in normals/somewhat improve jittering
  • Jasperre’s DDS - all TGA files (primarily weapon icons) in the final compiled version are now DDS
  • userpatch.ini version for much easier install


  • All models compiled so should load faster
  • Removed some unnecessary models and textures
  • Additional model fixes
  • Tattoo colours affect eyes of heads


  • Some model fixes such as short swords appearances 21-24 (upside down blades), pmh0_robe003/004/006 (robes not looking correct), pmh0_shinl010/pmh0_shinr010.


  • Initial Beamdog release.

Just giving props to this incredibly helpful project. The original release had a lot of issues and I’m looking forward to using the improved version.

Great! I think I’m happy it’s in a decent place now and usable with only one or two glaring errors we’ve noticed (check one of the halfling heads, the goggles one!).

There’s still improvements to come such as trying to fix stuttering which are caused by larger PLT textures, cloak and robe shadows and adjustments, horse phenotype copies of models due to skinmesh inheritance bugs, and people have some ideas on some tweaks to the model appearances to make them a little more inline with the originals.

Awesome, downloading now!

1 Like

Just bumping this next version will have a beta available. There’s going to be known bugs but I do want some performance testing if you have a lower spec gpu and CPU so we can get an idea on the lower end it’d support. Catch us on the vault discord!

Can anyone help? I think I have the Beamdog HD issues and don’t know how/whether to uninstall the pack or apply a fix.

Character used to look like this in game.

now he looks like this in the toolset

and this in the game . . .

1 Like

Are you using the latest version? (1.3) Are you subscribed to anything on the workshop or have any other override content?

Tbh looks pretty much like a 1.0 bug.

That is indeed a 1.0 issue that was addressed for 1.1, and further improved for the 1.4 release.

The best I can recommend is completely purging the data that contains the HD pack, and then reinstall the 1.3 version.

If you mean the fixes then no I haven’t downloaded them. I have no idea how I got the pack as I wasn’t aware of downloading it although my game is through Steam so maybe it has auto downloaded as it does with all the NWN versions ?

How do I find the data containing the HD pack to delete it. Alternatively would it be better to download your fixes?

I know there were several other ways to install the Art Pack, whether from Beamdog via some installer, or on the workshop.

I imagine it’s the installer one that made its way to your PC, I have never used it or anything so not sure how to uninstall it, but I’m sure there is someone on here that has experience with it.

In hindsight the art pack wont install itself by default, it’s something that will have to manually be pressed on for installation.

The files should be somewhere in the steam folder if it’s not in C:/documents/nwn

Ok, thanks. Will have a look. Is the issue not one that will be sorted by using your fixes then?

What would the files be called?

Yeah we fixed the particular issue you described, but need to ensure you have the older version uninstalled first to not cause some conflicts

Depending on how it was installed, it would be many files overriding existing bioware assets (models for races, genders, phenos, armor, helmets, some weapons, etc)

The best place to start is the good old c:/documents/nwn see if anything is in override, development, hak folders.

If the nwn folder in c:/documents is fine then it must be in the steam one, but again I don’t have experience using other installation methods (workshop, beamdog installer) so hopefully someone else can shed more light on exactly that.

@jimdad55 if you are on Windows and installed the official HD pack, Settings > Apps will let you uninstall it like any other Windows app.

Thanks, Proleric. Unfortunately I’m on an iMac. Checked the game folder ( hak,development, override etc. but no sign there. I’m guessing Winternite is right and that it is somewhere in the steam files which are in a different place but there are so many of them.

Can you give me the name of the main folder or maybe one of the single files so I can search for them?

Try searching for pfh0_chest001.mdl

There was no installer for Mac so you might have just dropped them in a folder like the games /ovr or got it off the steam workshop (which is in some subfolder of the steam foldeR).

If you’re subscribed to this page

simply unsubscribing should remove it.

This is assuming that the game installer for Mac on Steam isn’t forcing it on you (the Windows version doesn’t).

Ok, thanks. Will try.


  1. Did a search for the filename Jasperre gave me. No result. Would make it seem I hadn’t downloaded it.

  2. Did a search on Steam, found the HD pack but the button was allowing me to subscribe. Would seem I hadn’t already downloaded it.

  3. Went to my library on Steam and these are all the downloads for the game in the last while.

Which makes it certain that Steam auto downloaded it for me as when I go to properties it is set to auto download as soon as any new update is available ( which btw I thought I’d switched off !) In which case why can’t I find the file?

If I hadn’t downloaded it why is a character that was working fine last time I tried it now impossible to display properly. Tried a clean module and no dice.

There isn’t any auto download of the HD pack on any platform, Steam will never supply the files (except by workshop I guess).

I’d recommend just installing the userpatch.ini version of the 1.3 community edition which should just work and fix the issue.

Ok. I will. Thanks all for your help in this.