Beginner problem with conditions and actions in conversation

Hello everyone!

I have some problems with conversations. I created a conversation, wanted to add some conditions, selected a script (for example gc_check_race_pc). If I understand correctly, I had to see the parameters for this script to the right of the button “refresh”, but there was nothing. But if I change (not add) the scripts in original campaign, I see the necessary lines.

image

Maybe I didn’t do something important, but I didn’t find any information about this problem. Reinstalling doesn’t help.

I hope, you can help me and I won’t be surprised if the solution is incredibly simple) (sorry for grammatical mistakes)

Did you push the refresh button?

Yes, an error occurs “Script failed to compile”. This happens with all scripts.

Please provide more information then.

What version of the game are you on (language, version number)? What the OS are you using?

1 Like

Ah, hello, @Aqvilinus! Welcome back! Thanks for all the help you’ve provided in the past! :slight_smile:

@Metalwinter Have you placed the gc_check_race_pc in the slot for Conditions? Just checking, 'cause if you haven’t done that, if you’ve placed it on Actions, that may cause problems.
I just tried adding gc_check_race_pc myself in a conversation in the toolset, and there were no problems there. Just as Aqvilinus says, I think we need more information.
I find it a bit odd that you get “Script failed to compile”. In that case it sounds to me that you have opened and tried editing the script.

1 Like

@Metalwinter Even if I open the gc_check_race_pc script in the script editor in the toolset, I can’t even compile it, since it’s a stock script, so I have no clue as to what you have done here.
Edit: In your picture you have two instances of gc_check_race_pc. Why is that? Maybe you wanted to do an “Or” to check for two different races?

@Aqvilinus @andgalf Version in game 1.023, Russian language, Windows 10. But in launcher my version 0.95 (I don’t know, what you mean))
image

I placed gc_check_race_pc in Conditions, in Actions I tried to place ga_destroy_item and got the same result.

In my picture I wanted to show, that adding the script has no result, but when I replace the script from campaign all is correct (but I didn’t check it in game).

I will describe all my actions: I choose a phrase, go to the “Conditions”, “Add”, select required script from scripts list. And I don’t see the parameters. If I click “refresh” I will see this window:
image

If I copy the text gc_check_race_pc in new script and click “Save and Compile”, I receive image

So strange things)

That’s really odd. I have never received the box with “The script failed to compile” when pressing Refresh. At least I don’t think so. I can’t remember the toolset ever doing a thing like that. I wonder if it has to do with you having the russian version of the game? It shouldn’t make a difference, but who knows. I think @Rashi have the russian version of the game, so maybe she can help, I don’t know…

Well, 1.023 is the latest version of the game. Another question regarding this: Did you buy the game on GOG or do you have the old discs? I have both, but I’ve tried installing on Win 7 and 10 with the old discs and that will cause a number of problems. When installing the GOG version on both my laptop and my main PC, both with Win 10, it has worked like a charm.

Edit: I don’t normally load my game from the launcher, but I just checked and there it also says version 1.023, so it’s odd that you have version 0.95 of that.

Edit 2: Do you have anything in your Override folder? Things like that can cause problems if you’re not careful.

1 Like

Well, I have the old disc. I will try the GOG version, think, my problem will be solved. And I don’t have anything in Override

Thanks for the quick answers)

1 Like

@Metalwinter

You should always push the Refresh button to ensure the parameter boxes for that function appear. Then you need to add the parameters in the empty boxes that appear and then save it.

However, if I am understanding you correctly, then it sounds like your conversation may be broken. ie. Delete the conversation and start again, and make sure you use a new name for your conversation script to be sure. So try this …

  1. Delete the conversation where this error occurs.
  2. Write a new one, add functions … and use Refresh (and add parameters) before any saving.

This should not normally be necessary, but worth trying in this instance.

EDIT: Also, you could answer “YES” to remove all parameters in case you had a different function there previously - and it needs refreshing to remove those that are not used or required, and updates for the current function being used.

Hopefully that should work for you.
Let us know, Lance.

1 Like