Bishop Missing during Suken Flagon fight

I am playing NWN2 Complete Edition that I purchased from GoG for the first time. I have played and beaten the game many times in the past. It is version 1.23. I have progressed through Blacklake and saving Sandra, and after resting back at the Sunken Flagon, we are awakened by an attack by the Githyanki. After the fight there is supposed to be a conversation where we talk about Sandra getting kidnapped, looking for clues as to where she was taken, and Duncan calling a favor in from Bishop to take you to Ember. Bishop joins the party, we go to Ember. However, in my game, Bishop is missing from the Flagon during this fight and only the first like of the very long conversation is said before the conversation stops. Ember is added to my map and all Duncan will say now is to watch out for Bishop. Bishop is NOT in my party (Either selected or non-selected… he is not on the list). I can travel to Ember and get ambushed, but I cannot progress the story any further or leave Ember once I get there. The game is completely broken. I have tried using cheats to add Bishop to my party, using the roster edit cheat to add all companions to my party, and every possible thing I can think of to no avail. I really don’t want to start over, especially considering I might just end up with the same problem. GoG support was not able to help and directed me here. I believe that similar bugs have been fixed in the past using the Toolset to fix scripts and advance journals, but I have no idea how to do that. If anyone can find a fix I would be so grateful. It doesn’t even have to be pretty, if you can just find a way to brute force Bishop into the party and advance the journal so I can progress from Ember, that will be fine to me.


basically that long dialog needs to fire (it sets a bunch of variables as well as adding Bishop to the party)

So i put together a package that might do something … it has a condensed version of that dialog, and a console script that should either get or spawn Bishop in the Flagon. If you don’t know how to run a console script, open “getbishop.nss” in a text editor – it has simple instructions at the top.

if you run the script while in the Flagon after the githyanki fight, the dialog could start up pretty fast. Even if things fail you should end up with debugging messages in the chat.

[link defunct]

If you choose to accept this mission … unzip to your nwn2 /Override in documents and run the script

ps. it’s best to control your main PC (not a companion) and stand near Duncan.

1 Like

@kevL_s Thank you so much for your work on this. Unfortunately, it only ALMOST worked. When using “rs getbishop” the dialog starts, he is there looting the Githyanki, and the conversation seems to go as normal, but when it’s time to go, he is not on the party selection screen and I just teleport to Ember on my own (Or with whatever other party members I select) and I run into the same issues as before, not being able to progress after the ambush. If I don’t leave immediately, when I talk to bishop again and he seems normal, but again when I say let’s go he doesn’t appear on the party select screen. After teleporting to Ember I tried using roster edit to add him as well as modify him to no avail. Is there any other thing you could add? I really appreciate your help, and so swiftly too.

sounds good so far

give me a day or so to think about it, then i’ll modify stuff and update the package for a 2nd run at it …

This problem sounds very familiar…

What’s in your override, if anything?

PS: Howdy kevl

hey Axe … ( i’m curious what caused it too )

The only thing in my override is what kevL gave me above. Nothing was in there before.

My only guess on what may have caused it, besides it just being a random bug, is using cheats. I’ve played and beaten this game many times over the years so I do not feel the need to not cheat. I get items to make my characters look cool, modify stats, etc. I don’t think I’m too crazy about it, but other than just playing the game, that is the only thing I would consider possible of causing a bug.

Also, I’m not sure if I mentioned above, but Bishop WAS in the Flaggon the first time I went there upon entering Neverwinter. I can’t say for sure when he disappeared, only that he isn’t there now.

delete the old stuff … here’s new stuff

instructions: same as before.

This script does its darndest to ensure that Bishop is on the roster before the dialog starts …

If the dialog does not start, that means Bishop could not be added to the roster. In this case you should see a bunch of debug left in your chat window – i’d need to know exactly what it says.

anyway, give it a try,

1 Like

Huzzah! That worked! Honestly, when I posted here, I didn’t even expect a reply, let alone a fix for a 10+ year old game. Not only that, but you did so very quickly as well! I cannot thank you enough.

It’s too early to say I’ll not have any more problems, but after running your script, Bishop was able to join the party, the ambush and dialog at Ember happened how it was supposed to, and I’ve been able to move onto the Githyanki Approach. Thanks so much!

okie doke !

I guess it goes without saying that things could go south … because … what we did is nonstandard.

i don’t expect them to but if you notice anomalies they can probly be fudged over also

Just tossing this out there as a thought in terms of what might have caused the original problem. You mentioned modifying stats, giving items and such. Is it possible you forget to leave debugmode for some critical plot point that buggered the scene in the Flagon?

No. Its very clear when it is on, and I always turn it back off. Besides, 90% of when I use it is at the very beginning of the game. The other 10% when I get a new companion. It’s not that very often.


The OC and expansions tend to do roster management at certain distinct points. That is, they add companions to the roster en masse well before they can join the party. The companions will be marked “campaignnpc” so they don’t appear in the PartySelect gui, until the plot says they should be.

Somehow Bishop didn’t get on the roster, or an alternate version of Bishop got on the roster …

that’s not necessarily THE Bishop-object that should travel with the party … Shandra is another character-object that tends to go through multiple incarnations … (this is generally bad practice, since it gets difficult to determine which object is which)

i don’t know what happened; and there might still be another Bishop left standing alone in a corner somewhere …

ps. it’s hard to see how “cheating” could have caused the bug. It seems to me that something or other that was very distinctive happened/didn’t happen


1 Like

My game just seems to be completely busted. This is the first time I’ve played the game from, and the first time I’ve played a patched game. All other times I’ve played have just been from a CD.

Everything seemed to be going perfectly until I got back to the Sunken Flagon after rescuing Sandra. First thing I noticed is that upon leaving the Flagon there were 3 Bishops in the list. 1 in my party now, 1 level 5 and 1 level 6 in the add to party screen. This was fixed when I added them all to party while leaving the Flagon and came back in. There was only one in my party while outside, and now only one on the select screen. The next issue is that it seems Sandra has disappeared. I invited her to travel and train with me. She is not in my party, not in the select screen, and not in the Flagon. Finally, the last problem is another game breaking one. I cannot leave the Docks District. The world map has been blanked and not even the Merchant Quarter, where I am supposed to go, is selectable. I have never seen so many bugs in a game.

At this point, I don’t even know if I’m really asking for help as things may just continue to go wrong. I’m also concerned about starting a new game as I may just face the same issues again, not to mention I don’t want to redo everything I’ve done to this point.

I’m a little frustrated.

i wonder if your game is experiencing a very rare “bug” where it’s trying to write files* to a protected directory. But it fails (because the directory is write-protected.)

in any case, i really doubt that it’s GoG per se – many players use that version/edition. I’m guessing … and i repeat I’m only guessing … that something is going south between your particular installation and/or the OS.

you could try backing up what you want backed up, de-installing Nwn2, running a registry cleaner (eg. CCleaner has a reg cleaner), then re-installing to c:\

/for example

* the specific probl. that i recall was w/ the globals.xml file (that appears in save folders – it contains info about worldmap hotspots, etc etc etc.)

My last two completed runthroughs (OC, MotB, and SoZ) were done with the version. The only problems I had were the minor well known bugs, which kevl and others addressed and fixed. The actual bugs were super minor and none were game breaking.

It’s obvious you enjoy this game as much as we do. For sanity’s sake, I suggest your documents/NWN2 folder be deleted, start/close a new game, install nwn2fixes into the override folder, maybe add some graphical upgrades that are proven to work (facelift and hd menu upgrade), and add kevl’s metaprepa rod.

More importantly, stay out of the console when editing your party members. It’s worth taking your time to go to a tavern or Crossroad Keep to make sure who is eligible to be in your party and who must be in your party. What I mean by “who” is which “version” of the NPCs the game has determined it is ready for.

For kicks, I have been successful increasing the possible number of party members allowed. I was able to take the full allotment of party members (and more) and a couple of actual multiplayer PCs, at the same time. Yep, it was pretty crowded, but it was a hoot. Increasing the number of party members may be a good option for you, so you can take whoever you want. Just turn off the ai so NPCs you don’t want to do anything… don’t.

Actually, I’m going to start a new complete runthrough after Thanksgiving.

Yeah, I’m suggesting a restart, but it looks like you’ll be back to where you are in no time


1 Like


I’m not sure what your second paragraph is about. I’ve never used any sort of mods for this game. @kevL_s fix for Bishop above is the first time anything has ever been in my overrides folder.

As for cheating, the only editing I did to party members was for increasing party size (rs ga_party_limit(6)), influence (rs kr_influence), and stats once the party member is in my party.

It seems like both of you are suggesting doing a wipe of the game from my system are restarting from scratch. I really didn’t want to do that. Redoing content that you’ve just done is one of the best ways to make you not want to play a game anymore. Not to mention, this was a fresh install and my first playthrough already. Wiping a reinstalling may just end me up with the same issues. I didn’t have a single problem or bug with the game until Bishop was gone from the Flagon. As you say, that may not be very far into the game, but recompleting all of chapter 1 isn’t necessarily something I want to do.

Thank you all for your replies.


I’m not suggesting a re install, that would be a bummer. I’m just suggesting deleting or renaming the “Neverwinter Nights 2” folder within your “Documents” or “My Documents” folder (depends on you version of Windows). When you start a new game, NWN2 will create a new/fresh “Neverwinter Nights 2” folder. This “Neverwinter Nights 2” folder is the default folder the game keeps track of all of the variables, saves, screenshots, created PCs, etc…, which has nothing to do with the game engine installation location.

If you don’t want to delete the “Neverwinter Nights 2” folder, just rename it. The game will not see the renamed folder and will create a new/fresh version of the folder.

Hopefully, you know to “save early and save often”, when playing NWN2. At the end of my last runthrough I had 209 OC saves, 156 MotB saves, and 412 SoZ saves. I guess I went a little crazy with SoZ. Anyway, with the new/fresh folder, try manually copying a save from the old “Documents/Neverwinter Nights 2” folder and paste it into the new/fresh “Documents/Neverwinter Nights 2” folder. I’d grab a save from as far back as you’re willing to go. Make sure it’s back before Bishop is even mentioned. At least go back to just before you visit The Sunken Flagon the first time.

Don’t mess with any folders within the actual game engine installation folders (usually located within “C: Program Files/” or “C: Program Files (x86)/” or “C:Programs/”

“nwn2fixes” is a set of files made by fans, to fix any remaining bugs. KevL and Kamal are two of the Project Wards. You can download it from Well worth the download.


As a side note: I used the toolset to change the maximum number of party members in the campaign. I probably shouldn’t have mentioned it
I use Tchos’ HD Ui panels and dialogue and loading screens upgrade.
Big Bag Inventory SoZ is helpful.
KevL’s MetaPrepa is a time saver. Used to speed up buffs…
Xaltar’s Facelift pack makes the NPCs far better looking. Worth it just for Elanee.