Blender: Is Someone Willing to Help?

I have access to a lot of public domain placeable models (most with fancy maps) from the same source as the Large Public Domain Fancy Mapped Texture Pack that I posted last December, that I would dearly love to get working with NwN EE. Trouble is I have only ever managed to get a single model, a long time ago, to work and that was with gmax and didn’t have any sort of pwk either.

What I would like to do is to import them myself but that will need someone to hold my hand (you’re OK - I’m vaccinated and really socially distanced on here). A very long time ago RandomDays wrote a tutorial for his shabbiness @PLUSH_HYENA_of_DOOM on how to do exactly what I want to do. This has a number of problems not the least of which is that it seems to be no longer available. Another problem is that it was originally written for gmax and I’ve no idea how to translate that into blender.

So what would I actually like in the way of help? Ideally, if someone could write a tutorial with the absolute minimum steps required to get an already created placeable model (that lacks any sort of wlkmesh) into NwN EE. This tutorial would only introduce controls and keystrokes as they are actually needed (a bugbear of mine. Every single book I’ve seen on using various 3D modelling program gives you all the controls in the first few pages when you won’t need them until page 785 and forgotten them). It would also be helpful if the person/people helping me have a high level of tolerance for questions of an idiotic nature.

So what can I already handle. Well I can import the models into blender OK but I don’t see the textures. Speaking of which I can just about guarantee that textures won’t be a problem for me. Apart from that you’d be working with an almost blank slate. To quote (or maybe miss-quote) some comedian or other “I know nuthin’”.

What sort of placeable models am I talking about? Well, they’re a mixed bag. I personally class them as follows -

General placeables, usable in any setting like these

Who doesn’t need yet more rocks

barrels

or yet another tomb. Note with this last there is only diffuse texture but I can easily generate a full set of PBR maps for it.

Plants, again usable in any setting

Those, being small my not need a walkmesh

and it may be that only the tallest of these do either.

These on the other hand will. Funnily enough I can actually view the whole of that cactus, textures included in win 10’s built in 3D viewer. The same for parts of the pumpkin too. FWIW, I worry that the grape vine draped over a support may actually be well beyond my pay-grade even with help.

Suitable for D20 Modern only

If you do the maths, you’ll realise that in theory at least, that the PBR textures potentially give you 84 different appearances for a single model.

“If I was a rich man…”

Suitcase bomb with money and glowing buttons.

Actually it’s more likely to be an ammo box even if it has a glowing keypad.

These are weapon boxes. There’s actually a further three colour variations - white, desert camouflage and jungle camouflage.

And finally, a load of concrete security/whatever barriers.

Those are just a small sample of what I’d like to get into NwN. So would anyone like to help me, please?

Thanks.

TR

2 Likes

I can help you out. First off there is an old tutorial, but its made for an old Blender version:
https://nwn.wiki/display/NWN1/NeverBlender+101%3A+Part+2+-+Creating+a+simple+Placeable
So I’ll go through the steps again, with new screenshots. Not sure how familiar you are with Blender, so sorry if I’m over-explaining things or under-explaining (I’ll probably do both :grinning_face_with_smiling_eyes: )

First off, you can set render settings in the Top right corner of the screen. By default it is set to solid (no textures). Click on the button one to the right of the active one (the third from the left) to set it to Material.


Now the textures should be displayed. If not, something went wrong with the import. We’ll cross that bridge when we get to it.

Next up, not sure if you have done this already: If anything is present in your blender scene (by default a cube, camera and a light) press A to select everything and then X to delete it. You should have an empty scene. At this Point you may want to go File => Defaults => Save Startup File, so you don’t have to do this every time Blender starts.

Preparations done.

  1. Adding an Empty
    The basic idea is to group objects to tell Blender which (imported) objects should belong to which mdl. In order to do that we’ll use parenting. We’ll place our parent, this is what Blender calls an Empty (dummy in NWN).
    Press SHIFT+A for the Add menu and then select Empty => Plain Axes (Mouse cursor must be in the 3D View for this)

  2. Selecting Objects for Parenting
    We need to parent the imported objects to the Empty. I placed a cube a a placeholder. To preface this: Blender knows two ways to “select” objects.
    A. Selected object: can be multiple objects
    B. Active object: always a single object
    There is a little list with all objects in the scene at the top right. That’s called the Outliner. The light blue one is active object, the dark blue ones are selected.
    There is a little caveat on how selecting multiple objects works: The hotkey differs depending on whether you do in in the 3D View or the Outliner (I hope someone got punished for this :wink:)
    A. 3D View: Hold SHIFT and LEFT CLICK on them. The last selected object will be the active one.
    B. Outliner: Hold CTRL and LEFT CLICK on the objects. The last select object will be the active one.
    So, the first step is to selected them the right way: Simply select the Empty last, so it will be the active object.
    blender_parent1

  3. Actual parenting.
    The parenting process will parent all selected objects to the active one. So make sure the objects are selected like in 2. (check the Outliner in the top right). Then Press CTRL + P to bring up the the Set Parent menu (Mouse cursor must be in the 3D View for this). Select Object. After this the outline in the top right should look like this (you may need to click on the little triangle, left of the name “Empty” to expand the children.

  4. Rename the Empty
    Next step is to set change the name of the Empty. This should match the mdl name name. To do this double click on the Empty in the outliner.

  5. Walkmesh’N’Stuff
    At this point you should be able to export the model with File=> Export => Aurora Mdl. But its missing a walkmesh and nodes for spell target, etc. NeverBlender has a tool for automatically generate them:
    Select any part of the mdl (the Empty/Parent or any child object). Then select object properties (1) and scroll way down to Aurora Utilities and Node Setup Helper (2). Select Placeable and then Setup Placeable.

Now you’re ready to export with File=> Export => Aurora Mdl. NeverBlender will suggest a filename from the Empty name. Feel free to ask if there is anything unclear, I’ll be happy to answer all questions. Hopefully the texture show up in Blender, otherwise I’ll probably have to look at a blend file or a raw file to figure out how (or if) they were imported.

I’ll try to update the tutorial on the nwn.wiki above asap, but the location of the Node Setup Helper in Step 5 is subject to change to a more convenient one (not sure where yet). There are too many tools in that menu and people might start to sue me over their broken mouse wheels :wink:

2 Likes

Thanks for that. During following your instructions I discovered a couple of related things - You can only expand images in a post when you are logged in (which meant that it took longer for me to work out where things were :eyeglasses: :smile_cat:) and that what I thought would be a binary format (obj) is actually plain text. I tried looking inside both the obj and fbx versions of the model just in case the texture file was supposed to be in a different folder. I didn’t expect to find it in the obj (but had to look anyway) as I think that info needs to be in a *.mtl material file and there wasn’t one with the model.

Speaking of which I chose for my first attempt, the simplest one of all and imported the fbx version. Here is the promo pic from above to save you having to scroll all the way back there -

I stumbled through your instructions and am now the proud possessor of both an aurora model and pwk. The only trouble is it is untextured. I tried looking at the official video tutorials and confirmed that I just can’t handle them. For one thing, when I tried there were things in that video that weren’t there at my end. So please can you help?

Thanks

TR

I remembered that there was an fbx model that actually rendered with textures in the win 10 app 3D Viewer. So I tried importing that and success. So exported mdl and pwk. Put them, mtr file I created, PBR maps and 2da into the development folder. Created a quick little test module with a single 2x2 desert area and created a quick blueprint. Looks great in the toolset. Then something strange happened. In game with static unchecked it looks like -

However, with static checked the cactus swells to fill the 2x2 area. Have I found a bug do you think?

Anyway, I’m going to use that 3D viewer app to look at all the fbx models from this source to see if there are any more that the textures show.

TR

Just upgraded to 2.93.1. Only discovered there was a newer version (I was on 2.92.0) by accident.

TR

Hmm, not sure about that size issue, never encountered that one before. You could try selecting the cactus object(s) (should work with everything selected at once, just press A) and go CTRL + A to bring up the Apply menu and then select All Transforms. Maybe there is some weird scaling going on
The only other thing that could do this is an animation. But those don’t just appear out of nowhere. I’d need to see the mdl file, if this persists.

About the Textures. There is two ways of doing this. First is using the materials panel:

You’ll need to rename it, as the materials name will be used for NWNs mtr files:

The base color right at the top is for the diffuse color. You need to cllick the button with the small yellow dot and select Image Texture. The click on open to select an image file (the name of the image file will be written into the mtr as texture0)

Adding maps for Specular, Roughness, Self-Illumination (=Emission in Blender) works the same way. But you can also leave it at diffuse an edit the mtr by hand to add the other maps.

Normal maps need another step before adding the image texture. First click on the lbutton with the blue dot and select Normal Map. This essentially translates color values to a vector = the normal:

After that click on the Color button below to add an Image Texture again:

You can stop reading here, but if you’re feeling curious:
This whole process is just another Front-End to the Shading Editor, which Blender always uses in the background. You can look at the Shading Editor to see what Blender creates from this:


The green node is the shader, which in NWN you would specify in the mtr file and the various texture nodes are connected to it.

This is also Options 2: Create materials directly in the Shading editor. May looks scary at first, but it actually offers a much better overview.
There are better tutorial around than what I can write up in a short time, for example:

1 Like

Your instructions worked perfectly. I’ve now got a new problem though (best explained by a screenie I think)

When I couldn’t get it to display in the toolset, I had a suspicion as to what was wrong. That coffin is apparently 150 metres wide by 92.1 metres deep by 83.1 metres tall! Now while the model is resizable by scaling, I don’t see a way to resize the pwk and TBH I’d rather not mess with scaling but rather actually change its size if possible.

TR

You can scale from within Blender and then apply the scale with method mentioned above: Select the object CTRL + A to bring up the Apply Transforms Menu, then Select All Transforms (or only Scale). The scaling factor will be gone from the object (or rather back to 1.0, 1.0, 1.0) and instead applied to the mesh/geometry.

EDIT: Or alternatively press TAB to Enter edit mode, press A to make sure everything is selected and scale with S key. Its basically the same thing as above though. (Press TAB again to leave Edit mode)

Thanks. I think (warning “famous last words” approaching) I am beginning to get the hang of importing things into NwN now. With your instructions and neverblender, it is so much simpler than I expected.

TR

Spoke too soon. There are some models that are centred at 0,0,0 which the Setup Placeable doesn’t seem to like. Is there a control to automatically raise these models so that their lowest point sits on the on-screen grid and not below it?

Thanks.

TR

Argh, that’s a bug. I’ll get right on it, forgot to put it in the tracker and forgot about it. There is another fix I’ll need to upload anyways.

1 Like

In case there is another bug here is a blend file and texture of a model that sits on the on-screen grid but throws the same Setup Placeable error messages .

Reinforced.7z (2.0 MB)

TR

Quick Fix is to disable “Detect islands”. Seems I forgot to account for an empty list. That option is only there for something like an arch, which is supposed to have a hole in the walkmesh.

Thanks, I’ll try that.

[edit] Tried that and it didn’t seem to work. Here is a screenie (different model to the blend above) with the error message bottom right corner-

TR

The new Update should fix the issues, and there were multiple: Neverblender 2.8 | The Neverwinter Vault

I was a little careless with the latest update, when generating the new node prefixes ( for _impact, pwk_use, etc). Certain model names caused the tool to fail :rofl:

Anyway, Detect Islands defaults to Off now, even though it doesn’t cause error anymore its rarely useful and sometimes even does more harm than good.

2 Likes

That fix is working great so far. Only thing I am not sure about is that Neverblender is now generating a - Default OBJ.mtr - file when you export NwN models. While I personally have no need for it (the models I am converting come with their own PBR maps), I wonder how many people will actually make use of it. Cest la vie. I can just delete it when I spot it.

Thanks.

TR

OK. Another new problem, but this only affects the one model. So I have this model of a pumpkin plant with three pumpkins on it. This is supposed to look like -

Unfortunately it looks like this -

As you can see, the pumpkins themselves haven’t been textured even though the texture looks like -

Note, I’ve replaced the transparency with a checkerboard pattern to get it to upload here. Anyway as you can see, the actual pumpkin texture is there, just not mapped onto the model. So how do I go about UV mapping (that is what it’s called isn’t it) that section of the texture onto the model?

Thanks.

TR

UV Mapping spherical objects. Now there is annoying topic :grinning_face_with_smiling_eyes:

It’s weird that the pumpkins don’t have a texture. Maybe the material is missing? I doubt its coming from a missing UV map, since it wouldn’t be white. The newer Blender versions kind of colorize the object with the texture average color of the texture, if there is no UV map.

Is the pumpkin and the leaves different objects or is everything one? If they are different, please check if there is a UV map:

If its missing you can try adding a rudimentary one. This also only works if the pumpkin is a separate object from the leaves and stem, etc:

  1. Select a single pumpkin object
  2. Press TAB to enter edit mode
  3. Press U => Sphere Projection
  4. Hit TAB again to leave edit mode

It probably won’t look good, but for testing its enough.

If the pumpkin and the the rest of the plant are the same object, you’ll need to select the faces belonging to the pumpkin:

  1. Select the plant,
  2. Hit TAB
  3. Select any part of the pumpkin (vertex, mesh, face, doesn’t matter) with the left mouse button
  4. Press CTRL + L to select everything that is linked to the current selection.
  5. Press U => Sphere Projection (same as above)

If step 4 selects the whole mesh it will get annoying, because that means selecting everything by hand, by holding SHIFT + Left Mouse button.

Thanks for that. Turns out it was originally mapped after all. What it was, is that the model had two texture references instead of one - default and _pumpkindefault. When I selected the model and tried to set the texture, it only affected the default one -

Deliberately selecting the _pumpkindefault reference under the model and then setting the texture appeared to just texture the pumpkin’s fruit -

So it is now apparently solved. I didn’t realise that it was possible to have 2 texture references for a model where both use the same texture image. Anyway, it was your explanation that gave me the clue to investigate further.

Thanks.

TR