C.R.A.P. can't seem to get it to work

First, I do use NWN:EE

Second, I have absolutely everything from the C.R.A.P. haks, 2das, placeables, items, etc from the vault entry with the C.R.A.P. stuff:

https://neverwintervault.org/project/nwn1/other/patch/crap-168-and-cep2

  • I have all the conversations .dlg, scripts, etc

  • I checked that I have all the variables on invisible objects like the edge placeable for the climbing animation out of the pit, on waypoints, etc

  • checked module event scripts, and area event scripts…even on doors I noticed for spiking them shut

  • have the player widget

  • the “incl”

  • did everything I could find to make it work in my module…nada

I can’t even get the conversations for the spiking of the door or climbing down to work

What the hades am I missing?

Does it not work with NWN:EE?

It should…it’s just scripting right?

groan…why do I always find myself busting a nut just to get stuff to work in my module…I spent all day working on this…no joke of a lie…ALL DAY…looking at everything…

The only thing I can think of is it is a script somewhere I need to adjust…everything compiles except one script: crpc_listner_sp

I looked at the script and can’t figure out why…

Here is the script issue…but it seems to be trivial to the whole thing working:

My guess for the compiler error is that the compiler does not know the crp_GetIsItemDestroyed and that’s why it expects a right bracket (and not a left bracket) after the crp_GetIsItemDestroyed.

1 Like

In another thread, you state that your module uses CEP 2.67. The C.R.A.P. has been part of CEP since CEP 2.4 (maybe earlier). You’ll find the documentation for it in the /docs/CEP/legacy_docs/CEP_2_4_and_earlier included as part of the CEP 2.67 download. The version of C.R.A.P. you linked is a pre-CEP 2.4 version which the scripts from are probably not fully compatible with CEP versions from 2.4 and up.

1 Like

This is your problem … You import any stuff you find interresting into your haks.

As Karmiryn states, the error message is a bit misleading but probablably points out, that the compiler doesn’t find “crp_getisitemdestroyed” in any of the “'includes” at the beginning of the scripts. This could be caused by an includefile from cep (or any other source) with the same name, which overwrites the crap - stuff.

Look into your haks and into the module and search for files which are in the “#includes” at the beginning of the script. I bet, there are more than one version.

1 Like

Thanks LoreWeaver_196. All I really want to do is get the climbing out of the pit to work and the listening at doors …but where do I start to fix this? So I have both the CEP 2.67 now and the C.R.A.P. versions in my module…any ideas? What scripts are in the CEP 2.67 that do this? Obviously having the C.R.A.P. scripts in my module do not work…although they work in the demo C.R.A.P. module…I really do not know how to get this to work. I exhausted every angle.

Hi Mmat…Yes…most people take from the vault what they like…isn’t that the purpose of the vault? To download all those things one likes?

Which includes do you think are interfering with the CEP and C.R.A.P. scripts? I dunno.

I’d start by comparing the C.R.A.P. scripts in your module with the scripts that are included in the cep2_crp_s hak (or cep2_crp hak).

As for finding which include, the script editor in the toolset allows you to search all scripts in your module. Do a search for the function that is causing the compile error (crp_GetIsItemDestroyed). The listing of scripts it’s in will be located under the editor window. Then you just have to search through that list until you find the include file its in. Most include files have an “i0” or “inc” in the filename. Assuming that C.R.A.P. follows this naming convention, the include should be easy to find.

Alternatively, you can find them at the top of the script that is crashing. They’ll be listed in brown text and look like this

#include "nw_i0_plot"

The part in quotes is the name of the NSS include file.

Do you or anyone have a small CEP demo module you can upload demonstrating the climbing out of the pit and listening at the door i can look at? That is the best way for me to learn. I have never been good at scripting…but what I am sort of good at is stripping and blending stuff from examples. Just even one small area sample could help me see the scripts at work and waypoints to paint…and see the conversations work with the PC widget. I just need an example of those two things (climbing and listening…spiking a door shut would be cool too but not needed). So basically do what the CRAP demo mod did without the extras…

I like how you can connect the grappling hook to the rope and how you need the hammer and spike to do the climbing.

Sorry, can’t help you. I don’t actually use CEP for anything other than as a content repository I can scavenge and redo assets from. Maybe someone else has a mod.

Maybe try this and see if things work as you desire. Mannast's Vanilla Basemodule for building v.0.9.3 | The Neverwinter Vault

By “try this” I recommend playing around with the base module first, then adding whatever CEP version (or Project Q or merged versions of both) to it that you want (if you even do) and adding anything else after that.

Keep good notes and save your modules constantly with version numbers so that when you have a serious glitch you can just start agian with the last non-glitched version.

1 Like

Yes, download whatever you want and have a look what’s useful for your mod. This doesn’t mean, that you should import everything to your module. Importing only the things which are needed requires some skill, but it is essential on the long run.

As LoreWeaver_196 states, there’s probably a conflict between differnet crap-versions in CEP and your other downloads.I can’t tell you about potential candidates, since I don’t see the beginning of the script. Look for #include statements at the beginning and post them.

1 Like

One of the issues with CRAP is there was a severe lack of documentation when it was absorbed into the CEP. There was initially, but it got lost and fragmented over the years. It’s still out there, and in some cases you can find it nested inside of a Comment Tab within a placeable or item. For the rope system, I would suggest using TK’s rope system, which is CRAP’s system with all of the bugs worked out and the climbing animation restored. For some reason the climbing animations never made it into the CEP. He and I worked on this many moons ago (admittedly TK did all of the heavy lifting and I did all of the falling). I work with it and still use it to this day. Just note you’ll want to make sure you have rope items and such with the appropriate tags. TK’s Fix to the CRAP Rope System

1 Like

Thanks DM_Wise :slight_smile:

Without seeing how you use it, I can only guess, but the CRAP scripts need to be separate from the haks - ie, if you have the scripts imported, but still have them in the hak files, the hak files will take precedence. For example, any edits you make to the crp_inc_control file will not take effect until the hak version is removed - the CEP hak version is set to not have anything turned on, last I recall.
If I can find one of my CEP CRAP example modules from ancient times, I will upload it for you to check out. Found it on Rolo: Index of /rolovault/projects/nwn1/modules/6211

Oh man…thanks Mannest…that would be great if you could do that. Like others above said…there is no documentation on this. I’ve tried everything. Much appreciated.

Thanks…I downloaded all of the stuff you had on there. I will be looking over that stuff over the next week or two…again…much appreciated :slight_smile:

1 Like

I FINALLY…I got it to work…sort of…two issues

  1. The climbing up the rope animation does not work…instead the PC looks like he is riding a horse. I tried changing the ACP fighting style off…to just generic pheno thinking maybe the ACP animation is screwing it up…nope…still does this sort of jump/riding a horse animation rather than climbing the rope.

  2. Attaching the grappling hook to the rope does not work as in the CRAP mini module. I have to use the grappling hook attached to the rope item.

I even overrote my old CRAP climbing model with your model…still same issue for climbing :frowning:

I just found out tonight that my “Additional Animations” which were working really well no longer work since I added the C.R.A.P. stuff to my module…any idea why Mannast or anyone why it would break the “Additional Animations” animationas…is it the scripting or the C.R.A.P. animation mdl I overrode break this?

I believe I got the Additional Animations years ago from here?

https://neverwintervault.org/project/nwn1/hakpak/original-hakpak/additional-animations

My ACP animations still seem to work though

Aha!..I found the culprit…i went back to my oldest mdl of a_ba_non_combat.mdl I put it back in…the additional animations work and the ACP

Now the CRAP rope climbing animations (climbing up and climbing out) do not work as they should…instead it looks like PC is riding an invisible horse…so you do get to the top…rope at bottom and top work…but the animations don’t work.

So close…somehow I need this mdl part to blend the ACP, CRAP, and the additional animations together to work…anyone have one that makes them all play nice?

1 Like