[CEP 2.4] Weapon Finesse doesn't work with assassin daggers?

I’m making a very stabby module now and the assassin daggers are really cool (even though a friend of mine who knows all about that says holding a knife like this is practically never a good idea :smiley: ) so I made some, but during testing I’ve noticed that the attack bonus dropped significantly when equipping one of them as compared to a normal dagger (no enchantments in both case).
A quick calculation showed that the lost number was equal to the difference between the test char’s dex bonus and his str bonus. So my guess is, assassin daggers are not on the list for the Weapon Finesse feat and as such don’t trigger it?
Is that something that can be fixed?

Apparently Weapon Finesse is hardcoded to work only with specific weapons regardless of their size (i.e. rapier).

You might try to replace one of them in baseitems.2da or alter the standard dagger. Though out of curiosity I tried to switch short and long swords row data and they both became unfinessable.

thats because of weapon size

Yeah, it (long sword) worked when I changed it from 3 to 2 or 1.

I see. Not sure if it’s worth the hassle, then, but maybe when all else is ready.
(Ah hahahaha.)

Thanks for your help, guys!

Theres lots of cep supported weapons feats out there. Cep creates all new weapons types, even the backwards assassin daggers. so instead of having to do all that work yourself, you can just grab one of them off the vault.

1 Like