CEP ponies no longer have the hoof beat sounds?

Raised by Imtherealthing

Moved here from another thread:




Hello Imtherealthing


I still cant reproduce the hoove-sound-problem. I made a new mod, imported cep and created castle exterior. Then I put the spotted pony in and created two waypoints to let it walk. The hoofbeats are there.

Concerning the script zep_inc_phenos: For me it compiles without problems. And in my environment, it looks quite different:

How could it be that we’ve two different versions of the same script?


Looks like he is using a modified version of the original script that was changed some years back. There is probably something in it that EE doesn’t like.

EDIT - I think I see the issue now. If you look at line 848 in the screenshot in the OP, it shows " ; break; " @Imtherealthing try removing the ; before the break and compiling it. Of course, its hard to debug a block of code without seeing the entire block (or script).

Thanks Proleric…sorry I got carried away answering his question…lol

hi LoreWeaver,

I removed the " ; " from before the break…and recompiled…nope…did not work :frowning:

Yes…my scripts are from waaay back…but it worked up till recently in EE until I updated to CEP 2.7. So I don’t understand why this is happening…I changed no module event scripts

Hi Mmat

Let me correct my comment…I can hear the hoofbeats if I crank up the volume and lower the music…never did this before until I upgraded from CEP 2.4 to CEP 2.67. The vanilla horses I hear the hoof beats perfectly…nice and clear.

Thanks for your effort to trouble shoot this. Don’t understand why the CEP just dosen’t use the horse hoofbeat sound from the vanilla …much clearer.


I described a simple check above:

I made a new mod, imported cep and created castle exterior. Then I put the spotted pony in and created two waypoints to let it walk. The hoofbeats are there.

It’s a way to verify an issue apart from any influence of own scripting and modding. Could you do this check and tell us the results?


Someone removed a “case” statement without removing the whole line. Just removing the ; in front of the break won’t help, because then the other cases won’t get checked out. The whole ; break ; has to go.
Even that might not help, because who knows what else got deleted?
It looks like there isn’t even a “switch” there. This script is probably very much broken now.

Thanks Zwerkules…I will try that

Hi Mmat…I will try that sometime this week for sure…thanks bud

I forgot to answer this…just noticed. I never had that script until I downloaded the CEP 2.67. So my version came from there.

No, it didn’t.

CEP 2.67 contains only one version of that script. It is in cep2_add_sb_v1.hak.

As @Mmat has already demonstrated, that script is very different from the one you posted, so you must have a custom version somewhere in your haks or module.

hi Proleric…I am pretty sure I checked all my haks…but I will go through my old haks again and see if there is that script in those old haks. It may have been that I did have an older one that was modified and I never overwrote the newest one because as I was adding stuff from the CEP 2.67 and other great stuff from the vault I tried to make sure I did not overwrite my content…for fear of breaking stuff in my new haks which would use my old module.