Changing Familiar and Associate Conversations

Hi there:

I was recently trying to update the standard familiar conversation resource, nw_g_fam, so I could use an altered version in a module I’m creating. It didn’t work out quite like I planned, so when I deleted my altered version after playtesting so that the game could go back to the default version, I found out that characters used in that module could no longer summon familiars. Any idea why, or what’s wrong?


This could be something within your module or something with the game engine (such as third party add-ons or files in override).

To check that out, create an new and empty module and summon your familiar within. If that works, concentrate your investigation on the mod, if not, recall what is installed on the engine and could cause the effect.

Thanks. I think I may have found the problem. any advice on what to do with corrupted area files in the toolset? I suppose I could always try exporting at, deleting the area in the module, then re-importing and watching what happens?


In what way are your area files corrupted? What was the problem you found?

Without that info it’s hard to comment.

Hi Proleric:

On further testing, I’m not sure it was corrupted files after all. Here’s the thing - I’m building a module and after editing the standard familiar/animal companion conversations, I started noticing that the summon familiar and summon animal companion abilities would simply fail.

That being said, after some further playtesting I noticed that although the summon familiar/animal companion ability would fail (no familiar would appear, nor any VFX) on certain tiles in the W0rms Seasonal Forest Tileset (where my module’s start area is set). When I tested the summon familiar ability in multiple other areas and modules, I noticed it worked consistently. However, the summon familiar/animal companion ability would still fail, usually depending on where the summoning character was located in the Seasonal Forest Tileset (e.g. would not work on dirt path, near trees, etc.).

At least I think that’s what the problem is. At first, I assumed something may have gotten corrupted after editing the nw_g_fam conversation resource - but I don’t think that’s what it is at all. I don’t know if anybody else has ever reported an issue like that with the W0rms Forest tileset though, and I didn’t see anything after a quick google search.

Lol, thanks. Sorry for the large post.


Maybe there’s not enough room for the familiar to appear? I know that was the reason in many modules for me: each time the summoning failed, it was because the place was too small or overcrowded.

1 Like

The only thing I can think of is a problem with the walkmesh. Seasonal forest isn’t bugfree. Name the tiles. If you hover with the mouse over the tile in the toolset, you see the name on the bottom of the screen.

That would make sense. Thanks. Will see if I can make a list when I next do a test-playthrough of the mod I’m building.

I have a revamped version of seasonal forest on Pstemarie’s Custom Content | The Neverwinter Vault

I fixed numerous issues with the walkmeshes and greatly reduced the amount of textures by eliminating all the dupes. Maybe this version will fix what’s ailing your module.

1 Like

Thanks! The first chapter I’ve made in my series is already completed - but I’ll see if I can check it out and rework it, if it helps :slight_smile: