Character Editor for NWN1?

We were playing a couple of days ago and my son picked up an item (a creature item for expansion 3 (1.69) to store PC properties) from a chest in Chapter 1 while in the wizard’s house (name escapes me). Obviously glitched and now he can’t drop it. We are running Diamond and at the time 1.69 (yesterday we upped to 1.72). I found an editor for 2 but I haven’t found an editor for 1. Is there one?!

Thanks.

PS: I was going to attach a picture but I don’t see a way to do that. Sorry.

Just drag and drop your picture into your post where you want the top of it to be. These forums take both jpg and png images IIRC.

TR

Thanks. On an iPad right now. No pasting or dragging for me! I’ll try it from a desktop later today.

The simple answer is to drag the item to a quickslot, then use it.

It should disappear (it’s actually equipped to the hidden skin slot).

If that doesn’t work, don’t save, but try solutions discussed here.

Thanks, I’ll tell him to give that a try.

good thing is that if you installed community patch you shouldn’t be seeing this in loot anymore

Implied that they are.

NWN2 tool may work or may not? Keep a backup! If it’s a save game then you need to extract and modify the module.ifo since that’s where the player’s character is. If you can find, you can just delete the item’s node, but walking through that…might be easier to just upload the file and have someone modify.

Specific problem of why you can’t just drop it is it’s set to cursed. Someone logged in as dm can remove. Can modify say a player tool script to set target item as cursed and plot to false, or just a script to runscript console command that’ll do the same for all items in inventory, that’s a 30 sec job.

Turns out, that isn’t correct, it shows up with 1.72. Somehow I ended up with one of those skins in my inventory without picking it up. And, can’t even bring up a description when you click on it. I tried the console item reset and it said it worked, but, it didn’t actually do anything. On to the next thing.

That is odd, but it can certainly happen in some module because CPP is maintaing 100% backwards compatibility. For example, if the module has old code for IGMS then the old code will be used instead of new fixed code from CPP (IGMS is one of the spells that is spawning PC Skin).

Of course it is possible that there is some special case that can still generate PC Skin which I didn’t found, but personally I haven’t seen this item for years.

So downloaded Leto 1.69 editor from the Vault (found it via Steam) but it doesn’t seem to allow for item editing. I may be to dump all my stuff and recreate the characters to get rid of this stupid skin!

Edit: sorry, let me rephrase that. There is a way under Advanced Editor but, I don’t see display names so I don’t know how I’d I pick out the offending item.

Success! I had to drop every bloody item just to ensure I had the correct one. Saving the file wasn’t exactly intuitive but once I figured that out it worked. Bloody painful and annoying!

Now lets see if it sticks…

Thanks for the suggestions. Now if anyone has a NWN1 character editor that is easier to use for inventory management…

that looks like the standard pc properties hide. if so, this is actually pretty easy to solve with scripting.

create the following script, save it as ‘dropme’, and export both dropme.nss and dropme.ncs it to your override folder.

void main()
{
    object pc = OBJECT_SELF;
    object skin = GetFirstItemInInventory();
    while (GetIsObjectValid(skin)) {
        if (GetTag(skin) == "x3_it_pchide") {
            SetPlotFlag(skin, 0);
            DestroyObject(skin);
        }
        skin = GetNextItemInInventory();
    }
}

leave them in your override folder until the end of time. then, if you should ever run into this problem again, just follow these steps within the game :

  1. type :  ##DebugMode 1 in the chat bar.
  2. type : ##dm_runscript dropme in the chat bar.
    you should see Lost item: PC Properties appear in your chat window and the item will be gone.
  3. type :  ##DebugMode 0 in the chat bar.

for convenience [or if you don’t like scripting], here they are :
dropme.7z (463 Bytes)

voilà.

EDIT : fixed nefariously plartivartian type-o… :roll_eyes:

Thanks!