CMP music not playing

Back from a hiatus playing/modding other things, and I ran into a snag while working on my WIP module: the CMP music isn’t playing in the Toolset. It was working fine the last time I got in there which according my logs was… May 2019. So my guess was that it was something to do with the updates since then.

I previously was editing in my installed copy of the Diamond edition, so I moved all the haks, mods and bmus over to the NWN folder in My Documents. Still isn’t playing.

I did some reading about the latest patch, and it sounds like they changed things so that it plays mp3s, but that they still need the bmu extension. Should I convert my bmu files to mp3 and then just rename them? That doesn’t seem like the issue…

I also read that you can put music files in haks now, but I didn’t see anything that suggested it’s required. So that means I can still use the CMP hak as is, and leave the music files themselves in the Music folder, right?

Anyone aware of any other issues? What am I missing?

I know CMP worked in EE, Proleric’s Dark Energy module uses it.

The new builds and patches just released have spawned some comments about music not working in the toolset on Steam, but it still worked ingame. BD think they have fixed it tho. Are you updated to 1.79 or better, dev build 8193.4 ?

Another reported music issue is when you CTRL+SHIFT+F12 to get the new console, you can lose menu music by unchecking “disable intro movies” (Which actually means the opposite of what it says) so you could try toggling that ingame or in settings.tml and see if it has an effect too.

I think EE will play .bmu or .mp3 renamed as .bmu equally well and any change would break backward compatibility so that shouldn’t ever be a thing.

Have fun :slight_smile:

I actually haven’t tried playing it yet, only in the toolset. I’ll try that out, since I am on Steam now. I should be on 8193.4. Thanks!

I think for 8193.4 you hve to opt into betas. (RClick on the game in the left hand pane, properties, betas tab).

However, looking at the patch notes, it is 1.79/8183.3 that supposedly fixed the music so your normal install is fine. Do nothing, just test.

Have fun :slight_smile:

Regarding Toolset music, I too have difficulties getting it to play. I’ve reported it before and was told it must be on my end. I’ve updated drivers with no success. It is on my (our) end, it may have something to do with the machine and sound system.

But basically the preview music button doesn’t work like it use to. I have to close the area properties, click to turn Preview Music off, then click to turn it on again. Then I can hear the track. It’s a pain in the arse, but that’s about all I got.

That sounds annoying :frowning: . I just double checked in my copy and it appears to be working fine, changing on demand in area properties. I don’t know what to suggest, but I will keep my eyes open for any other reports.

Have fun :slight_smile:

1 Like

Well, I managed to get it working for myself by turning on music and then restarting the editor. Then if I turn it off and on again, it still works. Funny glitch.