Compatibility Fixes for EE Needed

I have found a few mods that don’t work with EE and I wondered whether anyone knowledgeable enough would be prepared to create fixes for these mods.

These are some of the Mods that don’t work…

  1. Caereena - Krakona Rising. Just replayed using latest version of EE and everything is fine.
  2. Calm Before the Storm (Area transition problem when trying to exit from the village you start in).
  3. Tales of Arterra - The Awakening (part 2 does not carry over henchmen information).
  4. To Find A Savior - Orfin’s Challenge (Save failures when using EE).

Added Leto to the list. See post for more information.

Thanks for any help, ideas or volunteers.

Caereena - Krakona Rising - what issue are you having? As noted in the module comments, I haven’t had any problems in EE.

Calm Before the Storm Nails reported back in June that this was OK - it would be great if anyone here has time to check that initial exit is still working.

Tales of Arterra - The Awakening @niv are there issues with data bases passing info from one module to another? I haven’t checked that this one is a data base, though.

To Find A Savior - Orfin’s Challenge does anyone have time to check this out?

Sorry not to be more helpful but I have a lot on my plate right now.

@Proleric, many thanks for taking the time to comment - very much appreciated.

Caereena - Krakona Rising - Unfortunately, my mod notes only say that it is not compatible, but not what the problem is. Perhaps it has been fixed in the later versions of EE. I will play it again and report back if I find any issues.

Tales of Arterra - The Awakening - There are quite few comments about this on the Project page and, having just played the Mod, I experienced the same issue.

One word of caution here. Because Nails is still on 1.69 it only means that their run through of Calm Before the Storm is really only relevant for that version of the game and not necessarily for EE.


1 Like

Just replayed Caereena - Krakona Rising using latest version of EE and everything is fine.


C2 - The Ghost Tower of Inverness has a CTD near the beginning, probably tileset-related.

Does anyone have time to fix it?

I thought I would add Leto to the list.

When you try to save your updated character you get this error…

You can know that this will happen in advance by the question marks shown when you select the Module resource. The question marks are not necessarily present in all EE saves.

This is one of my favourite utilities when you want to change your mind about things like the Weapon Focus feat (or the player’s sex).

Would be fantastic if some talented programmer could figure out what is wrong and how to fix it.

1 Like

I’ve noticed some modules are having some issues, like the Goblin Gate in Paths of ascension, the key simply will not work, even a new key!

I don’t know if it’s a tileset issue or because I imported the Diamond edition module into EE…

Nevertheless, I’ll make some new areas and see if the issues persist & then report the bugs!

I am willing to workaround all bugs that Enhanced Edition introduces to old modules provided that you send me:

  • link to the module that has the problem (and potentially haks so I don’t have to search for haks all over the vault if the module has them separately like Prophet 2)
  • savegame where the problem can be reproduced (sorry I won’t be wasting time playing the module to get the the point it breaks) with instructions what to do to reproduce it, if it is not self-exemplanatory

I can even fix non-EE related bugs like when the module has badly setup transition or script etc. If you cannot finish the module and you provide me what I request I can take a look.

1 Like

haha, I fixed it ShadoOow… :smiley:

It was a tag being changed by my poorly written treasure script! >.<

The real issue I ran into was a Pure Call error while working on a new frozen rural area I was creating, it just shut the module down for no reason at all!