Crash when saving?

This is weird NWN2 has been on my computer for years it’s not a GoG version or Steam it’s from the disk but now every time I save the game it crashes and says NWN2 has stopped working.

The only thing I’ve done is copied two saves from it onto a laptop but this is my PC with the original saves in. It’s not the module either as I reloaded a save from another module, saved it and it crashed that too.

Any ideas why ?

Thank you.

This is weird I started the game by right clicking the NWN2 start icon and as a test I ran it as an administrator to get to the start menu then hit play ( as usual ).

It saved normally with no crash, I exited, restarted it ( not administrator ) and saved again, no crash so it works now :grinning:

But why did it happen like that ? I have never ever ran this game as an administrator and that’s a lot of years playing it !

idk but whenever I see RunAsAdministrator i tick it

( it can have something to do with what folders the app is allowed to write to )

1 Like

When I had this problem it’s was a .2da problem, somme of the ability weren’t referenced correctly.

1 Like

kevL_s… I will run it as an administrator from now on if it happens but I never have done before, I’ve never ran it in any compatibility mode either. It’s just lived on my hard drive for years with no issues… Until now !

Shallina… It’s possible but I haven’t changed any 2das for ages and that was way before this happened.

Thanks and I guess I’ll be more careful from now onwards, I’ll save as soon as I start it up and load a save that way if it crashes I’ll know not to continue until it’s sorted again.


I’m back again and the issue returned even with me running it as an administrator from the desktop so I don’t know why that happened !

Anyway it’s fixed at the moment because I went into the Program Files ( x86) folders of NWN2 and right clicked the nwn2main file and then ran that as an administrator.

Hope this can help anyone else getting annoyed with this issue or being scared of saving !

This is getting on my nerves now but here’s a new thing that worked. Taking the Neverwinter Nights 2 folder out of my documents into another folder and then putting it back where it came from !

No idea why all these things are happening to something that’s been on my computer for years but it’s definitely annoying.

I’ve seen save-game crashes caused by tiles that have blank floor, wall, or ceiling textures. So check every tile in any interior areas to make sure those properties aren’t blank.
I’ve also seen tag-based scripts cause save-game crashes if they weren’t coded correctly.

travus… I wish it was that simple. When my computer’s doing it’s save crashes it will crash any module, any area. I’ve reloaded saves from way back in totally different modules hit save and I crash back to desktop with a message of Neverwinter Nights 2 has stopped working.

One strange thing happened last night it wouldn’t overwrite a save it just went straight back to the game without the game saved message but try making a new save and it crashed. The new save is there in the saves folder but it doesn’t show up to reload it and is smaller than the one in the area you loaded before saving.

I have deleted a lot of saves in case the folder was full up but that makes no difference. It’s random but goes on for at least half an hour with me turning on and off my computer, being an administrator, running it in different compatibilities, standing on my head while holding a branch from a rowan tree in my toes, doing various incantations or praying to every type of god ! But still crash, crash, crash until it clears.

My main problem is that I can’t play test things because I have auto save triggers in dangerous areas which will crash the game when I walk on them if my computer’s in a crashing mood otherwise I’d just carry on without saving and respawn if I die.

This might be a long-shot, but go to…
… and delete any NWN2 folders that might be in there.

1 Like

travus… Thanks, I’ll keep that in mind but it’s a bit scary doing that because it’s got script templates and stuff from my latest mod in there. Are they just copies ?

At the moment moving Neverwinter Nights 2 out of documents, into a folder and back into documents seems to be working but I don’t understand why. If it was a matter of the game not knowing where to put a save that caused a crash and me resetting the whole thing back in documents then why did the save files appear there ?

Alright they were useless save files that never showed in game but they were still named and there as a folder so had found their way into the right place.

I just had a brain wave whilst writing this and did a test which might shed some light on this issue. I looked at a save folder that didn’t work and one from the same module, three files were missing from the broken one that crashed and they were…

currentmodule, savenfo and screen.

When I copied and pasted these into the broken save from the good save the save showed up and it loaded in game. I then saved it and got no crash.

Those are just copies and you can safely delete them. But to be safe, just make a backup of those files in folder on your desktop and delete the originals out of the VirtualStore. Then see if the save-game crashes are fixed.

travus… It wiped out my script templates so I put it back in case it had done something else too.

My game is saving at the moment and I’ve got a cunning plan for a test. As soon as I start the game and load an area I save, if it crashes I go to the saves folder find the useless save and the original that I loaded and copy in the missing bits.

Then load the fixed broken save and see if I can save from it this time. It’s not ideal but it might clear the issue.

The game on my PC is the original from the discs and has worked perfectly for years. I’ve got a GoG version that I put on my windows 10 laptop recently so if all else fails and this gets to a point where I can’t play it anymore I’ll move all the files out to safety and delete my old faithful NWN2 and load in the GoG version, but I really don’t want to have all that hassle.

Back again with another part of the mystery !

More crashes when saving, went through the usual rituals but it didn’t stop it ! However what I did was took a crashed save file and looked at an alright save file and the differences were the same, The crashed one was missing the currentmodule, savenfo and screenshot.

The currentmodule and savenfo files are simple notepad text files that just have the name of the area and the name of the module in. So I copied them, pasted them into the crashed save and changed the text to the module I was in and the area, added a screenshot from the good save and ran the game.

The save came up, loaded it in the game and everything was correct, area, weapons, journal etc and it played just fine. tried to save it and it crashed !

Seeing as two of the missing files were very simple text files is it possible that my game is crashing because of a lack of screenshot because that’s the most complicated missing file ? This might explain why when it’s in a crashing mood it wont overwrite an old save and just does nothing.

If there is an order of how things save maybe mine just stops dead when it can’t do a screenshot as I can’t see two note pad files, with three words in, causing an issue.

@Tsongo Look into the security settings/ UAC / read-write privileges that are set in your OS. (particularly for the directory hierarchy that the saves are written to )

also make sure nwn2 runs as Administrator w/ Windows XP sp3 compatibility …

… This aint (wouldn’t be) the first time nwn2 has failed to write due to security privileges,

( hint: a windows update could have sent things borky )


kevL_s… Thanks but where are these security settings, all the ones I can find are related to the internet ? My PC’s on Windows 7 and I turned off updates a few years ago so it wasn’t an update.

This problem is sporadic but when it hits it lasts for ages and is really annoying. Is it possible that something stops copying of pictures into the crashed save folder ?

Before when it crased I switched to administrator Windows XP sp2 and it worked but since then this method has failed, I’ll try sp3 next time.

Windows’ security settings are a horseshoe to find and navigate if you’re not used to them :(

but maybe it’s not security, it’s just a guess on my part.

at this pt, I don’t believe that writing a picture file would be any more problematic than a text file … writing a file is the app sending a bunch of bits to the OS which is sending them to the hardrive … I’m assuming that the failure is the bits failing to write to the hardrive rather than the app failing to create an image, since it happens to those textfiles also.

(but it could be if Nwn2 creates the textfiles based on success of the image …)

still …

ps. I’m not qualified to guide anyone through ‘security’.

you could try ControlPanel|System and Security
or ControlPanel|User Accounts

or right click your MyDocs/Nwn2 folder (the one with your /Saves folder) and bring up its Properties|Security|Advanced|Permissions and/or |Owner …

just have a look but be careful what you touch,

and … google …

hm, that throws a monkeywrench at my idea …

1 Like

Thanks, I will investigate… Carefully !


After last night’s series of crashes I discovered that not putting a copied and pasted screenshot or savenfo file into the crashed save made absolutely no difference ! The crashed save still appeared and loaded no problem with just a replaced currentmodule file.

So the saves are going wrong when they can’t record the data of a module… Not much data, just it’s name ! This is nothing to do with my modules as it crashes the OC too and other mods.

1 Like