CTP tilset Issue (CTP Babylon - walkmesh) -FIXED!

I downloaded the CTP tileset and a prefab that uses it.


In the prefab CTP Prefabs | The Neverwinter Vault

In the Bazzar there are two walkmesh issues. If you walk around inside in those two places you walk up in the air.

Who do I contact to fix this?

I noticed this too … I assume the authors are long gone…I would fix it myself if I knew how…
(some shameless self promotion: I fixed some ‘ctp babylon’ loadscreens years ago:
Fixed CTP Loadscreens also many other Loadscreens CEP2.xx Compatible | The Neverwinter Vault)

Ok…thanks Vivienne :slight_smile:

I will check out your loadscreens too.

1 Like

Most of the time I fixed these sort of bugs by running the tile through CleanModels3 | The Neverwinter Vault

If that won’t help, manual editting will be needed in Blender or GMax. The main cause of these issues is that one of the tiles will have bad coordinates for the border “dots” of the walkmesh, it should be 500,500 500,-500 -500,500 -500,-500 sometimes its 501 or 499

Thanks Shadow, but beyond my skills :frowning:

Can you mark the exact position on the picture? Probably I can fix that.

1 Like

Well, the original CTP-crew is not doing any custom content anymore AFAIK. I was accepted into CTP for preserving those DLA-tilesets. I had no hand in all those CTP-tilesets.

I am warning to use Clean Models with great care and you need to recheck the output. The tool will break models with an a-node (= base name+a is replaced with a cm3_repair_1 naming, thus breaking the node)! Even the EE-version of Clean Models still does that. If a model doesn’t have an a-node, CM is a good tool.

But, as written by others, a manual edit can be done. If it’s only 2 tiles, I could do it, except that I’ll be away from home for about 2 weeks, and I can’t ATM.

But @Mmat is also good adress! He helped me with a bunch of DLA Solace tiles batch-adjusting/fixing some issues!

There is a potential problem with this tileset in particular. See the permissions on it. It is the only CTP tileset with those restrictions. So, even if you fix it, you can’t redistribute it according to those permissions.

CTP Babylon


I read that. But if it is an uploaded fixed hak of the original giving the CTP team and people credit that worked on it…I think they would understand. It is not being sold nor anyone taking credit for it…well not directly. One can say they fixed it on the new upload but all credit goes to the authors. These guys are gone. I think they only said that back then because they didn’t want people taking credit for their work.

Hi Mmat,

The two spots are right in that area in the pic above. The debris and red striped stall (together) and the one stall directly left of it. Download the hak and add it to a module (I guess you would also need the CTP common hak too so you can see it for yourself.

I think those bazar/market tiles (retextured and modified) are also in the TNO version included in PQ 3. So if fixing them by hand does cause any problems, it might be worth to have a look at that.

Regarding the permission issue Tarot_Redhand brought up - I think the best way to deal with that would be to upload the two (or however much) fixed tiles / woks as a separate add-on hak.

1 Like

I also hate when peoples are reposting the fixed tileset again so I understand the conditions of the author. Though I did that too, but I did lots of changes not just to fix few tiles.

Anyway, if the fix is integrated into the original hak on that page, would that be a problem?

1 Like

Yes, there are restrictions, but didn’t the CEP team ignore those and include that tileset in CEP? If so, ask them to fix it.

No, that tileset was not included in CEP - neither back in the bad old days of the “CC war” nor in the recent update of the current CEP team.

iirc, back then they only included the CTP generic door entries in the corresponding 2da (and names for the them in their dlg file, but not the models themselves in their haks). I think the problem between CTP and CEP was that there was an agreement that CEP would stay away from tilesets which they then went on to do anyway. Not saying the old/original CEP2 team never included anything else without permission though.

And just btw, someone from the current CEP team did in fact already step up and volunteered to try and fix the issue.

  1. Afaik, CTP-Babylon is NOT in Cep
  2. Take into consideration, that the people who take care of CEP changed with the time.
1 Like

Hey…lol…I use to be on the CEP team…lol…back when Barry ran it. Well I use to monitor the CEP forums.

EDIT: during those “CC wars”…ah the good ole days…lol…“not”!!

EDIT 2: And the battle that took place between CEP and Project Q…sheesh…remember those days?

OK, I contacted Winterhawk from CTP. He is still around, runs the CTP-homepages, but he’s not doing CC anymore (at least up to now). We see what he says. I’ll report.


Like Mmat said, that tileset isn’t in CEP 2.

From what I’ve picked up over the years, I think you’re referring to something that was discussed way back in 2008. The outcome was that the CEP 2 team of the day excluded CTP content. None of the current team members were involved.

As you know, we have been diligent in asking authors for permission to include work in CEP 2, even when it’s open content.

For the most part yes, but a heads up on the additional Qv3 content you were adding in your 2.70 update would have been appreciated. Could have saved me a lot of time merging all that stuff into the Qv4 update I was working on only to see it arrive in CEP, killing countless hours of work and ultimately leading to me trashing Qv4.

On the plus side, it led me to developing FUBAR, so all is good in the greater scheme of things.

Ok, here it is.

The problem is, that the tile tced1_mk02_03 has no aabb-node at all. So I copied the node from the wok. Works for me. This description should be enough for an experience builder to fix the issue.

@Imtherealthing: Plese send me you email-adress via PM (I guess I’ve misplaced it :slight_smile: ) and I’ll send you the update. And here is a special gimmick for you: In the toolset, under environment you can check the option “render aabb”. The faulty tile is immediately visible as grey square.

1 Like