Custom music help

Hey! I want to add some custom music to a module of mine to form my campaign. How can I do that? I am interested in a ~3:5 min long song. Please reply if you can help.

First step you need to convert it into NWN2 music format if it’s not compatible. I think you can find a tool for this on this site.

2d steps you need to edit the music.2da files to put a ref on your new song.

3d steps the song file need to be into the music folder.

I don’t think there is any other restriction, for how often, and how long you want your song to play everything is set into the area property pannel in the toolset.

There is also music specific scripts function that can allow you to stop, start or change the songs of an area, they all have music in their name so search for music in the function index of the toolset.

1 Like

@Shallina Thanks for your help lad/lass. It appears you have forgotten the link here

But other than that, thanks for the great tips. Also, I’d appreciate it if you could explain more about the .2da file editing part as I am quite new to this.

I’ll leave that to those that know NwN 2 but if you are not hard-core enough [joke] to use a plain text editor to do it, then the best 2da editor on here, by far, is Yata by kevL’s (well at least in my opinion anyway).



@Tarot_Redhand Thanks, lad. I will take that into consideration.

I guess this is what you’re looking for: MP3toBMU 0.35 | The Neverwinter Vault
Additional information on how to use custom music can be found here: NWN2 Custom Music Guide | The Neverwinter Vault

1 Like

Thanks, friend! I’ll see to it.

Fun little fact - What did Bioware do to get around the various software patents to do with mp3 files? They created the BMU format. How does this format differ from a regular mp3? It is always precisely 8 bytes larger than the mp3 it is derived from. How so? A BMU is just an MP3 with this precise text inserted right at the beginning “BMU V1.0” and the extension renamed to bmu. You can confirm this by opening a bmu file in a good plain text editor such as notepad++.


1 Like

4760 already have you covered with what you need to know. I just want to add a little thing. I’ve used mp3 files that were 320kbit/s and converted them to bmu. Even though the MP3toBMU protests when converting, you can ignore that. So it doesn’t have to be 128kbit/s like it says in the Custom Music Guide pdf.

By the way, if you need some free easy audio editing program, I can recommend Ocenaudio: even though I myself use Cubase (but that program, if you have the pro version, costs quite a lot) since I write music for work and in my spare time. Most people apparently use Audacity, but I’ve always hated that program.

1 Like

Hey there !

I followed the steps suggested by this topic and the Custom Music Guide, but it still doesn’t work. As it says in the guide, the 2DA doesn’t seem to take into account my added files, even with the proposed procedure, and even if I manually add the lines in the toolset.

Not sure if the BMU file should only go to the documents/nwn2/music folder.

Has anyone managed to put custom music into NWN2, and if so how?

Have a nice evening !

I always put the bmu files in the documents/nwn2/music folder. Then if you have added lines in the ambientmusic.2da you should be able to pick the track in the toolset for an area. It has never failed for me.

Like for instance, a line could look like this:

242 **** jekto **** **** **** jekto

then in the toolset it will show up as “jekto” when you try and choose the music for the area.
I put this ambientmusic.2da in the documents/nwn2/override folder, but you can make a hak pak and put the 2da file there also, or in your campaign folder if you’re making a campaign. If you work with PWs I have no idea how it works though since I only make single player modules.

EDIT: If you want to, you could post your track here and your 2da file, then I could take a look and maybe help you out. It could be that there’s something wrong with the bmu file…

1 Like

Okay, thanks very much for the help, here are some screenshots.
The BMU file (don’t pay attention to windows media player, it’s a bmu file) :

The ambientmusic.2da, in the override, only modified for its final line :

When I start the toolset and a totally new module, this is the 2DA I can see, BUT the selection of the music for the area shows this :

So, even if I don’t open my custom module or campaign, it seems that the 2DA viewer in the toolset is never accurate. Look at those french names (in the 2DA viewer, it’s labelled in english). Perhaps in my french version of the toolset, the toolset uses a 2DA in another mysterious place ?

Sorry for the height of the post !

1 Like

From what I can see from your screenshots everything looks correct. You see that you can scroll down the music in the toolset, right? The music is (most of the time) in alphabetic order so you need to scroll down to see your mus_a-vio file.

Another thing that I can think of that maybe causes an error is the “-” sign. What happens if you rename the file and in the 2da file to just mus_avio?

Alright, just as in France it’s about 1 o’clock in the morning for me now. Better go sleep. I can help more tomorrow if you wish.


Yes yes, doesn’t appear even if I scroll, and even if I remove all the demonic characters possible. And that’s for a purely new module. For the existing ones, I can’t even see my own ambientmusic.

I have the weird feeling that my modules create, from the VOID OF DOOM, a new 2DA every time I open them. Like some kind of luciferian invocation. :japanese_ogre:

It’s truly late, good night, hope someone has an idea of the problem ! (Perhaps I will fix it myself, everyone can dream)

Really weird.

Do you save this module as a directory or a module? That shouldn’t have anything to do with it but…

1 Like

Hi, the most likely cause is that the game can’t read your custom “ambientmusic.2da” file

For this many reasons are possible.
The file isn’t set correctly in your work, or is owerwrite by an other one.

Priority order for highest from lowest is HAK, then Override, Then Campaign Folder, then Module directory.

Be sure you don’t have 2 versions and other isn’t taking priority over your own.

An other problem could be you formated your file badly, and then the game is unable to read it.


Shallina is right. I have made that mistake a couple of times of having multiple 2da files associated with the same module.

@Macastril - Just to try and find the problem: Here’s a test module I made with my own custom 2da and a music file (just copied and renamed one of the stock tracks from the game). This works on my end. Check and see if this works on your computer: (2.8 MB)


I’m a nwn1 builder so not sure if this will work for nwn2 but this is how i put my custom music in my mods using .wav files with no .2da editing… Put music/ .wav files in a hak, put hak in module. Then use sound wizard to turn each song into a sound placeable and then put sound placeables in each game area. Turn off all original music for the areas and it should work. I use 16bit wav files and set them in sound wizard as looped and area-wide so they keep playing in game areas. Hope this helps!

1 Like

I think (but I’m not sure) that when you use sound with placeables in NWN2 the sound is always mono for some reason. I remember doing it like this in a certain area in my third module where I had bards play when you got close to them. So, if that’s the case, then I don’t recommend it. You, of course, want your music to be stereo.

In any case it should work with just editing the 2da and having the bmu file in the music folder. As I said in a previous post, it has never failed for me. I have the english version of the game though, maybe that’s got something to do with it (I don’t think it should)?

1 Like

Yes, music_X1 and music_X2 seem to not be considered at all.


Maybe change 233931 to ****, or another entry in the tlk that is not a long text. I know for a fact that when the text to display is too long, NWN2 doesn’t display anything instead of just showing the first characters.

French version here, and no problem to add my own music.