Custom NPC refuses to spawn (Enhanced Edition)

I am having some difficulty getting a custom NPC to spawn in a module that I am creating.

-The NPC was made using the creature creation wizard. She is an elf wizard and belongs to the commoner faction. She is placed directly onto the map (i.e. no encounters, scripts, or other triggered events that would make her spawn. She should just be there, but she’s not).

-To test if creature spawning is not working, I added a goblin from the regular creature palette and placed it elsewhere on the map. It works normally.

I used to make modules for NWN long ago before the Enhanced Edition was released. What am I doing wrong?


Refresh your Creature Palette if you just made her. (right click on the palette title and you’ll see the refresh option

Make sure the creature in question is placed on a viable portion of the tile. To make sure, under your Build section of the Toolset dropdowns, run the Verify area option to make sure she is in a valid location.

Make sure she doesn’t have any stealth things turned on, or other things that might make here invisible. For instance, if there is an enemy faction nearby, she may go into stealth and invisible if she feels threatened, and she may be doing this before you can get your test character there to see her.

Same here, I get this problem myself fairly recently.

Well, I still can’t make the test NPC visible. Either stealth or a bug?

-Changing the test NPC’s faction to merchant does not help.
-Clearing everything out of the NPC’s inventory (i.e. making her naked) does nothing.
-Changing the goblin’s faction to anything other than Hostile makes the goblin disappear, but doesn’t make the test NPC visible.
-There were no other hostiles on the map except for the goblin, so stealthing in response to hostiles isn’t the cause, seeing as removing the goblin does not solve the problem.
-Adding a Sharwyn (stock friendly NPC) works normally.
-Changing Sharwyn’s charisma from 16 to 18 causes her to disappear, however.

Ive had a long day, and I’m quite tired, but i actually remember the fix now for the issue i had haha.

I went and remade the character in a seperate module and copy and pasted it over to the existing module then suddenly poof! it was there now!


No dice. I can’t seem to copy from one module to another.

How did you try to copy the NPC? The standard way of doing it is to go via the file menu and export them as an erf file. Then import the erf into the second module.


Tried that, still doesn’t work. Can I upload files on this forum? The only remaining option seems to be to email tech support and see if they can fix it.

You can upload to e.g. Dropbox, then post a link here.

Or SendSpace (or similar) if you want an anonymous upload (but watch out for ads (and this isn’t an ad)).

Good point; here it is:

The script you have to fire for the conversation script (set_app_to_me) of the NPC has EffectDeath();

Remove the script, NPC is not killed.

void main()
object TargetPlayer = GetNearestCreature(CREATURE_TYPE_PLAYER_CHAR, PLAYER_CHAR_IS_PC);
int myheadnumber = GetCreatureBodyPart(CREATURE_PART_HEAD, OBJECT_SELF);

SetCreatureAppearanceType(TargetPlayer, APPEARANCE_TYPE_HUMAN);
SetCreatureBodyPart(CREATURE_PART_HEAD, myheadnumber, TargetPlayer);




1 Like

I removed the script, but it doesn’t help.

The script was only supposed to run on conversation, anyway, and since she never spawned in the first place I could not initiate conversation. Also, since she is only ten feet from the player, her death should show her body falling to the ground, right?

Did you try to play the module and see the NPC?

I tried the module you offered.

The NPC is not there.

I loaded it in the toolset, and deleted set_app_to_me from the NPC’s OnConversation, the NPC is there upon loading the module.

Doesn’t get any easier than that.

With the script not removed


This seems to be an EE bug. The same module (just module.ifo edited to allow me to open it in 1.69) works fine.

The script in question is not firing (which is as expected as there should be no shouts or convo clicks).
And even if it was, EffectDeath() is just an effect creator. It’s not applied to the NPC. There’s something odd in EE making having that script there fail to create the NPC. I didn’t test it in EE since others have done that. Weird though…

So it’s not the script. It’s something about painting the blueprint. The script is a red herring. If you open the module in the ee toolset and simply open the properties of the NPC and close w/o making any changes, then save and play, the NPC is present. To remove the script you opened the properties.

I then painted a new one and it did not show up. So I did the same open properties thing and then it did. Still weird but at least less so than a unexecuted script causing issues :slight_smile:

Edit: I should add this above is EE.

…Alright, I guess I have to write tech support. I still can’t get the NPC to spawn when loading up my module.

Thank you, both of you.

So I poked at this a further in EE. The problem is that your blueprint has 3 entries for the same class at level one. This is a snippet of the diff between the non-working area and what it looks like when I just open/close the properties for the NPC.

@@ -50,14 +50,6 @@
         __struct_id: 2
         Class: {type: int, value: 10}
         ClassLevel: {type: short, value: 1}
-      - !,2013-07:struct
-        __struct_id: 2
-        Class: {type: int, value: 10}
-        ClassLevel: {type: short, value: 1}
-      - !,2013-07:struct
-        __struct_id: 2
-        Class: {type: int, value: 10}
-        ClassLevel: {type: short, value: 1}
     Color_Hair: {type: byte, value: 1}
     Color_Skin: {type: byte, value: 1}
     Color_Tattoo1: {type: byte, value: 1}

If I take those extra class entries out of the blueprint I can paint new ones that just work. I don’t know how you managed to get wizard listed 3 times for class. I have not tried to do that in the creature wizard.

Edit: class is wizard not monk. Fixed formatting.

Fwiw, this is not ee specific. My earlier tests on 1.69 I had already opened the properties window. The game won’t load the creature in this state although it paints fine in toolset. Opening properties seems to save it valid.

Still, odd that the blueprint was messed up. Did you do anything else like edit in Leto? I could not get the creature wizard to let me put a given class in more than once.

Edit: one more follow up… if you just edit the blueprint properties and okay (even changing nothing) it seems to fix it up too. How about packages? Did you have custom packages in the module you created this creature?

I did notice the apparent three classes. How do I get rid of those? Is Leto the language you were using above?

I have yet to try to test that (real life was busy today), so I’ll work on it tomorrow.

Thanks again!