Custom Painting problem, getting error

Hello everyone, I think I’m stuck in a bit of a problem that my instinct tell me is rather silly but my brain can’t get around it.

Straight to the point: I’m trying to make a custom painting following the guide below:

I followed every step to the letter and managed to create my own painting and all. However, when I try to view the painting in the toolset I get the following error:

System.FormatException: Input string was not in a correct format.

at System.Number.StringToNumber(String str, NumberStyles options, NumberBuffer& number, NumberFormatInfo info, Boolean parseDecimal)

at System.Number.ParseInt32(String s, NumberStyles style, NumberFormatInfo info)

at NWN2Toolset.NWN2Data.Instances.NWN2PlaceableInstance.get_Hook ableInstanceType()

I believe the last line is where my problem is, but can’t figure out what may be causing it.
My guess is that it has to do with where I’m placing the existence of the painting in the placeables.2da line.

I made sure to use a free line and even checked nwn2 wiki to see what other mods may be using certain lines (mods that for the most part, I do not have, so it shouldn’t affect me anyway)

Other than that, I wouldn’t know what may be causing the error.

Unless it has to do with the image itself, but since I followed the tutorial step by step with the same programs, I don’t think that should be it?

Any tips and hints will be welcome.

Thank you.

EDIT: I changed the line position, the same result, changed the label and NWN2ModelName (also remade the images with the new name) same result.
Made a new, clean override folder just in case, the same result.


Did you by any chance include a space in the name of your painting (in the “label” column)? If yes, you’ll need to surround the name by " to tell the parser that the space(s) between “” are not columns separators.
Something else worth checking, if you use the tab key as the column separator: make sure there’s only one tab each time (two tabs mean two columns. Between them, there will be an empty column: this will offset the rest of the table!)

I’m using 2DA/TLK Editor so not tabs.
Also no spaces.

I even used Fix2da.exe and Tidy2da.exe to find possible errors and to make sure everything was in order but the results were negative there.

in placeables.2da what is the value of “IsAccessory”?

( i think it should be “0” )


Once again you’re my savior and hero.

Yes, that was it (among other things that I needed to enable as well that I didn’t know had to be enabled)

So yeah, I knew it was something that silly, but I didn’t know whether to pay attention to it or no.

It works now, thank you ever so much <3

1 Like

thank the folks at JetBrains for their (free) c# decompiler  ;p