Destroy tree?


#1

So I’m trying to remove a tree through the command DestroyObject in a script…Is that not possible? I doesn’t seem that way. I know trees are a bit wierd in some aspects, but at least I thought they were removable through scripting…


#2

First, make sure that particular tree is not a static placeable (if it is, uncheck the static box) and secondly when you attempt to destroy make sure that you also use the SetIsDestroyable(…) function to TRUE before you call the DestroyObject.


#3

I’m afraid that’s not possible because it’s a tree. If it had been a placeable that would have worked.


#4

And you can’t just make a placeable that looks like a tree?


#5

Good suggestion, however when looking through appearance there are only a few “tree appearances” and those are mostly just without a crown.


#6

There is no known way to address trees via script, sorry.


#7

And it’s not possible to take the appearance of a tree and put it into say placeables.2da or something like that, and then make a placeable that looks like a tree (like a fir-tree)? I’ve tried for a few hours now, searching and searching the vault and nwn2 nexus for alternatives to do this but no such luck. I just had a small quest about chopping down trees which I thought would have been a bit of fun…


#8

It’s been years, but I created my own crafting system for a server I ran. I definitely had trees that could be destroyed but they were placables. I think I used several placable trees from the CEP. Wish I still had the code but that was about twelve years ago. If you can find a placable that you like (some kind of clash with the existing tileset IMHO) and use it you should be able to make it destroyable.


#9

CEP is nwn1, this is nwn2 where trees are normally speedtrees rather than built into tileset or placeables.


#10

No, that’s not possible. Speedtrees trees are their own thing.


#11

There are several tree placeables from stock NWN2 SoZ that can work just fine, can’t you use those for your purpose?


#12

Actually, that jungle 07 one looks quite ok. I would have rather it been a fir-tree but this could actually work. I didn’t think it had a crown at first because the tree is so large (and I didn’t zoom out enough). Now that I see your picture and look at it in the toolset maybe I should use it.

Yesterday, I decided that maybe I could do the quest anyway without the visuals of the tree disappearing but…Well, I’ll try it and see. Thank you for all the help Clangeddin, kamal and Girko187!

Edit: Ok, I tried it but in game the trees just don’t fit with the environment. I think I’ll have to go back to not destroying and removing the trees in game. If the environment had been a jungle it might have worked well but as it is now…well, back to square one, I guess.


#13

I believe rjshae has some placeable trees in one of his packs.


#14

The Dragonlance pack also has a nice-looking fir placeable: https://neverwintervault.org/project/nwn2/prefab/placeable/dragonlance-pack-1


#15

Thanks Grog! I’ll try that.


#16

I don’t get it. I tried this but it doesn’t work. The placeables have no appearances. Took the dragonlance_pack1.rar and unpacked it, put it in my override folder. Put the placeables.2da and put it in my override folder also (I have no other placeables.2da file there so there should be no problem) Imported the blueprints.erf into the toolset. When looking at the placeables the appearance line is blank on every placeable in this pack:

It must be something I’m not getting, something I’m doing wrong…


#17

Well those are dead trees (in the Sundry Items pack), so they may not be suitable.


#18

If you do get the placeable appearance that fits your module, I do have choppable tree scripts you can use in my Kings Festival Campaign. The scripts check for the weapon type and damage type and when the tree is successfully chopped down replaces it with a stump and gives your chopper a plank of wood for his hard work.

Specifically look at module KingsFestivalMod2 area 1000_ext_test.