Disappearing Placeables (On A Reload)? - (SOLVED)

#1

SOLVED: The problem was due to a function that I was using - See last post.

Now this is one of the weirdest bugs I have ever encountered … I will add screenshots to show what I mean … Any guidance appreciated.

UPDATE: Actually, I just discovered another part of the wall had disappeared on a reload and fresh test - and the only effect that was “running” then was lightning in the area.

UPDATE 2: It appears that converting placeables to environmental objects may resolve the issue. However, that has currently messed a couple of other things up, like doors, which I need to fix. :frowning:

UPDATE 3 (POSSIBLE SOLUTION): OK, I believe I can confirm that changing placeable object to environmental objects does appear to fix this problem, even though it was not a problem in the past.

I am still interested if anybody else has come across this or something similar with respect to placeable objects and potential effect issues.

  1. Wall with archway OK.
  2. Beam affects start and finish.
  3. Save game after beams have finished.
  4. Reload game, and the wall is missing its archway.

Now the supporting screens …

The first shows the archway intact!

The second shows the beam effect passing through textures.

Look closely at the save image (arch shows present still).

Arch missing on a reload!

Sometimes, the entire building can be missing and other parts of the wall. It looks as though the “beam” effect somehow damages the objects that make the wall, etc.

Any advice appreciated.

Wall now missing!

0 Likes

#2

Is the wall really gone or just clipped out of view somehow? I’m intrigued…

1 Like

#3

Well, you CANNOT walk through the gap (where a wall used to exist), but that’s probably due to having been baked when there was a placeable object originally - and I have not re-baked since swapping them all from placeable objects to environmental objects.

So, it’s as if the placeable has been “destroyed” somehow by the VFX. Whether that’s because in creating the VFX it had problems and somehow corrupted the placeable through which it passed, I don’t know? As I say, maybe a VFX/placeable/NVidia issue? NOTE: The placeable appeared to still be intact until after I reloaded!

It’s really weird and unpredictable anyway, as I said, I also had some “destroyed” when just walking around in a thunder storm. And yet, I never had any issues at all prior to activating the beams at some point. Now they appear to disappear quite randomly.

The only good definite was the fact that they do not appear to suffer from the problem once converted to the environmental aspect. I don’t know enough about the differences between a placeable and an environmental object to say anything else, but would also be pleased to hear from somebody who knew better.

I even tested a saved game from my wife’s computer (where it was first encountered), and the saved game was still “corrupted” on my computer. And doing like for like on each computer (mine and hers), we both get destroyed walls. :frowning: (Both games are being run on latest Windows 10 64 bit build and latest NVidia drivers.)

0 Likes

#4

Is the script somehow removing the plot or static tag from the wall? Maybe the wall chunk is somehow turning into a destructable?

0 Likes

#5

There are no scripts associated with the effect that have anything to do with the walls that go “missing”. Don’t forget that entire buildings went missing too - and I even had one nowhere near the beams that disappeared. And, most importantly, these missing/destroyed objects do not look destroyed or missing at the time of saving. (i.e. They are still present!) They even still show in the “save image” upon saving.

However, by the time we load (or re-enter an area after leaving it), the buildings/wall/objects are simply gone. It is most weird. :worried: Thankfully, changing from placeable to environmental objects does appear to resolve the issue, so I do understand why you may have thought this.

My only “clue” to date is that it appears to be related to VFXs somehow - as the objects go missing after a VFX has “affected” the space in which they stand … if that makes sense. i.e. The missing walls are most obvious because the “rays” pass through them, and I am guessing a “lightning” VFX may have been the cause for the occasional random building elsewhere (which did not have the other beams pass through them). Destructive ray gun anyone?

1 Like

#6

That’s wild.

1 Like

#7

OK - Having continued to play further. my wife has discovered that a placeable object, even in a different area has gone missing! This is a lot more serious, as it is required to move forward.

I am going to try to look into this some more, but this is quite a severe problem that appears (as I stated above) to be an impact of VFX on placeable objects.

Again, I raise this in case others have experienced anything similar.

0 Likes

#8

Resolved!

1 Like