Dynamic placeable rendering lag

Is it just me, or has the delay in rendering dynamic placeables got worse in recent versions of EE?

In 1.69 dynamic placeables generally appear instantly when you enter an area or load a saved game, so that they seem to be baked into the tiles. Sure, there are lighting differences, and rendering fails at 40m, but otherwise they look fine.

In EE now, for small non-static placeables, I can just detect a fade-in, but maybe players won’t notice. For larger placeables, it’s problematic. For example, I doubled the size of a carpet. In game, I see the bare floor for a moment, then the carpet gradually fades in.

I guess I could black out the area while this is happening, or double the size of the model and make it static, but that kinda defeats the object of scaling placeables.

Does anyone have a better workaround?

Problem doesn’t occur with the 2 x scaled carpet when it is the only placeable in an empty area using a very simple tileset (CEP City Interior - Home terrain).

Could tileset be an issue? Seems to occur with the latest EE tilesets to some extent, also noticeable in Ancarion’s Castle Interior. Will research more.

Tried compiling the tileset, but that didn’t fix it.

Carpet is already compiled.

So I gave up. Made a larger static placeable using the “scale” parameter in the model. Works in the toolset, but not in game - anyone cast any light on that?

Hello,

I don’t have a solution, but what’s the reason to make that thing dynamic?

Btw. I sometimes notice “creation lags”, even on 1.69. Maybe it has something to do with the line of sight?

To use the new placeable scaling feature, it must be dynamic, even if the size is pre-set in the toolset.

The immediate example is a carpet that I would like to fill the room.

More generally, any placeable that will be animated, referenced or acted on in game has to be dynamic.

I’ve started to notice that fade-in is getting worse as my module gets bigger, even on dynamic placeables that are not resized. Even doors do it in some cases.

Yes, I am seeing this behavior with non-static placeables on my module. I didn’t know the cause so this at least helps me turn the things static that don’t need to be scaled.

1 Like

Finally have a solution that works - a static version of the model in which the vertex list is explicitly larger.

So, if the original model has vertices

10 10 0

the new model (which is three times larger) has vertices

30 30 0

It appears that the “scale” property of the mdl format works in the toolset but not in game, unless the placeable is dynamic (i.e. not static).

As noted from the outset, dynamic is unacceptable because of the visible lag in rendering the carpet.

I found a old comment somewhere in my researches that “large things are supposed to be tiles, not placeables”. Placeable scaling does seem to work better for smaller objects, but I sense that isn’t the whole story here.