EE Mod Compatibility

I have experienced problems with some Mods under EE and wanted to share these issues to see if anyone else has had the same (or other) issues.

Use this topic to share your own experiences and let me know whether the problems I have been having are peculiar to my setup or common to other players.

Crashes on start

  1. Caereena - Krakona Rising. Seems to work with dev version 8187.

Crashes when loading saved game

  1. Blackguard: Becomes unplayable after running a cutscene, which then tries to load an area.
  2. Swordflight.

Careena seems to run fine for me on EE. Actually the level up/down mechanism is a pain. But got past that and the starting cut-scene. Stopped at going to see grandpa.

The system I tried it on was win 10 64 bit, geforce 750ti, i5 4590. Are you trying to run it on integrated graphics?

Will try the others later.

TR

Thanks for testing. I wonder why Caereena doesn’t work on EE for me.

I have a NVIDIA GeForce GTX 1080 Ti.

Also, I inadvertently switched to EE while playing Swordflight and it was working OK for some time before I realised. I have switched back to NWN to avoid any issues later.

I used Leto to set the MinGameVer so I could revert an EE game save to NWN.

This seemed to work fine, until I noticed that doors opening to an exterior did not have the transition area to click on.

Does anyone know what else could be changed so that NWN can be used to load and play an EE game save?

Many thanks for any help or suggestions.

You can also use this, made (well, by me…) exactly for the same purpose.

Did you look into the cause of area transition problems? By “did not have the transition” do you mean there was “nothing beyond the door” or that it transition trigger was usable but didn’t work? Did it afflict all to-exterior doors or just some of them? What happens when you load a “broken” save into EE again?

There is no transition area to click.

Loading into EE again provides functioning transition areas to click.

I do not have the knowledge to investigate further, so I started the game again using NWN. In EE, the game was crashing when transitioning to certain areas or loading a save game for some areas,

Maybe it’s invisible or rendered badly on your system? Did you try to run through the door with WSAD? If it is not tileset-specific bug then it might be a regression introduced into the engine. Perhaps it somehow cannot find the transition target and therefore hides the trigger.

Thanks for responding.

I don’t remember whether I tried WSAD or not and now I have deleted the save games and playing under NWN from the start, which has no door issues.

Just tried Caereena - Krakona Rising with the latest dev version (8187) and it did not crash.

OP updated.

Hit an EE problem with The Song Divine on area transition from Base of the Dragonspine Mountains to The Gnomes - level1. The game crashes when you click the hidden door.

I edited the game version to load the save game in NWN, which allows the transition to work. This is OK until you try to go upstairs and the problem with doors after loading an EE game save into NWN occurs (ie the door has no transparent area to click). Loading the game into EE allows you contine, however, although you can exit to the Dragonspine area, you can’t go back without crashing the game.

BTW, I was unable to edit the OP with this information - is there any way to do that?

If you post your .log/.dmp files from the crashes, we can figure out what is causing them exactly - and hopefully fix in next version of EE.

No log or dump files are created - it just terminates. The issues I described on the OP all display the same symptoms (no log or dump files).

I think at some point, dump was created for a similar issue, which I posted but have had no feedback.

If I do manage to get a dump, which happens occasionally if you try often enough, I will post it.

Edit:
I did manage to get a dump and have submitted it.

1 Like

I have discovered that the The Song Divine area transition problem is caused by Beamdog Enhanced Workshop Items. Uninstalling Workshop Items resolves the issue.

I have now managed to play all the games listed in the OP without a problem.

Some of the issues were caused by CPP. @Shadooow has provided me with three components that seem to have resolved the problems. In the absence of general availability of @Shadooow’s fixes, I recommend uninstalling CPP for EE until a new version is released.

Do you have any advice for Arriki? (See Blackguard page).

I already responded to Arriki on the Blackguard page. Did not help because CPP was not installed.

1 Like