EE - some CEP placeables look too dark

Can anyone shed any light (literally) on what might be happening to cause this?

As you can see, Beamdog has closed the ticket, presumably because it’s a custom content issue, but the problem is easy to reproduce, and will affect CEP users amongst others.

In case of the paintings, it’s (edit: probably) that the ambient and diffuse values are low:

ambient 0.200000003 0.200000003 0.200000003
diffuse 0.800000012 0.800000012 0.800000012

Set those to 1.0 1.0 1.0 in the model with a text editor and it should be fixed. In gmax, this can happen when the creator forgets to tick the “Over-ride Mat Values” checkbox on the AuroraTrimesh modifier. If you see modified creatures or armourparts that are conspicuously darker than other parts, it’s very likely the same thing.

The showcase glass turning solid black when changing from 1.69 to EE (?) doesn’t look like the same issue, though. :thinking: I’ll go try and dig it out of the CEP, see if anything stands out.

That “shading” effect is usually (99.9%) an ambient/diffuse issue. Keep in mind, however, that sometimes ambient diffuse settings are intentionally set different from 1.0. For example, some of the BioWare desert placeables from SoU have an ambient/diffuse setting that equates to a beige color.

The glass is a familiar issue that happened way back and was fixed, but I can’t recall exactly what the issue was. Strange that it has reappeared with EE. These display cases are also in Project Q. Have you tried the Q models? If they work, drop TAD a note and he can put the Q models in CEP. If you don’t have the Q models, I’d be willing to post them to dropbox so you can grab just those models (they will probably have different names though, so you’ll need to include a copy of placeables.2da in the test hak.

EDIT: Just a thought, but are the CEP models of the display cases compiled? If they are, try them decompiled. Compiling sometimes messes up things such as animations, emitters, and texture effects

1 Like

If the issue is not present in the Q version, could you upload them please, @Pstemarie? :smiley:

I’m switching settings on the glass pane around at the moment, seeing what does or doesn’t make a difference. Decompiling, by itself, doesn’t alter the outcome, but if you remove the texture (bitmap NULL), you can get a decentish state that still looks like there’s something there:

There’s something visibly happening with them in the toolset, too:

Happens while rotating the camera. Not randomly either, but dependent on the camera position. Rotating the placeable doesn’t alter it.

Also, changing the file format of the texture didn’t make a difference.

I can’t tell you if they work in the EE edition because I don’t have that installed on my system. All the bugs with it were stressing me out so I uninstalled it.

EDIT - LOL. Turns out I still have the Beamdog Headstart installed, but when I tried to launch it, I saw there was an update and I STUPIDLY clicked update. The Beamdog Client verified the game files then stalled on the download then crashed. Now when I restart the launcher it won’t do anything WITH the EE - won’t update, won’t verify, won’t launch. I even tried reinstalling the Beamdog Client - no luck.

RANT DELETED - I really need to switch to decaf.

3 Likes

::laughter:: :hugs: Head -> Wall time? Head -> Wall time. :smiley: That’s software development for you, I guess. Fix one thing, break something else, cry into keyboard, throw things at wall, get sodding drunk, cry some more, try to fix the new problems.

OK, I’ve checked out the Project Q versions of the display case and it was an excellent lead to follow:


… save for one, the glass is working fine in them. Also, interestingly, rotating the camera in the toolset does not appear to be causing glitches with any of them, including the one where the glass is black.

Digging out the files and comparing them with the CEP ones, as well as the single non-working Q one with the working Q ones. Will report findings.

OK, I found no particularly meaningful differences in the .mdls between the Q and CEP versions, although the Q versions appear to have been run through CleanModels while the CEP ones haven’t, and the CEP versions have an odd “#part-number -1” line that I’ve never seen before in a NWN model.

But I think I’ve found the solution all the same. The case with the single Q one that was black was that it was the only one of the models I’d placed down that was set to static - as were all of the CEP ones in my test scenario. The Q display cases’ glass switches to solid black while they’re static. The CEP models’ glass becomes see-through when they’re not static.

@Proleric Try switching the placeable to non-static.

:thinking: Need to find out what’s causing this. New bug report with this new information might be helpful to BD. Can set up a repro case module if needed.

You should be able to easily fix it. Click Options/Verify Game.

TR

Sorry for the shouting. Yes, I have tried that and it will not verify. At this point, the only option is to unistall it AGAIN and reinstall - which I really have no desire to do because the more I play with EE, the more p@%$% off I get.

YES, that was the issue. It wasn’t with the models at all - we tried “fixing” them by hand then let CM3 have a crack at them. The only solution was to set them to either useable or have the “static” box unchecked.

1 Like

Many thanks! Unchecking the static box fixes the display cases!

I’ll look at the the paintings.

1 Like

Evidently, the paintings are not the same issue.

I tried unchecking the static box. In the case illustrated, this made the paintings look black in 1.69, when previously they looked OK! In other cases, the illumination of the painting changes abruptly as the player approaches, both in 1.69 and EE, which looks weird.

I’ll have a look at the ambient and diffuse settings mentioned by @TheBarbarian. This will affect paintings in CEP, too, since mine are all derived from one of the CEP models.

@TheBarbarian was on the money as usual. I finally found time to tweak the ambient and diffuse settings in the paintings, resulting in an EE bug report.

So many models need fixing for the workaround that I’ll wait and see whether Beamdog fix the bug first.

1 Like