Few camera questions

Hello there !

I have two questions about in-game camera modes:
1- Which do you prefer in general? Personally I prefer the exploration mode, which is more immersive than the strategic mode and less screwed up than the character mode.
2- How to ruthlessly eliminate the two buttons of the other two camera modes? Putting the game permanently in exploration mode would be a great improvement in my opinion.

Have a good evening everyone!

1 Like
  1. Exploration Mode

I’ve always wanted to be able to set “Exploration Mode” as the default. Bummer I have to remember to press the “*” key at the start of each play session.

2 Likes

exploration generally. But since i Pause&Puppet battles then strategy. Character mode for running around the SoZ overland map …

in hotbar.xml comment out the elements <UIButton name="STRATEGY" and <UIButton name="CHARACTER"

note that there’s a keybinding Numpad * for Toggle Play Mode under options|keymapping|game (but offhand I don’t see how no-key can be assigned)

also note there’s a bit of a bug after Strategymode is selected; after that the game will start in Strategymode no matter what you left the game in. To clear that, select your preferred mode, go into Options and just accept – that seems to clear the sticky Strategy mode ← @Axe_Edge

 
one more thing re. Camera … to get the most out of camera settings you might have to play around with the camera-values in docs/nwn2/ nwn2player.ini

particularly [Exploration Mode Options] → ;edgeturn - this is not in Options

eg →

[Exploration Mode Options]
;wheelzoom
Mousewheel_Speed_Min=5.000000
Mousewheel_Speed_Max=20.000000
Mousewheel_Speed_Default=10.000000
Mousewheel_Speed_Current=9.950001
;mouselook
Mouse_Turn_Min=0.100000
Mouse_Turn_Max=2.000000
Mouse_Turn_Default=1.000000
Mouse_Turn_Current=0.955000
;edgeturn - this is not in Options
Edge_Turn_Min=1.000000
Edge_Turn_Max=5.000000
Edge_Turn_Default=2.500000
Edge_Turn_Current=2.820000
;edgescroll
Edge_Move_Min=0.100000
Edge_Move_Max=1.000000
Edge_Move_Default=0.500000
Edge_Move_Current=0.325000
;keyscroll also keyturn and keyzoom-in/out
Keyboard_Move_Min=1.000000
Keyboard_Move_Max=5.000000
Keyboard_Move_Default=2.500000
Keyboard_Move_Current=3.720000
Fade Objects=1
Show Move Cursor=1
Mouseover Highlight Flags=74
CameraMode=1
LeftClickAction=1
Ceiling Draw Mode=0
PossessAsDefault=1
CameraFollowAlways=0
MouseMovement=1
Enable ScreenEdgeCameraTurn=1
Enable ScreenEdgeCameraMove=0

[Strategy Mode Options]
;wheelzoom
Mousewheel_Speed_Min=1.000000
Mousewheel_Speed_Max=10.000000
Mousewheel_Speed_Default=5.000000
Mousewheel_Speed_Current=3.970000
;mouselook
Mouse_Turn_Min=0.100000
Mouse_Turn_Max=2.000000
Mouse_Turn_Default=1.000000
Mouse_Turn_Current=0.955000
;edgeturn
Edge_Turn_Min=1.000000
Edge_Turn_Max=10.000000
Edge_Turn_Default=2.500000
Edge_Turn_Current=5.050000
;edgescroll
Edge_Move_Min=0.100000
Edge_Move_Max=2.000000
Edge_Move_Default=1.000000
Edge_Move_Current=0.955000
;keyscroll
Keyboard_Move_Min=1.000000
Keyboard_Move_Max=5.000000
Keyboard_Move_Default=2.500000
Keyboard_Move_Current=2.480000
Fade Objects=1
Show Move Cursor=1
Mouseover Highlight Flags=74
CameraMode=3
LeftClickAction=2
Ceiling Draw Mode=2
PossessAsDefault=1
CameraFollowAlways=0
MouseMovement=1
Enable ScreenEdgeCameraTurn=0
AutoCenterFreeCam=0
SelectedCharacterCursor=1
Enable ScreenEdgeCameraMove=1

[Character Mode Options]
;wheelzoom
Mousewheel_Speed_Min=1.000000
Mousewheel_Speed_Max=10.000000
Mousewheel_Speed_Default=5.000000
Mousewheel_Speed_Current=3.970000
;mouselook
Mouse_Turn_Min=0.100000
Mouse_Turn_Max=2.000000
Mouse_Turn_Default=1.000000
Mouse_Turn_Current=0.955000
;edgeturn
Edge_Turn_Min=1.000000
Edge_Turn_Max=10.000000
Edge_Turn_Default=5.000000
Edge_Turn_Current=2.980000
;followdelay
Camera_Lag_Min=0.100000
Camera_Lag_Max=2.500000
Camera_Lag_Default=1.000000
Camera_Lag_Current=0.484000
Fade Objects=1
Show Move Cursor=1
Mouseover Highlight Flags=74
CameraMode=0
LeftClickAction=1
Ceiling Draw Mode=1
PossessAsDefault=1
CameraFollowAlways=0
MouseMovement=1
Enable ScreenEdgeCameraTurn=1
3 Likes

Exploration mode

In nwn2player.ini, I’ve got a line CameraMode=1 in the [Game Options] section, and that’s enough to have all games starting in the exploration mode.

2 Likes

I always use Exloration mode. I too wish I would be able to eliminate the other buttons, but I’m a bit afraid of doing that in fear of bugs. @kevL_s If I were to fiddle with the hotbar.xml for this would it be safe you say?

I’ve noticed several times that sometimes at the start of a game, or something like that, there is sometimes a bug that doesn’t let you switch camera modes (I think it happens after a dialogue). Just reloading tends to take care of this.

EDIT: I tried with doing as @kevL_s said and it seems to work, I think. It looks like this now:

It would have been nice though if the two other squares to the right of Exploration mode were removed entirely.

2 Likes

Great ! Everything works, thank you very much.
Such a shame we have no way to rework entirely the UI in the toolset.

Exploration mode by far with camera centred on character, and I never leave it if I can help it.

There is a bug with not saving camera modes properly, for me it’ll always remember if I was in character or strategy mode, but never exploration mode. The fix mentioned earlier in the thread does not work for me, but opening up nwn2player.ini and setting Client Mode to 2 does make it start up in exploration mode and stay there until I accidentally enter one of the other ones.

Two ways of doing it; if you try to assign a command a key that is already in use, it’ll remove the binding that previously used it. The other is to dig in nwn2player.ini. To disable the camera change key, look for “Action118”, the default value should be “Action118=64”. Change 64 to 255 and it will disable it. Note that you have 3 different instances, under [Keymapping_1], [Keymapping_2] and [Keymapping_3], each one for a different camera mode (character, strategy and exploration, respectively).

4 Likes


hotbar_bg.zip (58.5 KB)
If you also change the background, that should do it.

4 Likes

I play almost entirely in Exploration mode.
There are times when however when differences between my PC and game settings vs what the author is building on make it hard to see some placeable or important plot clue. I’m occasionally forced to go into Character mode to be able to see or maneuver in a tight space or get the right angle to solve the puzzle or find the object I need.

2 Likes

While it is possible to remove these GUI options, unless you are doing this for yourself only, then I would advise leaving them present for those that would like the option to click on them in the GUI.

3 Likes

True. Strategy mode pleases the ones who like to control companions while pausing, and character mode is best for screenshots.

3 Likes

Oh, that’s the default GUI I see now. I like the Divine GUI so I won’t be able to use this. Maybe I can fix it myself though.

EDIT: Quite easy to fix once I knew what the file was called. However, I just noticed (and that was expected really) that the game still always starts with another mode than Exploration mode. I wish one could force my own module to choose Exploration mode by default, but I guess that is done in the ini file and every player has his own one, and I don’t think I would want to try and change anything else there and players probably have different settings there, so one shouldn’t tamper with that.
I guess I’ll just edit my own ini file then.

2 Likes

This didn’t work for me…

This however worked.

3 Likes

Additionally, from the NWN2WIKI:

Setting the default camera mode

There is no ingame option for selecting which camera mode to be use as default when starting the game.

Normally the game will remember the last camera mode used, but this isn’t the case with Exploration Mode. The game will start in Strategy Mode every time.

To make Exploration Mode default you need to edit “Client Mode” in “nwn2player.ini”.

Values are:

0 - Character Mode
1 - Strategy Mode
2 - Exploration Mode

Obviously the game will fail to remember the setting when exiting and reset “Client Mode” to 1.

To prevent this from happening set the file as read only. Make sure to remove this every time you want to change settings.

[Camera | NWN2Wiki | Fandom]

3 Likes