Floating walk bug / "ghost walk" when creating a module


I am baffled by this issue. NWN2 and all its expansions work fine on my system, but whenever I create a module (even a small test area) the PC’s walking animation is messed up. He/she just floats along with arms slightly raised, like a zombie or ghost.

See video here:


Again, this never happens in the main game, expansions, or the test module included with the game. I am baking the area as required, so the walk mesh is not the issue either.

Can anyone help?

System specs below (via dxdiag), and I’m running Nvidia v 391.24 drivers:

System Information

Operating System: Windows 10 Pro 64-bit (10.0, Build 17134) (17134.rs4_release.180410-1804)
Language: English (Regional Setting: English)
System Manufacturer: ASUS
System Model: All Series
BIOS: BIOS Date: 02/11/15 20:41:12 Ver: 05.06.05 (type: BIOS)
Processor: Intel® Core™ i7-5820K CPU @ 3.30GHz (12 CPUs), ~3.3GHz
Memory: 32768MB RAM
Available OS Memory: 32668MB RAM
Page File: 6141MB used, 59294MB available
Windows Dir: C:\WINDOWS
DirectX Version: DirectX 12
DX Setup Parameters: Not found
User DPI Setting: 96 DPI (100 percent)
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
Miracast: Available, with HDCP
Microsoft Graphics Hybrid: Not Supported
DxDiag Version: 10.00.17134.0001 64bit Unicode

DxDiag Notes

Display Tab 1: No problems found.
Sound Tab 1: No problems found.
Sound Tab 2: No problems found.
Sound Tab 3: No problems found.
Sound Tab 4: No problems found.
Input Tab: No problems found.

DirectX Debug Levels

Direct3D: 0/4 (retail)
DirectDraw: 0/4 (retail)
DirectInput: 0/5 (retail)
DirectMusic: 0/5 (retail)
DirectPlay: 0/9 (retail)
DirectSound: 0/5 (retail)
DirectShow: 0/6 (retail)

Display Devices

Card name: NVIDIA GeForce GTX 1080 Ti
Manufacturer: NVIDIA
Chip type: GeForce GTX 1080 Ti
DAC type: Integrated RAMDAC
Device Type: Full Device (POST)
Device Key: Enum\PCI\VEN_10DE&DEV_1B06&SUBSYS_66963842&REV_A1
Device Problem Code: No Problem
Driver Problem Code: Unknown
Display Memory: 27461 MB
Dedicated Memory: 11127 MB
Shared Memory: 16334 MB
Current Mode: 1920 x 1080 (32 bit) (60Hz)
HDR Support: Not Supported
Display Topology: Internal
Display Color Space: DXGI_COLOR_SPACE_RGB_FULL_G22_NONE_P709
Color Primaries: Red(0.644055,0.332531), Green(0.286633,0.601086), Blue(0.152844,0.076672), White Point(0.313000,0.328625)
Display Luminance: Min Luminance = 0.500000, Max Luminance = 270.000000, MaxFullFrameLuminance = 270.000000
Monitor Name: Generic PnP Monitor
Monitor Model: ASUS VH242H
Monitor Id: ACI24F3
Native Mode: 1920 x 1080§ (60.000Hz)
Output Type: HDMI
Monitor Capabilities: HDR Not Supported
Advanced Color: Not Supported
Driver Name: C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_95d88c9d04436846\nvldumdx.dll,C:\WINDOWS\Sys tem32\DriverStore\FileRepository\nv_dispi.inf_amd64_95d88c9d04436846\nvldumdx.dll,C:\WINDOWS\System32\DriverSt ore\FileRepository\nv_dispi.inf_amd64_95d88c9d04436846\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileReposi tory\nv_dispi.inf_amd64_95d88c9d04436846\nvldumdx.dll
Driver File Version: 23.21.0013.9124 (English)
Driver Version:
DDI Version: 12
Feature Levels: 12_1,12_0,11_1,11_0,10_1,10_0,9_3,9_2,9_1
Driver Model: WDDM 2.3
Graphics Preemption: Pixel
Compute Preemption: Dispatch
Miracast: Not Supported
Hybrid Graphics GPU: Not Supported
Power P-states: Not Supported
Virtualization: Paravirtualization
Block List: No Blocks
Catalog Attributes: Universal:False Declarative:False
Driver Attributes: Final Retail
Driver Date/Size: 3/14/2018 5:00:00 PM, 949016 bytes
WHQL Logo’d: n/a
WHQL Date Stamp: n/a
Device Identifier: {D7B71E3E-5846-11CF-5678-9B461BC2DA35}
Vendor ID: 0x10DE
Device ID: 0x1B06
SubSys ID: 0x66963842
Revision ID: 0x00A1
Driver Strong Name: oem25.inf:0f066de35d9aeff6:Section118:\ven_10de&dev_1b06
Rank Of Driver: 00D12001

Have you made any changes to the appearance.2da file? It sounds like the wraith animation.

Hi @rjshae - I didn’t make any changes to the .2da file that I’m aware of

I do have 3 mods installed in the override folder for use during play (Item Appearance Changer, Portrait Pack, and the Facelift pack). Looking through these, I didn’t notice any 2da files being overwritten. Also not sure if the override folder impacts the toolset.

It’s odd that a wraith animation would occur for the player/PC. I wonder if a reinstall of the whole game is the only troubleshooting option left?

I’ve seen that happening before. Try clicking farther away when clicking to move and see if the pc doesn’t switch over to a normal move animation.

I think It’s a game engine bug where the character gets stuck in the default animation position and doesn’t adopt any normal animations.

1 Like

first try to rename the neverwinter nights 2 folder under mydocuments. starting nwn2 the game will create a new blank folder without mods and your stored settings. don’t worry about that. repeat everything you did to create a test module. if it works this time, delete the module and copy your old module with the bug to your blank nwn2 folder. if it works now too, bring those three mods back one by one always testing your module afterwards.

1 Like

Sorry for the delay in response, been slammed so took me a while to try these tips.

@Semper - I tried this method (good idea), in addition to disabling all toolset plugins that I had installed for better usability.

The issue still persists.

@kamal - this tip actually worked (though it doesn’t solve the issue of course). When I tried clicking to move a sufficient distance away the animation looked normal. When I tried a “fresh” test mod following Semper’s advice, the area I created was only 4x4 (“Tiny”) so I could not click far enough away to fire the proper animation. Still the weird floating / lack of walk animation.

Again, it’s really weird this only happens in mods I create, not in the core game, expansions, or even the “example” mod (I forget the name) included with the game.

This bug is a shame, as I never had issues with the NWN1 toolset and got tons of use out of it years ago. Unfortunately, NWN2 is just a better-looking game in general and I don’t have an interest in modding ugly-ass NWN1 any more. lol

Anyway - I think my last option here is to re-install the game completely (after backing up my saves & mods), unless anyone has other suggestions or fixes. I would try re-installing just the toolset alone, but that’s not an option I’m aware of since I bought the game on GOG.

Client Extension ?

/just checking

Hi @kevL_s - I’ve tried both vanilla and with the Client Extension. The issue is omnipresent no matter what.

The game itself actually runs choppier w/ the CE on my machine, and is even crashy. But I am keeping it installed just for if & when I want to try some multiplayer.

Other than that, it hasn’t solved the issue unfortunately. But it sounds like if I save (a.k.a. rename) the Documents NWN2 folder and replace/revert name after a testing a totally clean game install (assuming the issue still persists even then), I would give up on modding hopes but at least finish playing the game.

Thanks for everyone’s help & please keep fixed coming if you are aware of any. I wish I could jump into actual modding & use this forum for something other than troubleshooting this bizarre bug.


1 Like

Hi,i have this problem too .
also sometimes i get this animation when i press
shift+2 = run
i tried bake area again sometimes it’s help.
i tried reload pc/game(im thinks it some temporary files bug)
and seems like solution this problem (and all works ok).
but sometimes( rarely) this problem happen
don’t know why.
you need try reload pc
if the game is on DVD
try to take out the disc and insert
and run again
this should help.
if the game is on pc
try restarting your pc
this should help.
i hope it help you and others.

This happens sometimes for me too. My theory is that it happens when an area is a bit “heavy” on the game or the computer, like the game doesn’t have the power, or have problems, to portrai the animation properly, but I don’t know.

1 Like

Hi all,

Seeing some recent activity here, so wanted to provide an update:

I’m no longer experiencing the issue. It must have been either (a) some weird NVidia video driver issue or (b) some weird Windows 10 issue, both of which were patched. The issue just stopped happening many months ago, and has never surfaced again.

I’m now building a mod with no such issue and having a great (yet slow) time doing it.

Very odd bug and still not clear on what was causing it in my case…thanks for the follow-up!

1 Like

I am having the same problem. Does anyone know a solution to it?

It only happens in the interior areas. And, the walking is fine until the character stops for the first time. Then it just floats instead of walking again. So, it seems that in the interior areas the walking animation does not reset.

This happens to me randomly. Both outside and interior areas. Don’t know what to do about it. I tend to just ignore it.

I get it mostly on hasted characters going up/ down slopes when testing an area with someone that can run around fast ( down looks quite funny but would look much better on skis ).

However in the same areas when doing a playthrough I can’t remember ever seeing it. It could be something to do with baking because those areas get baked a lot more when I add things after initial testing.

Whatever it is it’s not your fault.

OK, I was stubborn and got lucky - just found the cause and the solution!

(Edited this a few times…)

It is due to missing lights/shadows. Place a light that casts a shadow, also set the “has directional light” and “directional lights casts shadows” in the area properties and the walking will be normal (at least around the placed light sources). So, try tweaking the light/shadow coverage. The placed light can even be set to 0 intensity and it’s shadow to 0, only the range matters. So, the fix is to place a light in the middle of the interior area, set the intensity and the shadow to 0 and the range enough to cover the whole area.

I found this out by importing an interior area from the game and it worked in my module until I removed the lights.


So the reason would be “no light, no reason to show the animation”? (as it would be in the dark. Interesting, thanks for sharing!)

1 Like

Yes, I was thinking the same. It looks like an optimization attempt.

I don’t recall the issue in the past so I suspect it has to do with an update in DirectX or the graphic drivers. One that happened after the game support ended.

A similar case is with the choppy character movement. When I installed the game yesterday, after a decade, the characters were moving choppy and I found out that there is a directx9 dll that should be placed in the game folder and that solved the issue.

So, maybe, there is a solution to both problems that involves installing a particular version of directx and graphic drivers.


alek73… Next time I see this happen I will test your fix, well done, you might have just solved a mystery.

ps. beware too many lights in a tile can mess up your water, I don’t know if this applies to invisible ones but it might.

Please, let us know here if you confirm the solution. Hopefully, it works for everyone.

Ok, I have this problem again now. It’s an outdoor area 12x32, so it’s quite big at least the height, if that has to do with anything. The PC doesn’t float all the time when walking in the area, just sometimes. There are no extra lights placed in the area and it’s set to Natural True, Day/Night Cycle True, Directional Light Casts Shadows True and Has Directional Light True. I tried with setting Directional Light Casts Shadows to False, but that didn’t do anything. I’ll try some more stuff…

EDIT: Tried with setting Natural to False, but that didn’t do anything either.