Fx_fire_lg (Corrupt Sound File Toolset Crash)?

Hi All,

I tried using the fx_fire_lg SEF file and it kept crashing the toolset whenever I tried to use it.

I then loaded it into the VFX editor and the only way I can play the sef without crashing the toolset is by removing the sound property.

Is this just me, or is there a problem with this SEF and its sound property?

This would not be the first SEF I have found that crashes due to an associated sound file.

EDIT: I don’t know if there are any “coding experts” out there that know how to check for memory leaks or issues in this area, as I am reasonably certain that it is this area (sounds with VFXs) that causes the biggest memory issues with NWN2. The gauntlet has been thrown down. :wink:

EDIT 2: I can add that I “fixed” the sound file format from whatever it originally was by importing and exporting via “Audacity”. That exported sound stopped the file from crashing. :slight_smile: The file size was much larger though.

EDIT 3: I also note that in-game, the sound file cannot be heard due to the fact that by the time we reach the fire, the sound file has finished playing (7 seconds), and the sef file was not set to loop, or be continuous. My guess is that these sef files (with sounds) may actually have meant to have their sounds removed, and a builder place them afterwards.

EDIT 4: Not sure what the problem is with the OC sound file, but it loses all quality and texture when used in a sound file. Thankfully, my own edited version of the file (with Audacity) plays as it should.

Thanks in advance, Lance.

1 Like