Game crashes

Hi all.

I need help identifying the cause for a crash that occurs for a player playing my campaign. He enters a trigger which fires a conversation and his game crashes. The script that’s attached on the trigger has been working in his game in other situations, so I know it’s not that. The conversation has a couple of action scripts attached to the first node.

ga_create_object and ga_vfx

The first one creates a creature. I already asked the player to tell me if the blueprint exists and its file size, because in my experience corrupted files have 0KB. It exists and has 23,9KB.

The second just spawns an effect on the location of a waypoint.

Some facts that may help

He is the first person to ever had this happen. I’ve never had anyone report a crash on that area.
His override is empty.
The first node is spoken by an ipoint that is already placed in the area. Any subsequent node by the creature that is created on the first node. However, the player crashes immediately. He doesn’t get to see any node.

Any help would be appreciated. Thanks.

Hi andysks,

I don’t know if this is any help, but I have had VFX files crash my NWN both in game and from the toolset.

It turned out to be that my computer does not like some sound file formats associated with the VFX.

You could try offering a version that bypasses the VFX to see if that helps. (In case it is a similar issue.)

Cheers, Lance

Thanks Lance, that’a big hint. The player said now that just before the crush he heard something sounding bad.

Hi andysks,

Do let us know what fixes it in the end.

If it is the sound issue I refer to, then it may be due to a Windows update gone awry, or simply another system level program messing with it, such as some video/sound editing software (with codecs). NB: Reinstalling NWN2 did not fix the issue for me.

I have tried to get to the bottom of my own NWN2 sound issue for some time (it’s at least a few months old or more for me), but have not been prepared to go as far as a Windows reinstall yet.

EDIT: Here is my original post: Too Many Flames? Or Maybe Sounds? (With VIDEO of dropout.)

Keep me informed.
Cheers, Lance.

1 Like

Hi again,

OK, I did some digging around on my theory that there was an issue with my sound somehow, and eventually managed to find this program that fixes codecs:-

This “temporarily” fixes my sound problem and crashing from toolset - but I am unable to confirm game crash fix as that is random. Basically, if I run this program to “fix” my codecs, then the toolset works again until I try running the VFX again, at which point the sounds appear broken again. I then have to rerun the utility to “fix” my codecs again to enable the toolset to work on a fresh opening.

Now that I have shown this to “fix” the problem, maybe somebody with more programming / sound codec knowledge will be able to provide a permanent fix.

EDIT: The specific “fix” that temporarily fixes my issue is the “Re-register base DirectShow filters”, which then must fail again after I close NWN2 toolset.

I suspect that there may be many players who may have this potential problem, as it is not an obvious one to track down.

Cheers, Lance.

Hi there Lance. I sent a DLG file to the player with the sound effects removed. He still crashed, but this time he heard no weird glitchy sounds while crashing. He also said that the game hanged for some seconds before crashing, almost as if trying to load a resource. I now sent him a replacement of the creature that is supposed to spawn there. Perhaps it was indeed corrupt in his instance. Will see.

Hi andysks,

Sounds like it may be that … EDIT: Does the creature spawn with a VFX/SOUND?

I have also been continuing my search down the sound/vfx route, and (for the record) note the following …

After applying the Codec “fix” …

  1. VFX/sound crashes toolset if I try playing the VFX sef twice in a row. (It works if I play the VFX, close the VFX editor, open and play again.) However, playing more than once will crash the toolset.

  2. Closing the toolset and reopening to play the VFX/Sound will crash the toolset again, but only if I have tested a VFX in the VFX editor.

Applying the Codec fix between toolset opening allows me to play the VFX/Sound again. It’s as if the NWN2 program “deregisters” some sound related codec on using the VFX editor to view a SEF file. (The file I use to test for consistency of failure is sp_holy_hit.sef.)

I will keep looking on this front, but let me know if removing the creature helps.

Cheers, Lance.

Graph below shows how bad this problem is for me on Windows … with multiple tests and crashes due to VFX/Sound issue.

You might be onto something. There is this parameter on ga_create_object called “Use appear animation” or something like that, I don’t have it in front of me right now. I usually leave it blank because I don’t really need it. In this case, it is set as TRUE, either as an oversight on my end or because I felt like it.

I guess it could be something hidden there. In any case, I wait now for the corrupted file check and then I’ll take it from there.

1 Like

Hi andysks,

I finally got to the bottom of what was causing my sound issues after months of searching … It was the direct filters for sound related to some old programs I have on my computer that came with the CDROM I have on the computer: Nero and Cyberlink software. The software must be past its register date or something (or just corrupted) for as soon as I disabled all these filters my toolset now works as it should!


Bear in mind that I was also having the occasional sound issue in game (causing me to crash), so this might have some bearing anyway.

EDIT: I used the tool I link to above to disable these direct filters. (I will probably uninstall the software too, as I hardly use it nowadays.)

EDIT: Maybe your user has some of these older programs or “possible” defunct filters?

Cheers, Lance.

Source links …

1 Like

Well, it wasn’t the UTC either. I had little hope for that anyway. I asked the player to try and find the filters as you say and see if there is anything there.

edit: I also asked the player to step by step try to spawn the creature and initiate the dialogie by console means. Let’s see at least which step fails.

1 Like


Hey Lance, which software is this? The links take me to some forum posts and either I am blind or I see no links there for downloads :smiley: . Probably the first is happening of course…

Hi andysks,

The link is in the post that says this (above):-

" OK, I did some digging around on my theory that there was an issue with my sound somehow, and eventually managed to find this program that fixes codecs:- "

The download is there where it says “server 1”. And the actual programs I uninstalled to get rid of these broken codecs were:

Nero Essentials and Cyberlink PowerDVD.

Cheers, Lance.

1 Like

Hi all. The player disabled the filters and there was no change on game behavior. He then tried to spawn the creature which is supposed to spawn on the first line of the convo via console

rs ga_create_object(“C”,“d02_fentomy0”,“genie_a”,0,"",0.0)

and nothing happened. No creature spawned. Note he has a new version of the UTC file. Even if it was corrupted, he now has a fresh one in the override. So… can it be that the WP spawn point is problematic? Because I can’t really think of anything else.

simplify …

// 'forcefent'
    Console script.

void main()
    object oPc = OBJECT_SELF;

    object o = CreateObject(OBJECT_TYPE_CREATURE, "d02_fentomy0", GetLocation(oPc));

    if (GetIsObjectValid(o))
        SendMessageToPC(oPc, "utc d02_fentomy0 is valid");
        SendMessageToPC(oPc, "utc d02_fentomy0 is NOT valid");

    o = GetObjectByTag("genie_a");
    if (GetIsObjectValid(o))
        SendMessageToPC(oPc, "object exists in the module");
        SendMessageToPC(oPc, "object does NOT exist in the module");

    o = GetWaypointByTag("genie_a");
    if (GetIsObjectValid(o))
        SendMessageToPC(oPc, "waypoint exists in the module");
        SendMessageToPC(oPc, "waypoint does NOT exist in the module");

    o = GetNearestObjectByTag("genie_a");
    if (GetIsObjectValid(o))
        SendMessageToPC(oPc, "nearest exists in the area");
        SendMessageToPC(oPc, "nearest does NOT exist in the area");

What would be the validity of the object here KevL? Is it the location that is being checked or the method and all the information in it?

it’s just checking if the object spawns from the UTC, bypassing the waypoint atm

give me a minute and i’ll add a check for the waypoint …

check that those strings i used in the script are correct eh

the UTC file:


the waypoint tag:


Ah ok thanks. It is not doing any spawning or convo starting, just checking the values and objects included in the whole story. Let’s see how it goes.

since this seems to be a difficult issue I should point out that i have seen GetObjectByTag() fail … have also seen GetWaypointByTag() fail …

GetNearestObjectByTag() is imo the most robust function for getting an object, but it searches the Area only

i could add those …

Funny, I’ve heard this often but GetObjectByTag never failed me. I guess I got lucky. I sent the player the script as is now :slight_smile: .