Getting an error message trying to open an area in toolset (RESOLVED) - THANKS!

good grief…

I have gotten so many little issues upgrading to CEP 2.67. On the flip side have gotten lots of great stuff too (i.e CEP weapons, new items, placeables, creatures, etc)

I’m trying to work out all these bugs that came with the upgrade or from something else I downloaded from the vault when I started these new haks.

Sigh…another issue is now I can’t open an area in my module (a Rural) tileset area. I can open other Rural tileset areas so I do not think it is the tileset…but maybe one of you can tell me what this message means and how to fix it?

gawd…I wish I had all your talents to fix this crap myself :(…this is so disheartening…

Is there someone out there I can send my area to …to look at this…so they can tell me how to fix this please

Ugh I hate that one. Caused by missing placeable or creature model

I have a not so quick fix and its tedious.

  1. Open that area in the original hak and note the actual tileset used and every placeable and creature with a new model-if it has a blueprint take note of their save location (all note if they have attached scripts or unique tags). DO NOT save them as new just find where they are (usually in the miscellaneous tab)
  2. Make sure that tileset exist in the new version (This usually checks out, but if not add it to hak)
  3. Go to new module and check those blueprints. If it has no appearance chose one for it and update all areas. if the defective area name shows up that might be it.
  4. Save and try to open area again. if it still gets out of bounds keep checking the next custom placeable and creature for missing appearances and do #3 until you do all of them or it gets fixed.

Groan…so it is either a placeable or model causing this issue…crap…could it be a tileset piece too that got screwed up? because all i have in that area is two placeable ships and a NPC that gives tickets. F’ me…why the hell did this happen???..ugh!!..always so crap with this update remake of the haks.

Geeez…there is not much in that area for blinking sake!!

All I have (looking at the old module with my other haks that I ported over to use with these new haks) are the following:

7 transitions
9 way points
one bloodsailor
one fish club

I looked for the bloodsailor and fish club in my new module using the new haks…that bloodsailor is in my monsters list and the fish club is in my items list…same references

So seriously…now what!!!


Only thing I see different is the portrait on the bloodsailor…geez…seriously…this is driving me crazy…could it be a tileset piece? I know I have tilset ships in there that perhaps a CEP override is screwing up…

Ok I did the “Find Instance” in the module…the bloodsaiolor resref is in the module as in the old one…so that is one of the two things in that area that says it is in there.

And the fish club resref is in there using the “Find instance”…

So that’s it…the only two things in the area besides the waypoints and transitions

Tileset in both are rural

Is it possible that it could be a waypoint or transition? Only things left.

But you can have all the talents. It requires some patience though.

Can you export the area into an empty module? Then put the new mod into a zip and drag and drop the zip into a PM to me? Then I’ll have a look on the issue.

I hate this unhelpful error as well, doesn’t even tell you which “list” is causing this; either 2da or maybe in this case the ttr01.set file.

But from your descriptions I’d also guess it is a missing tile model. Did you use any add-on haks for the Rural tileset when you build the area originally which are now missing? You said something about ships.

Please also keep in mind that adding cep2_ext_tiles.hak to your module will add changes to a lot of the default bioware tilesets. So if you have an add-on hak below cep2_ext_tiles.hak, it’s set file will get overwritten, possibly causing the issue your having.

Looking at the default ttr01.set file, the tiles go up to 282. The same file in cep2_ext_tiles.hak go much higher, BUT the index/tile in question - being 301 - just has a model called tpad_301 assigned to it. Which I’m pretty sure doesn’t exists and this was just meant to pad out the set file so merges with other tiles might be easier. This goes on from tile 283 to 500 btw.

This makes me happy I never touched the CEP. Just hearing about the things the people that “created” (compiled would probably be the better word) it makes me sick. I think TheAmethystDragon and Pustemarie were the only ones that cared for the CEP who even knew what they were doing.

I’m glad to see you happy, but this is not helpful for those who try to pull the carriage out of the dirt.


Hello bodah,

you’re completely right “tpad_???” is a very unusual name for a tile, and I can’t find it. If there is no entry in the palette it will probably do no harm.

However: I made a full comparison of the ttr01.set between CEP 264 and 267. The files are identical. So this does not explain the issue, it’s something else.

I guess without more input from the OP (as requested) we will not solve it.

Never for a minute did I pretend to be helpful.

1 Like

I think those “padding tiles” (tpad most likely being short for tile_padding) probably are in there since acaos (I think) from the old CEP2 team added the tileset add-ons (CEP 2.4?) so I didn’t meant to imply that this a recent issue. In fact, I don’t think this is a CEP bug at all.

My hunch is OP has a third party rural tileset add-on in his hak list and when updating to CEP2.67 he might have added cep2_ext_tiles.hak somewhere above it. This way, the set file from the first hak gets overwritten, which might very well have an actual tile model at TILE301 which was used in the offending area. Now however, index 301 points to a model which doesn’t exist and thus: ka-boom.

Ways to fix this would be:
a) removing cep2_ext_tiles.hak from his list of haks
b) moving the other hak above it

But maybe I’m totally wrong :grin:

As you said, only OP can bring light into this darkness.

1 Like

Completely missing models usually do one of two things: You either get an empty space where a tile should be or the game crashes.
The error message doesn’t indicate that a model is missing, but that the area uses a tile that has a number higher than the number of tiles in the set (if this is related to a tileset). So if the ttr set file in cep2_ext_tiles has 301 or more tiles, you wouldn’t get this error message, but likely a crash.
If this is indeed a tileset issue (which is likely because 301 is a very low number for placeables or creatures) there must be a set file which has less then 301 tiles.
Also consider that tile numbers might not match the actual number of tiles in a set if someone made a mistake.
Opening the .are file with a gff editor might help with ruling out a tileset error if there is no tile 301 used.

Also maybe Virusman could be bribed to add some important information to the error message: which 2da was being read when the error occured.

1 Like

TTR01.set has (much) more than 300 tiles, but tile 301 is somewhat inactive:



According to your and boodah’s statement, my best guess by now is a changed Hak-Order. The mod doesn’t use the set-file from CEP anymore.

Here are my 2 cents:
It seems to me that your own hak is botched somehow… and you may have to go thru files one by one to find the culprits that are causing problems for you. Not fun, i know
A couple of months ago I had a similar problem where all kinds of errors were popping up. I was still using the CEP2.65 (the newer ones hadn’t come out yet.) All the doors were gone (my son had a joke about how some rogue had come in the night and stolen them :grin:), npcs were showing up with weird looking clothing, some areas would not load, items were missing and the build model was showing all kinds of errors. It took me a while to figure it out through trial and error. I had to meticulously look at the files in my own haks (because I don’t touch the cep haks so it had to be my own haks) to find the culprits and replace them. (some of them were 0 bytes!?) and fix the 2das.
Good luck!

Hi Boodah

I don’t have tilesets above each other. I created the following haks in this order with the items in each hak:

Hak 1 - 2das
Hak 2 - misc stuff (scripts, .pwks, .txi, dwk, dlg, are, ini, plt, utc, uti, etc)
hak 3 - .dds only
Hak 4 - tgas
Hak 5 - tgas
Hak 6 to 12 - mdls

So 12 haks. I sorted out all that stuff to make it easier to find stuff

top hak being Hak 1…bottom hak being hak 12

In my old module with CEP 2.4 everything worked well. I had 10 original haks from my old module and sorted them in the correct order ensuring I would not overwrite anything. It got rid of lots of duplicates. I then added the CEP 2.67 and lots of other stuff I cherry picked from the vault in (modified the 2das) …and used the same module (my old module) and built the module with the new 12 haks.

I was so meticulous not to “override” my stuff knowing it would break stuff…but yet…here I am…several issues later…this being one of the issues.

So much has been said above in the comments I honestly do not know most of what is being said (whoosh…over my head). So I am despondent.

Currently I have onedrive that only holds 5GB. I was thinking of uploading my modules and haks from both old and new so I can send a link to whoever wants to take a look at this stuff. I do have some treasures in my modules…like a throwable net that knocksdown your opponent if he fails a saving throw…some cool placeables one can no longer find anywhere…inlcuding a DM screen from 2nd ed AD&D on a table…a placeable of our solar system, some modern stuff mixed in the module for fun…Failed Bard’s climbing animation …you can crawl up walls…etc etc.

But I’m not sure if one has to have office 365 to get the $2.00/month for 200GB (all i need as I have about just under 100GB of stuff for both modules with respective haks)…

If I can get this…then if those who want to look at this…please do…you are welcome to strip anything out of my haks…but my module I play with my friends is nothing great…lots of old tilesets…some bad shape 2das…but they worked fine in my old module…funny weird stuff…but hey…just play it with my buddies…I’m an old fart…I was around when this game was first released…till now…took a break from it for a few years now back…trying to remember how to do this stuff.