Gmax MDL export

I have gmax 1.2, NWgmax Plus and NWmax 0.8, but can’t export the model using both of those.

NWmax 0.8 fails because of this error:
gmax_error

NWgmax Plus actually does something, I can see it in the Listener Window, but when I check export directory I find nothing in there.

I also have 3ds Max 2014 and NWmax 0.8 works fine with it.

What I want exactly is to replace some body parts from one character model with the same parts from another. Let’s say, left hand. So I select that hand in gmax, save it as .gmax file, then import another model and replace (File -> Replace) its hand with the one I saved. Once it’s properly placed, I go to “MDL Base Parameters” and click “Export” button, or use “Export All or Selected” in “General Utils” tab. Either way, I can’t get model exported. There are tons of text in the Listener Window, but it’s not structured as ASCII model. I tried with and without compiling/sanity checks, tried import and export geom only - all the same.

Help me, please.

I do things a little different. its a little crude but it has not failed yet. here’s what I do (Gmax):

  • Open the character file with the body part
  • Select all objects and delete everything EXCEPT the bodypart you want to keep (You should have only 1 object left)
  • go to display/ hide object
  • now open your main character file you. Select all and go to display/freeze (everything)
  • with everything frozen unhide (the HIDDEN not the frozen) that single part and move it to the right spot
  • go to display/unfreeze unfreeze by name (select the part you want replaced)
  • next select object (select the unfrozen part, NOT the unhidden one)
  • go to modify and click the editable mesh line but do not select any of the selection modes
  • below the selections the “attach” button is clickable, click that and select the other file
  • then click the select object arrow and select the combined object (you should have only one now)
  • go to modify/editable mesh and use the element selector (3d box button) to select the old part and delete(easier on wireframe view)
  • unfreeze everything select the main file name and export. voila new part on old model

skinning it will be a whole different issue but if you have both things you should be fine

The problem is not with the method, but with the export procedure. It just doesn’t export at all, no matter what I do with the model.

This is what I get in the listener:
%D0%91%D0%B5%D0%B7%D1%8B%D0%BC%D1%8F%D0%BD%D0%BD%D1%8B%D0%B91
I googled “gmax snoopstart snoopend” and found this thread with a guy pointing on the same problem:
http://smf.asmodei.net/index.php?topic=27218.15
He was told:

it sounds as if you started gmax via the direct gmax shortuct (or directly from .exe) instead of starting it via the snooper. You must have the snooper loaded prior to loading Gmax or it will not correctly find the memory locations to actually listen properly. The script(s) from inside either version of NWmax or NWMax+ will run, but if that snooper is not loaded properly in memory, you can get that sort of error

Then I found some PDF manual with the same instruction:

Now we start Gmax, remember to start Gmax not using its icon, but using Nwmax’s icon, it will start the Snooper script too, without it you will have to paste the text from the gmax listener and copy on a text file to export the model.

That’s the mistake I made. I was starting Gmax using its shortcut. OK, now I start nwmax.exe first and have NWmax Snoop tray icon. But it doesn’t start Gmax… If I understood correctly, it should also launch Gmax. Or shouldn’t? Well, I just start the program using its shortcut again, try export and get this:
%D0%91%D0%B5%D0%B7%D1%8B%D0%BC%D1%8F%D0%BD%D0%BD%D1%8B%D0%B9

Thanks to what I read in that thread, now I know that I can copy text from the listener and paste it to Notebook++, replace all the ~ for line breaks and get my model done. Yet, I wanna know how to start NWmax and Gmax correctly to make export work as it should. So what am I still doing wrong?

If you followed the NWmax installation, the NWmax icon should start gmax
when you open something use this…

Also, I apologize in advance if you already know these things, the whole error thing looks like something I did when I was starting out because I opened and exported using the wrong buttons.

Well, there are just two folders called nwmax_plus and Startup, which I simply copypasted to \gmax\scripts\ directory.