Gp_talk_object problem

@travus - I just checked again, but I had actually changed that before testing I saw. I think I remember when trying to solve the issue that a lot of the Fortitude Save and Hitpoints etc was changed to 0, so I changed that. Still, it’s good to know that one has to have one hitpoint on a placeable.

I rarely use the clicked event in preference of OnUsed. nw_g0_convplac does this job nicely. Just assign the script and attach the conversation file to the placeable.

For a nice touch, if needed, set the placeables useable flag to false at the end of the conversation.

1 Like


I think @andgalf was using the OnUsed event. I know he says “click”, but I believe (from looking at the script), he was referring to the OnUsed anyway. :slight_smile: Correction: My bad, it seems he was using the OnClick.

Yes, and another is to do the same on an OnClosed (for an inventory object) when empty. (Let’s player know its done!) :+1:

1 Like

Don’t know quite what you’re talking about here. The script I’m using now, that is proven to have worked, I have placed on the OnLeftClick event. So, no, I wasn’t using the OnUsed. I was using the OnUsed at first, but when that never worked I had to use OnLeftClick instead to get the conversation going.

Whenever I say “click” I mean it. I mean that you click with your mouse on something.

I’ll investigate this. Don’t know where this script is supposed to go, but maybe it says so in the script itself. I’m not familiar with it, so I will open the toolset and investigate. (I need a break from all this now, I’m starting to get a headache working in the toolset for two days straight all day long).

Put the script in the OnUsed script slot of the placeable.

The script is a stock script. It simply calls for the conversation assigned to the placeable to be started.

Yep (I saw in the description of the script where it was supposed to go). I saw that it was approximately the same as gp_talk_object (the other stock script I used at first). Like ga_talk_object, nw_g0_convplac didn’t work in this case.

I’ll continue to use my workaround instead since that hasn’t failed yet.

My bad … There is another pickup that can sometimes be used here then too…

GetPlaceableLastClickedBy (For On Left Click event)

Not sure if will make any difference for you though.

PS: For the record, all my tests were done from the On Used Script hook event and not the On Left Click. May have some bearing.

When I tried all your stuff, I used it on OnUsed.

Assuming everything else as “correct”, then my last consideration in this case would be that the placeable object you are trying to click on (and assuming it had the small script on its On Used Script event), was too close to another placeable object … or you have discovered another issue of which I have yet to encounter.

At least you have your solution. :+1:

As I say above, a last double-check would be to move the placeable slightly from its current location to see if another placeable object is affecting it. i.e. Does the script work when the placeable is moved into more space.

But, as you say, it looks resolved … I am just curious to see what is causing it in this situation.

You may want to add a distance check, without one you can activate the object and the convo from very far away.