Hand model textures

I’ve got an issue that I finally tracked down to the fact that cep2_core7.hak has hand textures for the low numbered hand parts. Let me explain further…

I have in my haks a set of hands I got from I don’t remember where (maybe CPP1.71?). Let’s take one for example pfh0_handr005.mdl, that fixup the original hands to have fingers and such.

This model uses “bitmap hand2”. This seems to be a built in resource? I can’t find that in any of the game files or haks. This gives bare fingers, some leather and then a cloth back with laces.

cep2_core7 has pfh0_handr005.mdl and that one references pfh0_handl001 as bitmap. However, there is also a pfh0_handr005.plt file which I guess is unused?

I have my model in a higher priority hak. If I have cep2_core7 in the hak list my hand model uses the pfh0_handr005.plt texture from the cep hak instead of the specified hand2 bitmap.
It shows cloth fingers, plam and skin back of hand, but the model is right (the fingers are thinner than the cep ones).

If I remove the pfh0_handr005.plt file from cep2_core7.hak it works correctly. The picture show having removed just the one right hand texture from the cep hak.

As far as I can tell there is something odd about the (builtin?) hand2 and hand bitmaps that allow them to be overridden by bitmaps of the same name as the model when present. Really odd.

As far as I can tell the only way to fix this is for me to package cep2_core7.hak’s files (minus the hand textures) into my haks and drop that from my haklist.

If I could find the hand2 and hand textures I could probably just put them in my haks as pfh0_handr005.plt and so on and it might work.

Anyone have any clues?

Phenotype models are weird. The bitmap line is essentially ignored (it might be the MTR loads for it but not sure).

Instead (in EE) the same texture as the filename is loaded, eg pfa0_handl003.mdl loads pfa0_handl003.plt

If that isn’t present it loads the appropriate phenotype 0 I think first (ie pfa2 loads pfa0 first via. Inheritance in phenotypes.2da) then finally the base human variant (ie phenotype 0, female models, goes with pfh0_handl003.plt in the give example).

EE at least didn’t just always load the human one as 1.69 did. You now can set them per-race and phenotype ID.

But you can’t set it by bitmap, texture0 or MTR. MTR can load a different set of fancy maps though.

Thanks, that’s good to know.

I’m still stuck not knowing what texture is actually getting loaded. It’s not using the base game pfh0_handl005.plt clearly… or maybe EE has updated these? I think my nwnexplorer is only opening the 1.69 files. I’ll try to dig it out of the EE data manually and see what it looks like. It would certainly be easier to add those files to my haks than repackage cep2_core7…

Edit: Anyone know where that would be in the EE games files if they have been updated in EE?

Just one of the texture bifs I think. Beamdog cleaned up the files and removed most duplicates and low quality versions.

This is the EE explorer: https://github.com/virusman/nwnexplorer/releases

That’s the one I’m using. It does not seem to open the beamdog EE files. It’s opening my old 1.69 directory because the cpp1.71 bif is in the HOU patch key too. If I explicitly open one of the EE bifs I get data, but all the files are resXXX which makes it hard to find the right one :slight_smile:

I should add I’m running it on Linux with wine so maybe that’s why it’s not behaving quite right.

Edit: wait there’s Options …

I was about to say look at options it supports 1.69 and EE

That should do it.

Edit : They are NOT in NWN Texture Packs/texture_tpa.erf… see below.

I’ll copy those in and see what it does. Thanks!

EE doesn’t have any files in ERF containers only BIF looks like you’re still using the 1.69 source.

But to be honest it’s of course 99% the same as EE so no worries.

No, I’m in the right place, but I think nwnexplorer had cached some stuff from before I changed the path. When I restarted it just now it does indeed not have those erf files. These are in textures_02.bif right where the old lowres ones were. Thanks again. Copying those into my hak has done the trick.

Glad you fixed it and yeah was going to say mayybeee restart since nwn explorer is a bit…unique sometimes!


Can you send me the your right hand? (+ plt). Put it into a zip and attach it to the post by drag and drop. I’ll have a look into the issue.

CPP doesn’t use haks (except one that basically just serves to enforce player having it to play module/join PW which nobody wants to do and risk anyway). However it is true that CPP contains these improved hand models. So if you installed CPP then the models are either in patch17x.bif or in case of EE version in /ovr directory (assuming you installed it there as is recommended and not elsewhere on your own risk).

I am not sure I understand your issue, but with CPP having lowest priority you only get to see hands from CPP if there is no custom content overwriting it. Ie. if the CEP2 contains same filename, then a model from CEP2 will be shown. This means that CC that uses fists of doom will not play well with CPP, but that is to be expected and I don’t think it is a valid reason for CPP not including these improved models.

I never said CPP came with haks. While I was looking at my issue I notice that the hands I had matched what was in the patch17x.bif, so I thought that might have been where I took them from. There’s no CPP issue here, sorry I even mentioned it :slight_smile:

Thanks for the offer. @Jasperre was right. The bitmap entry wasn’t getting used so what happened is my model with higher prio was picking up the pfh0_handr005.plt added by cep rather than defaulting to the base game 001 texture. I couldn’t tell what texture was actually getting used (and then I wasn’t looking in the right place for the texture but that was pilot error).

I just copied the updated EE base game textures to my hak so they are on top. It’s all working fine now.