Has anyone finished Moonsea?

Don’t usually post asking for help with a module as I don’t play too many of them but recently I’ve got back into the original campaign which is going well and Moonsea which was, but has now hit a seemingly insurmountable problem.

I’ve reached the Dreadspire and have to get past the Innovator of Pain. However, because of some spell cast on me by Wak Rather I cant harm him. So, I cant get past him to find out how to get to floor 3 to find and kill Wak Rather then deal with the IOP.

Now, having died trying quite a few times in the pursuit, I’m sure there are no doors I haven’t found to dash straight past him, I’ve picked up quite a few books in the library, none of which seem to offer any clue, while undoubtedly improving my knowledge of the lore of Neverwinter ! There now can’t be many dead men who know more about it now than me. The only thing on that level that must be some kind of clue is you pick up a shard of glass ( thinking non magic etc) so I equipped that and tried to tackle him with that. NOPE!

So, has anyone managed this or is this one of those situations where everyone assumes everyone else managed it easily ( or no one managed it) and gives up?

I think you need to kill Wak Rathar before you can harm the Innovator of Pain.

Thanks, yes I know. However, the Wak you kill just before then was only a hologram ( or some such thing acc to the fiend in the previous room ) and Wak is still alive. Apparently he is on floor 3 and the IOP is on floor 2 and not keen to see you reach floor 3. Nothing you do damages him, there are no secret rooms on floor 2 etc. and there appears to be no way you could get to floor 3 even without the IOP interfering.

Are you playing the original Moonsea? If so, I think the IOP and Wak are on the 3rd floor.

If not, then there has been a change that requires you to find another key or something, otherwise it may be a bug.

Sorry I could not be of more help.

1 Like

No, it’s the retail version brought out last year.

However, thank you for being doubtful and forcing me to double check. There seems to be no answer in print but I found this video on YT which answers it perfectly.

First of all, I may well have been referring to Floor 3 rather than 2 - my mistake if so . Because I was getting chased by IOP I immediately opened the door ahead of me and followed the corridor with him right behind me. I completely missed the door sharp left immediately after the corridor door. Having looked again it doesn’t show up and with camera angle above it is at least partially hidden. However, problem solved by looking at video

Don’t know why this didn’t show up when I searched before. Seems to be in Polish so maybe the tags were in that language.

Anyway, thanks again. I’m off to hand the IOP his sorry ass . . .

EDIT. Not as easy a battle as I’d hoped . . .

1 Like