HELP - Body textures turning white

Recently, some of my characters’ body textures have turned white in some modules. I’m using a few cosmetic overrides via patch haks, particularly Gunner’s Body Rebuild/Retexture mod, but until now I never had any problems with it. And the weird thing is, if I disable all patch haks and make sure the override folder is empty, too, the textures in my save game are unchanged, still white. I also tried exporting the haks content to the override folder, to see if something about the patch hak process has stopped working, but it didn’t make any difference. Doesn’t seem related to the modules or the haks they’re using either (one uses CEP, the other Project Q). Also, when I saved the game of the first screenshot, the torso still had the normal texture, only the leg and pelvis were white, but the next time I loaded the game, the torso and biceps had gone white, too. It seems rather randome which body parts are affected and when. I didn’t check, but it’s even possible that at the beginning of the game, the body textures were still intact.

Does anyone have any ideas that could help me find out what is wrong all of a sudden? :frowning:

I can’t say for sure, but recently I’ve been working on making texture overrides, and discovered that in some files the link to the texture in the model is broken. I don’t know why, but there were texture names in the decompiled models where the filename was incomplete. When that happens the texture doesn’t load and the model is just white. So, maybe decompile the models and check in notepad++ to see if the model is linking to to the texture?

1 Like

But that would mean that the textures should always be white, wouldn’t it? I forgot to say, I saved the character with the white textures, loaded it in the Pretty Good Character Creator, and all the textures were there again, none of them white … :thinking:

It’s got to be a clash with things in the override then. Do the modules in which this happens have haks by any chance? If they do there is either a name clash between things in the hak and things in the override or a 2da clash. This is why my override is empty. OK so my development folder has a ton of stuff in it but I am working on something that is big (in terms of number of files and overall megabytes).


1 Like

Like I said, I disabled the patch hak file and made sure the override folder is empty. When I load the game, the character has no head (because that was an override), and he has the default clenched fists instead of the refined hands from the override. But the textures are still white, even with all overrides disabled. That’s the weird thing. But good call on the development folder, will check it out and clear it too, if need be.

EDIT: Nope, even with override AND development folder empty and patch haks disabled, textures are still white. :frowning_face:

One module uses an individual hak, the other one not. The first uses Project Q, the second CEP2.

Did you recently update your gpu driver? Did you try running a check on the file integrity - use verify files in Steam, not sure for Beamdog or GOG installs.

Also, which version are you running?

1 Like

I’m running the Steam version of the Enhanced Edition, v83.8193.28.
Just checked the file integrity, all files were validated, but textures are still white.
I haven’t updated the GPU driver in a long time, but whenever I search for an update, the device manager tells me I already have the most fitting driver version (my GPU is old, NVIDIA GeForce GTX660, driver is v23.21.13.9135 from 03/23/2018).

Dunno. It can’t be a shader issue because other folks would be seeing that behavior too. Maybe something has changed that makes it so that internal texture references for body parts now have to match the model name/number?

Might want to jump on the Discord and tag Niv or Soren.

1 Like

TBH I wouldn’t trust device manager alone to check for updated nvidia drivers. I’d go and double check at -
nvidia’s driver download site. Don’t know about a GTX660 but I was still getting updated drivers for my gtx 750ti more than 5 years from getting it. Obviously I no longer get those drivers after I got myself a gtx1650.


1 Like

@Tarot_Redhand Okay, I followed your advice and got the latest driver directly from Nvidia’s site, and you were right. The one I installed now dates back to 07/12/2021 and has the version number (instead of So my driver was outdated before, and it is now up-to-date. Thanks!

Unfortunately, it didn’t fix the white texture issue.

Just noticed something in the first picture. Is Benjamin Fiddlestick’s hair supposed to be pure white, or are they wearing a weird hat? Otherwise, if no to both, then your problem is not just clothing related. Can you post a larger picture but just of Benjamin.


1 Like

No, his hair his fine, just very fair, but hardly visible. What you mean is a goofy wizard’s hat that comes with the custom head. It’s dependent on the clothings’ colors, I think, if a bit buggy, and in this screenshot, it uses a very, very light kind of beige for some reason but is not affected by the texture bug. If you look closely you can see a colored shade on it. Sorry for the confusion, it’s true that one can’t tell from the downsized screenshot and that it looks suspicious in this context, but the white texture is only on torso, arm, pelvis, leg and foot.


Is it just the choice of pictures or is it in fact affecting just the Left arm, Left leg and Left foot in addition to the torso and pelvis? Just trying to narrow it down.


1 Like

I was looking through an old pre-EE notebook from several years ago and came upon some notes I made about white textures appearing on parts based models. As odd as this may sound, in that case, I was able to determine that the issue seemed to be caused by a higher quality foot model I was using. When I removed the overriding foot model (it was the left foot), everything worked fine.

I noticed you are using Gunner’s body override. Does that by any chance override the left foot model?

1 Like

I’ve wondered about that, too, but I don’t have enough samples to confirm it, only those two characters (plus the NPC’s arm in the first picture).

Something else that might be of relevance or not is that these two are rare examples of me playing male characters; I usually create female ones. So if this is only affecting male bodies, that would explain why I didn’t notice it before. Also, the first character uses the elf phenotype and the second the half-orc phenotype, and I usually play humans instead. Then again, apparently it can also affect human NPCs who show some skin, so maybe that theory is BS…

I did some more experiments now and found out something even more curious: If I start the modules in question from scratch and import the same characters, they are fine, no white textures on their bodies. And it makes no difference whether I use their initial version from character creation or the version exported from the savegames when they already had white textures on them. It also does not matter whether I do it with the overrides enabled or disabled.

That suggests that it’s not a general issue with the textures but something glitchy that happened in the course of playing the game. But a glitch should not stick when loading a savegame, should it? Something that I did shortly before the textures turned white, I think, is modify clothing with Kamyrin’s CCOH (Customize Character Override Hak). Of course, there’s a chance that it was already there before and I only noticed it because I was changing clothing, or it might have been caused by my meddling with the clothes - but I did not edit body parts, only clothing parts, and it has never caused issues before - I use the CCOH intensively, in every module I play. And the mk_ccoh.hak dates back to 2020, so it can’t be caused by some recent change in CCOH; I’ve played quite a lot of modules since then, without issues.

I also noticed that in an earlier savegame, my character is already affected by the white textures, but the arm of the NPC isn’t yet. And he had nothing to do with my clothing changes. (Don’t mind the missing head, that’s just because the overrides were turned off).

The hak for Gunner’s body override seems to include models for both feet, yes.

Oh, and I use Eurgiga’s Robe-Based Armors as patch hak and cycle through these robes a lot with CCOH. Could something in there have caused it?

Like I said though, removing the overrides retroactively does not fix the issue. The character models stay bugged in the savegame.

I tried cycling through the robes with all overrides/patch haks enabled, but was not able to replicate the issue that way. I noticed though what both modules have in common, and that is that they don’t give me access to Eurgiga’s robes, because they already have their own CEP or Project Q robes taking priority over my patch hak.

Don’t be sorry for confusing people! Be proud! :wink:


Huh. I disabled the robe hak that wasn’t working anyway due to CEP, loaded an earlier savegame where the white textures had not appeared yet, “crafted” two new robes for my character and a companion via the CCOH, and all was fine, no white textures. I played on, occasionally unequipping the robe to see whether the body textures were still intact, and they were. When I had played enough for today, I saved the game, then remembered to check for the textures again and lo and behold they had turned white again, just like in the screenshot above. When I put the robe back on, I noticed that the neck part was white, too, but only on the robe (Neck(1)). When I removed the robe, the neck was skin colored again.

Going through my screenshots, I noticed that one time the custom icons in the iventory had turned to white squares, too. Not sure if that’s related. But that seems to have been a glitch during that session only. In my savegames, the icons are intact.

I really have no clue where the white body textures are coming from and why they stick in savegames regardless of overrides disabled or not. :frowning:

It happened again, even with Eurgiga’s robes hak disabled. So I also disabled Gunner’s Body Rebuild/Retexture, reloaded a previous save and played on with body textures still intact. This time I put my PC’s CEP robe in a quickslot so I could easily unequip it from time to time to check whether bod texture was still fine. In the end I resorted to having my PC run around naked all the time. When I made the last quicksave body texture was fine, and then a few minutes later I made a regular save with body texture intact and quit.

Now this is new and even weirder: When I load the savegames now, the body textures are white, even though they weren’t when I saved! :dizzy_face: