Help ! NWN2 is misbehaving


#1

Greetings, so this is where you’ve all been hiding.

I put this question up on the Nexus ( am I allowed to use that word here ? ) and got no reply so here I am. Somehow this site new my email address ( which was changed last year ) and me even though I’ve never logged in here which is really weird but irrelevant.

What is relevant is that my copy of NWN2 doesn’t work properly and here’s what happened…

I installed a new hard drive ( E ) to put all my games on and swapped NWN2 over from the C drive that it has lived on for years. This was both files, the Documents one and the Program files too and I changed the target on the desk top link to match this.

The game launched fine but all my saves had gone ! So I made a new NWN2 documents file in C and a saves one like the original, put in some saves from E and launched the game again. The saves were back again but if I made a new save it put it on the C drive, not the new one. I can live with that but it’s still not perfect.

So I loaded up a random save from one of my mods and it loaded but looked very different with people running around in their underwear and having had face change surgery due to a hak not working.

Back to the C drive and I made a hak file which I swapped the haks from E into and thought I’d solved the problem. But now it wont load at all and says that haks are missing ! I copied the haks and put them in the E hak file so I now had two copies and they’re still missing !

I wiped my new NWN2 files in C and put back the original ones from E but it still wont work and it still wont load saves.

So any ideas how I can fix this and is there a way to get NWN2 to only use the E drive ?

I don’t want to reinstall it in E because of the updates and it might not make a difference anyway. I do have a copy of NWN2 on an external hard drive ( to save doing updates if something happened ) which I could just put straight into E but it was originally installed on C so will be exactly the same files.

All suggestions welcomed, thank you.


#2

I replied to a similar question here:


All you need to do is to create a new shortcut.


#3

Hello,

Thanks for the reply and the link, only problem is I don’t understand what you mean.

What is the root directory the key home and object field ?

I made a new shortcut before from the Atari NWN2 file and changed the target on the original one in both cases the game fires up but doesn’t recognise the haks and saves in the old place so will this key home and object field thing change this ?


#4

To my knowledge you can’t change the location NWN2 goes to for save games(documents one) because it’s using a windows Path Variable %UserProfile%

You can change the executable folder(Program Files one) and have done so successfully.

You will need to restore your NWN2 documents folder to as it was before you moved it. If it is complaining haks are missing then you have lost files in the move.


#5

I’ve explained above how to change this.

By object field there I meant the Target field (see an example below) in the shortcut properties window. The root directory is the folder where your game is installed.


#6

Thank you both for the help.

Kinslayer… Problem is that my haks are still there in the documents file so even if they’ve got nothing in them now surely the game wouldn’t think they’re missing and how would six different module specific haks get corrupted whilst moving ? I have tried loading saves from different hak related mods and got the same results.

Aqvilinus… I just put E:\Games\Atari\Neverwinter Nights 2\nwn2main.exe" -home “E:\Neverwinter Nights 2” in that highlighted box in your picture ( thanks for the clarity ) but the saves wont start it says loading modules, gets to the end and then says cannot start !

I’m going to do some more investigation with what’s in what folder.


#7

It’s all getting very confusing now !

I put the original complete documents file back in C and it all starts up and works again. I can load the saves but the characters that were in custom armour, that was in the hack, are in their underwear again and their faces have changed. Also in the toolset the custom armour shows up fine and they look like they should too.

It sees like half the game is using the C drive and half using the E one. So when loading it looks for the hak in C then in the game can’t find the information because it’s looking in E and the toolset is just using the C.

Is there any way to make NWN2 make up it’s mind and stick with the E drive ?

I can’t believe this is so complicated as I’ve swapped over a lot of newer and bigger games and they all worked fine. I had thought this would be the easiest to move but it’s the hardest.


#8

in my experience just copying installed games to another location only causes issues. i’ve not looked into it but i guess there’s a registry entry defining at which place the exe is stored and where other directories are located. those entries will not be changed without reinstalling, if not manually by yourself.

perhaps you can resolve your problems with a simple uninstall / install of nwn2.


#9

I… can’t help you. But I stopped in to say holy crap it’s Tsongo! I thought you were long gone. Welcome back.


#10

QuixaI…Thank you, I might be back but my game’s in a mess !

Semper… I’m beginning to think that’s my only option including downloading mods etc. Ages ago I had a perfect plan to avoid updates in the future with a complete updated NWN2 on an external drive but that’s come from my C drive so will be the same thing as I’ve got !


#11

Welcome back.


#12

Thank you, I must say that if there were award ceremonies for forums the NWN2 ones would win the most helpful and polite category.

I think I’m going to have to reinstall my game but before I delete it are there any issues with updating as this games quite old now ? Also can I just take the mods, campaigns and haks out before and stick them straight back in the new version without issues regarding which drive they’re in ?


#13

there’s a quotation mark right after the .exe. dunno if it’s just an error in your post or if it’s actually there. make sure that only the path to your custom nwn2 user directory is in quotation marks.

you could also reroute your whole documents folder to a new location, like a different drive. navigate to c:\users\username, right click the “my documents” folder, select the path tab and change the destination to a suitable place. this way all files and programs wanting access to your documents folder will be looking at the right place.


#14

Thanks for the suggestions but I can’t move the documents as that’s what I want on the C drive and it’s got a lot of other things in it.

I think I know the problem as somebody on the Nexus suggested the same changes to the shortcut and tried it himself. His version saved in the E drive and made all the relevant folders there too.

So I went drastic and wiped out NWN2 from my PC for the first time since it came out and installed it again. The patcher didn’t work and got an error telling me to contact Atari but the game started.

The pre made characters were gone so Adaur Harbor is now in the void, but served me well in testing and will not be forgotten.

I made a character started the game and saved… It created all the files in the C documents and saved there too.

I think it’s all because my game is from an original disc and something’s hard coded and cannot be adjusted.

This sucks ! Now I’ve got no updated NWN2, useless discs and probably can’t ever get it to run from the E drive.


#15

Hi Tsongo,

Sorry to hear about your installation woes. For the patches, you can find them here:-

https://neverwintervault.org/patches?field_game_tid=6&field_official_version_tid=All&field_platform_tid=All&field_language_tid=All&field_requirements_tid=All

However, I also have NWN2 on a computer with two drives, and found that the best solution for me was to install the program in the default location after making my C drive the SSD one. That way, I got the maximum performance with least issues. I know that may not help, but that was my solution. I also had to reinstall NWN2 as a Windows update had given me problems. Also, do not forget you may need the directx_aug2009_redist.exe for the toolset to work properly.

Cheers, Lance.


#16

Why spend all that time patching when you can get NWN2 Complete on GoG for the price of half a tank of gas?


#17

Lance_Botelle… Thanks for the info, that’s a lot of patches ! I think it’ll have to stay on C whatever happens because it’s an obstinate little beast ! I might just use my copy that’s lurking on an external drive.

As for Windows updates they’re even more obstinate and force themselves onto my daughter’s Windows 10 computer all the time, sometimes with bad consequences. I’m sticking with Windows 7 with them switched off for as long as possible.

rjshae… Principle I suppose and GoG would be my next solution if I can’t get it to work. But here in England it probably converts to about an eighth of a tank of gas !


#18

I suppose it depends on how much you value your free time. If you were working, say, and had a choice between spending a couple of hours patching or buying a patched up product, which would be cheaper? :wink:


#19

petrol?


#20

Got it working from the copy I had on an external drive. It’s back in the C drive so it was a total waste of time !

What looked like the simplest game to swap was in fact the most difficult and there must be some ancient code stuck on the original game which has been taken out now it’s digitalised. I suppose back when it came out not many people had more than one hard drive and it was easier to write that way.