Help wanted with tile joining

this is a follow-on to a question i (mis-)posted to the toolset forum, ‘Help wanted - tileset modification’.

i’m revisiting this problem again as it’s come up in the context of another tileset, one of the newer forest sets where, once again, a stream just won’t connect to a body of still water no matter what i do. i can orientate the stream tile itself so that it will be a perfect fit against the pond, but when i place it, the toolset chooses a different tile which breaks the flow w/a bit of land. even worse, if i edit the area file directly using the gffeditor so that i place the tile exactly the way i want, when i run it in-game the engine once again replaces the tile w/another one. :rage:

i’ve read several docs on tileset creation and i’m still confused.
what exactly is going on w/this problem? or more to the point, what mechanism governs which tiles can be placed where relative to tiles that have already been placed? i thought this was governed by the .set file, but apparently not? is it part of the model itself? is it something else entirely??? please help me finally get some sleep tonight… :woozy_face:

ideally, i’d like to modify the tilesets (if i’m able to…) in order to overcome these issues.

If I understand correctly you want to connect a river (which is most commonly a crosser) with a larger body of water (terraintype water). I’m still a beginner as well, but I think that there needs to be at least one tile which works as rivermound. If it doesn’t exist (quite possible for a forest tile set), the you can do whatever you want, the river will never connect to the water.

Possible approaches:

  • There should be somewhere a tool in the vault, which places every existing tile into an area. So one can have a visual check, if a rivermound exists.
  • If the tileset is available for public, name it, so that others can have a look.

------------------- edit --------------------------------------------------------------------------
Example rivermound - Bioware City Tileset:


Now check the .set of your tileset if there is a tile with the same scheme.

Open the tileset hak in nwn explore to see if the tile exists. If it does not you can not

@mmat - yes, it uses the same scheme. i modified one of the tile entries in the coastline tileset to mimic what i found in ttr01, but as i mention in the first post of this thread, it didn’t work.

here’s an example of the problem :

you’re probably already familiar w/the stream connector on the bottom [ttr01_g11_1] ; it comes with the rural tileset. the yellow circles show the tiles from the coastline tileset that i’d like to be able to accept a stream. as you can see, it’s also impossible to make the ‘shallows’ tiles go all the way down to the water, intervening rural tiles are required.

i tried a similar approach with the forest tileset, but i don’t have anything to illustrate because i no longer have the hak… :unamused:

Apologies for not reading the first msg in the threat thorougly. Got the tileset and will have a look on it this evening. The coastline looks very similar to the one in DOA_CityRural_21, which already gave me some headache …

iirc, that tileset mod uses a “sand” crosser - this will prevent you from doing what you want because afaik you cannot join two crossers perpendicularly.

if the “sand” is a terrain, then you can do what you’re trying to do. You’ll need a tile similar to q11_1 but the top corners adjacent to the water will need to be the same terrain type (e.g. “sand”).

@Zwerkules knows more about this type of this stuff.


@Pstemarie: Correct, but in this case, “Sand” is a terrain type.

@Xorbaxian: To connect the river (lower yellow circle in your picture) you need a tile with the following configuration:
The tile will still show a small stripe of sand. Such a tile doesn’t exist by now.

If the river runs over a wider stripe of sand (upper yellow circle in your picture), things get more complicated, since you need a crosser Grass/Sand and another one Sand/Shallows.

my thanks to both of you for taking the time to answer.

@mmat - to sum up, then, i’ll need more tiles, not just dinking around w/the .set, correct ?

is it possible to use tiles that are already available and just rename them using, e.g., the tileset renamer [or by hand], then place the newly renamed tiles into more entries in the .set? if i’d need to create entirely new tiles mixing streams and water and such, then i’m afraid i’m 'out of my depth`… [har har…]

You should be able to use existent tiles as you suggest, assuming they fit what you need.

It might be worth your tile to take a look at the Project Q 3.1 version of TNO. @boodah added in those sand “shallows” and he may have made additional tiles to fit the stream-to-grass/sand tiles you are looking for.

If Q has the correct tiles, you’d just need to run them through CM3 and use the “lower tiles” functions and drop them 5m.

The sand terrain in Q 3.1 TNO was taken from the Tropical tileset (ttz01), which is different from the one used by OP here (which features sand and shallows terrain). The sand terrain in TNO also does not support stream - or any other - crossers.

The original sand terrain in ttz01 does support the stream crosser (also on grass/sand), however those tiles won’t be of much use here, since the sand terrain OP uses comes with a slight decline. In other words, it is a bit lower than the grass terrain.

I think at least two new tiles are needed to make this work. And probably 4 to make it somewhat robust:

  • stream crosser on grass/sand
  • stream crosser on sand/shallows
  • stream crosser on sand
  • stream crosser on grass/shallows

Correct. It might be possible, that you find something you can use in other tilesets, such as those Pstemarie mentiones. The grass/sand/shallow combo seems to be quite popular, you’ll find it ervery here and there. I.e. you’ll find similar tiles in “DOA_CityRural_21”. But this tileset doesn’t have a proper rivermound (I already checked).

Thanks for the clarity

In the Ravenloft: Prisoners of the Mists haks is a tileset +City/Rural Builder Base which also features Sands and Shallows terrain.

I think that’s a modified (?) version of tileset Mmat mentioned.

It also doesn’t have the stream on sand tiles, but at least comes with a stream on grass/shallows tile, which would take care of the lower of the two yellow circles in your screenshot:

You can get their haks from their website here (first link under 2. Necessary files).

The tile should be in rl_ruralcity.hak.

Not much, but maybe a starting point.

1 Like

Yupp, there it is. ttr10_e16_01