Help with importing .erf files

I’m still working on my first NWN2 module and the going is slow, mostly because work and life keep intruding… But, it’s coming along. A huge thanks to all of you who helped me figure out the encounters, especially rjshae, kevL_s, andysks, Taihou, and Aqvilius.

My latest areas of struggle are importing .erf files into the toolset and scripting some area transitions. I’ll save the scripting question for a separate post. WRT the .erf files, I intend on using the snakes developed by Arpharazon and the giant frog by Kalister68.

Here’s what I’ve done so far, downloaded the .erf and .hak files for both, placed the .hak in the hak folder, figured out (or so I thought) how to use the import feature of the toolset to bring in the .erf files. However, when I try to place the creatures, nothing shows up. The creatures are listed in the Creatures list in the toolset, but all I see is a blank cross-hair cursor.

I read somewhere that I need to associate the models with the module, not sure if this is the problem or even how to do this. Any suggestions and instructions would be greatly appreciated. And please remember, I’m a total noobie, so please make it idiot-proof!

Thanks!

1 Like

Just placing the hak on the folder alone won’t be enough, you also need to associate those haks to the module. (view -> module properties)

If, by any chance, the author also modified the appearence.2da file, you will also need to put that inside the hak (if it’s not in already)

When you’ve done so, save the module, close and relaunch the toolset. It should have fixed your issues.

.erf is usually not needed if the .hak is used – generally speaking it’s one or the other

Their packages should contain the same files … the difference is in where those files end up.

  • if hak : files end up in the .hak [see Clangeddin’s post above]
  • if erf : files end up in the module (or thereabouts)

all this gets into the concept of “priority” – files with the same names in different places resolve that conflict because the engine gives priority in this order :

top priority

  1. files in hak
  2. files in /Override
  3. files in /Campaign
  4. files in the module
  5. stock files in <installation>/Data folder

( note: xml files for the UI can be placed in the UI folder, which i believe has a priority down near that of the module; but this is later, just learn the 5 priority levels listed above :)

1 Like

By the way, if by any chance you’re testing this https://neverwintervault.org/project/nwn2/model/custom-creature-conversion-project

Keep in mind that snakes, basilisks, monodrones and rust monsters appear to be bugged (perhaps some file is missing, or some values are wrong in the appearence.2da), try testing the Displacer Beast, the Xorn, the Dracolich, Scorpion or Carrion Crawler, those are working.

1 Like

Clangeddin, kevL_s, THANKS! Worked like a charm. I was able to import both the snake and giant frog. I was able to place both and use each in separate triggerable encounters. I never would have figured out the View > Module Properties, save and re-start steps by myself.

I didn’t notice anything buggy with the snake in either instance that I used it. But I’ll take a look at displacer beast, xorn, and others and let you know.

Thanks again!

1 Like

OK, so here’s today’s weird problem… I am able to import and use the giant frog in a test module I use for practice, but it won’t show up in the actual module I’m working on for release. In addition to that, there are several of the standard creatures in NWN2 that won’t render either in the module. In particular, wraiths, megaraptor, and deinonychus will work in a test module, but not in the one I’m building. It must be a setting problem with the module. Any suggestions?

The only way I could help you would be by seeing both modules and comparing the differences, the only thing I can say for now is to check if you didn’t forget to associate the haks on the new modules, like, doublecheck you didn’t miss anything.

(particularly if your Module is accessing a different Appearance.2da than your test Module)

eg. one could be using a 2da in the .hak, and the other could still be using the stock 2da

and if there’s more than one .hak, you’d have to look inside those … the topmost hak takes priority, btw

 
like Clangeddin implies, it’s very fiddly … until you get used to it,

:eyeglasses:

All, thanks! I’ll probably post both mods here in the next week or so and see if better minds than mine can figure it out. Now, however, I’ve run into yet another problem… As I’m building the crypt for the mod, I keep loosing one tile section. When I build it and test it, it initially runs fine, I can enter the tile and engage with everything. But I keep noticing that later on, I loose the area. It’s as if it’s not baked. No matter how many times I go back and re-bake the area, I cannot get access to it again.

Screenshots are below…

and…

I’ve already tired rebuilding the whole area twice and I run into the same thing with the exact same tile location. Does it have something to do with the shape of the room? Or the combination of tiles I’m using?

Any suggestions would be greatly appreciated.

Sorry for the wasted post, but I actually just figured this one out on my own! WOOHOO! It turns out that there were some placeables in the tile that were NOT set to be walkable. Once I set walkable to TRUE and re-baked, all worked fine. I guess old dogs can learn new tricks!

2 Likes

Trying to get areas packed with placeables walkable can get garment rendingly frustrating at times. I can feel your pain. I’ve encoutered the exact problem you have numerous times, and it is such a joy to deal with. Glad you got it working without having to lose too much detail.

1 Like

Thanks to everyone for their help and suggestions. I posted my in-progress module and a test mod at: https://neverwintervault.org/project/nwn2/module/hermits-chalice-progress

Any critiques and pointers would be helpful.

I have a couple more dumb questions… Why does my start location icon insist on floating about 10 feet above the ground? I place it back at ground level every time I save the mod, but it always ends up back in the air. It has no effect on game play, but I am curious about why it happens.

And as I’ve been hunting and pecking through the hundreds of scripts available, it occurred to me to ask if there is a single, consolidated dictionary of all the NWN2 scripts and what they do in plain English? Maybe it’s too much to ask, but a guy can hope.

2 Likes