Horse issues: a.k.a. she's lost her head again!

So, just been horse riding as you do on a Sunday morning ! ( After reading Proleric’s guide to horses for builders).

However, had a slight mishap in that despite me doing nothing to annoy her, my good lady lost the head as soon as she climbed on her horse !

Dismounted and she appeared to be fine again.

The other issue is that I can get the party to mount okay ( although her head disappears) but when assigning a waypoint ( in the same area) with the appropriate tag for clustering, after forcing dismount through the Party dismount trigger, it doesn’t appear to work. Party dismount brings the following:

As you can see I dismount but my good lady doesn’t and my horse just wander a few yards away as if knowing he should be going somewhere ( suggested also by the text) but doesn’t.

Can anyone familiar with this operation suggest where I’m going wrong - please don’t suggest not taking my good lady along :smile: It beats taking the dog for a walk . . .

Is that a custom head? If so, some custom CC body parts don’t behave well with horses. Try moving the head model to a different number.

1 Like

Thanks for replying.
No, not as far as I know. It’s a bog standard female commoner from the toolset but will try your suggestion in case.

@jimdad55, I’m confused. Is that not a part-based model?

Now you’ve got me ! I guess it is in the sense that you can choose a new head in the Appearance tab but what I meant was I just selected a commoner in the toolset with no haks for new heads or anything.

Just back from shopping :shopping_cart: will try a new head in a while.

Here’s your issue - the model you are using is the human female commoner which does not have an associated riding appearance. Therefore, when the commoner mounts their horse, they change to the human female appearance (note the different body parts on the rider) and the engine doesn’t know which head to use.

What you need is to make your commoner a part-based model by using the human appearance OR I think @ShadowM has a mounted appearance for that model in his HR Base.

Edit - Looking at your screenshots of the mounted commoner, what is being rendered is the clothing model that is equipped. If you unequip that clothing, you wouldn’t see a rider at all.

Absolutely right. I’ve just tested it using the human appearance and it works. That’s really interesting. Thanks.

I’ve also solved my dismounting issue with a little more trial. When I enter the party dismount trigger the PC almost immediately dismounts but the henchman doesn’t. However, if I then run further into the trigger the henchman dismounts properly.

Only issue left to solve is why the dismounted horses don’t both run off to the waypoint with the “X3_HITCHING_POST” tag. Off to try the blindingly obvious that I may actually need a hitching point there rather than just a WP ?

Dunno. I’ve only played with horses a tiny bit. @Proleric would be the one to ask.

Yeah, I’m sure he’ll be by at some point. It’s only me mucking about on a wet Sunday but it’s fun knowing why something works or doesn’t.

Thanks again for all your help. I’d never have guessed that, especially since the female commoner doesn’t have a choice of heads in the Appearance tab.

Just playing with the last issue now. With my luck it’ll probably need a script as well ! :see_no_evil:

I haven’t used dismount triggers much, but according to my test notes, waypoints work. Did you try setting bDismountFast to 1 in the waypoint variables?

Thank, Proleric. Just tried it but no difference.

Screenshot 2020-01-06 at 11.28.51

Screenshot 2020-01-06 at 11.29.24

UPDATE: bit more testing although no success.

  1. At first only the PC dismounted. you need to walk further into the trigger to get your henchie to dismount as they try to follow you.

  2. I now know why the horses just stand where they are - its because they cant come into my trigger which caused the dismount.

  3. I thought the lack of clustering at the WP might be because I didn’t have the horse include in On ModuleLoad but that doesn’t make a difference ( and if it needed that would it not also need it for the other actions?).

  4. I do notice that the horses both disappear then reappear quickly upon dismount.

Current thoughts :

Could it be the type of waypoint? I’ve just chosen the ordinary one.

My trigger has the “x3_tr_dismounth”. does it need anything else to cause the clustering at the WP?

Try increasing the size of your dismount trigger. Based on what you’ve described, the hench mount issues may be caused by them not being able to enter the trigger before they dismount.

Ok, thanks. Will try.

Actually, scratch what I just said. After looking at the script again, it appears to be searching for a multiple mount/dismount variable on lines 25 and 26. Make sure that variable is set on the Area where the mount/dismount is occurring.

float fX3_MOUNT_MULTIPLE=GetLocalFloat(GetArea(oCreature),"fX3_MOUNT_MULTIPLE");    
float fX3_DISMOUNT_MULTIPLE=GetLocalFloat(GetArea(oCreature),"fX3_DISMOUNT_MULTIPLE");

It also checks if this variable is set on the Entering Object. I’d do a search on those variables in the Lexicon and Prolerics tutorial and see what’s up with them - assuming they are documented.

Yeah, didn’t work.

Don’t quite understand what Im doing here. Where am I adding these lines? Is the script you refer to in the Area properties, trigger or somewhere else?

Yes, I know that’s a numptie’s question :grinning:

Do you mean add these to the variables on the trigger?

They are lines 25/26 in the x3_hr_dismounth script.

EDIT - Found the reference, they are multipliers for the mount/dismount speed to speed up the animations for mounting/dismounting. Nothing to do with your issue.

Ok, thanks for your help. I’ll have a play around . It’s a wet day here !

2 hours later . . . No, I’m missing something and whenever this occurs it’s usually a script issue.

My WP has the variable “x3_tr_dismounth” and tag “x3_plc_hpost”

My trigger is called “Dismount and Hitch” and it’s tag is “x3_tr_dismounth”. No variables.

The only other thing I can think of is that I need to put a script on area Enter something to do with
#include “x3_inc_horse”. to call up all the horsie actions.

Should there be a script in Area OnEnter starting with this? There are no X3 scripts in the pulldown so presumably its not enough just to type that into the box in which case I’m out of my pay grade.

Your WP has to have the tag “X3_HITCHING_POST”. Delete the variable - its not needed.

Your trigger OnEnter script needs to be “x3_tr_dismounth”. I think the tag can be whatever.

1 Like

I’ll get onto that in a while. Thanks again.

UPDATE : YESSS !!! It works.

So, changed WP to a placeable hitching post ( don’t think that mattered).

Hich post - no variable but tag “X3_HITCHING_POST”

Trigger - tag didn’t matter. OnEnter script is “x3_tr_dismounth” with “bDismountFast” set to 1 in variables.

I also rode round to the other side of the trigger to enter but that couldn’t have mattered either I don’t think.

Anyway, horses are now happily at hitching post and I can go to bed and have a fair chance of sleeping.

Thanks for bothering, @Pstemarie and @Proleric.

Glad to help.

1 Like