How difficult is it to modify classes for a module? [SP]

I’ve noticed that many builders are able to change class properties in their modules, sometimes pretty drastically. I’ve tried to read up on that, but it all goes way over my head, and I think I need some sort of Class Modification 101. How hard is it? Do I need special file editors and things? Should I even think of attempting it?

Proleric created a Courtesan class for his superb Dark Energy module. You may wish to talk to him.

1 Like

while creating a class (or extensive modifications) requires a fair bit of knowledge, surgical changes can be easy.

If you say exactly what you’d like to do someone could say “oh just change that column in such a .2da” eg.

(i’m Nwn2 and shouldn’t comment on specifics tho)

1 Like

I was thinking of expanding the spell selection (and possibly spell slot amount) for rangers in a ranger-centered “treehugger” module.

Rangers are my favourite class, but investing in WIS 13-14 just to be able to cast one Cure Light Wounds and one Camouflage (can’t even remember what you get at lvl 3) is a farce.

Minimum wisdom is likely hardcoded.

in Nwn2, the file CLS_SPGN_RANG.2da looks like it controls what level they get spells at and how many.

and allowing Ranger to select different spells or to change the level they get particular spells at is column “Ranger” in Spells.2da

ex: Copy those 2das into your module and start tinkering (no guarantees – nothing works until it does …)

1 Like

That’s my understanding, too. I’m not certain, because my custom class wasn’t a spellcaster.

Whether you’re tweaking existing classes or making a new one, the 2da files to modify are classes.2da, packages.2da, plus all the cls_*.2da files…

… and pack*.2da files for the class in question.

My own Courtier class was a very crude attempt, so no doubt others know more.

The CODI New Prestige Classes Tutorial is quite helpful, but doesn’t cover your case because there are issues with creating new spellcasting classes, apparently.

EDIT - The editor won’t let me put two asterisks on the same line, hence the …

1 Like

To do that you * highlight the text with the * and then press the pre-formatted text button([CTRL]{SHIFT]C). FWIW I would highlight and pre-formatted text the pack*.2da.


1 Like

Thank you everyone for your responses!

I’m okay with the minimum wisdom requirement, as long as there are actually useful spells to cast. I love the idea of rangers having a little casting power, focused on practical support, Aragorn-style, but the spells available to rangers in NWN1 are ridiculous.

How do I modify 2da files?

I don’t have access to the Nwn1 toolset, but it should go like …

open the 2da you wish to edit in the toolset. It will be the stock .2da that comes with the game (unless modifications have already been done, and/or there’s a copy in /Override or something…)

figure things out and make the changes, and when you save that 2da it should – i think – get saved as a new copy with changes in /Override … or perhaps in your module if it’s currently open. idk

someone with the toolset can guide you better if things go awry.

Note there are external .2da editors also, which should allow more control over things like where the file gets saved … but i don’t know the recommended one for NwN.

1 Like

My toolset only lets me open module files. I can’t find a way to open any other kind of file with it.

(If I try right-click and “open in”, my Win8 gives me a message to “setup a default program for this type of file in the aplet” and the NWN toolset doesn’t show up in the aplet).

You need to edit the 2das with a text editor outside of toolset. You can then put them in override (assuming the same 2da is not in a hak for that same module). Or you can put the 2da in a hak above any already in the module.

There is no toolset support for editing these.


What @meaglyn said.

If you prefer to use Excel there’s a handy tool. Smaller files, especially those with few columns, are easily changed with a text editor, but in more complicated cases Excel will freeze the column and row headings for you, so you can see what each field means as you scroll.

1 Like

is there a dedicated app?

eg - TlkEdit

I use the version for nwn2 (and recommend it for those who use 2) - the version for 1 comes bundled

1 Like

@kevL_s, how did you get access to those fields below? My window doesn’t look so informative. Maybe that because I’m using a wrong version of Java…

1 Like

mine doesn’t do it either. (ripped the screenshot from the Vault entry for ver r13b – but linked to ver r13d)

r13b is classified under Nwn1 and r13d is under Nwn2 but I think they both bundle versions for 1 and 2 so i linked to the lastest version: r13d.

anyway, i think it’s an nwn1 thing … pretty cool whatever it is (notice the dropdown eh)

Ps. It’s the info found in the text files along with the 2das: Eg, “spells.txt”

1 Like

Thank you very much, everyone, for your (continuing) assistance.

I don’t have Excel (I use Open Office) so I downloaded TlkEdit. Trying to run its .exe file results in a popup saying it requires Java (some number) and redirects me to the java webpage to download it. Downloading and installing it does not change anything, the .exe file still does the same thing.

OO has a spreadsheet editor: Calc

but in all honesty I can’t recommend using a generic spreadsheet editor unless you already know what yer doing. (I just tried using Libre Office Calc and while I got it to import okay, the output was quite borked on a not-so-complicated 2da, and while I got a success with a very simple 2da it has a bunch of extra whitespace and overall I wasn’t impressed. I thought i had to use one years ago, to increment values with a macro, but since then decided it’s been easier to write a script that outputs text to the logfile, and paste that into a .2da instead - if you get my meaning. Maybe Excel is kinder to 2das.)

tbh my primary 2da-editor is nwn_2daeditor but it’s for Nwn2, and i have no clue if the header or whatever else changed from Nwn1.

If you tried ver r13d (linked above) you could try r13b

I notice a comment from GoodLuc says,

But yeh, if you have Java installed and TlkEdit isn’t finding it, the operating system gets involved. TlkEdit seems to run fine for many persons. In the back of my mind i recall there’s a way to spec. a path for java (apart from system PATH), but it’s buried …

There’s also TabularFramework and TubularFramework – iirc I tried it and it wasn’t good for me but it might be good for you.

1 Like

Are you sure you installed the correct version of Java? From comments there:

You need to use Java 8 32-bit, not 64 bit.

Also, there’s another good 2DA editor that I personally recommend:
Works well both for NWN1 and NWN2.

And while we’re on the subject of 2DA editors, I want also to recommend a great tool for comparing two different 2DA files:
(good to use in conjunction with specialized programs like Araxis Merge, WinMerge, etc)


That helped! The program ran fine, all legible columns and stuff. Editable, too, so thank you everyone so much for your help. Of course, that does not mean the matter is resolved (no such luck).

The “classes” .2da file lists - as far as I understand - other resource files used to determine class properties.
These files include CLASS-[name]-FEATS, CLASS-[name]-SKILLS, and CLS-SPGN-[name]. That last file should (I think) list the spells available to a given class. And I have the first two files in my .2da folder, but I don’t have the SPGN files anywhere.

I have a “spells.2da” file, in which I can set individual spells as available to specific classes at specific levels but doing only that is not enough: when I put a thus edited file in the “override” folder, a ranger character gets additional things on a spell list, but these things are all signed “Bad Strref” and do nothing.

EDIT: turns out this happened only for Magic Vestment and Magic Weapon 1st level spells. Other spells such as Bull’s Strength were added successfully despite the lack of the SPGN file.

So, I have now successfully expanded the ranger spell list and the ranger class skills with the help of you guys, which is amazingly wonderfully awesome. Thank you everyone for your assistance!

I still can’t add new feats, despite editing the file.

btw, “spgn” stands for “spells gained”, and if you come across it “spkn” for “spells known”

… Something occurred to me, since spells for Rangers are changing … the spellscripts ( Spells.2da column “ImpactScript” or similiar ) might not calculate a casterlevel correctly (etc.). That is, you can see where this is leading … scripting.

anyway, I hope you’re making backups and all that good old matter-of-policy stuff.

Again, i’m Nwn2 and it’s getting too specific,

re. Feats: there could be 2das similar to the ones for spells that control which feats are granted/available and at what level.

My advice is, keep your mind/eyes open and poke around. that’s what everyone else does …

1 Like