How does one could make custom portraits show by default on polymorphed forms?

What I’ve already tried was to copy creature blueprint (druid red dragon form in this case) set custom portrait in the settings and then export that file into override folder. Unfortunatelly upon activating this form in game creature didn’t had any portrait at all. Is this even doable?

Hi mhroczyn

I checked today
it is at your request.

and everything worked fine for me.

This is problem
spawned only 2 creatures (fire and wind elemental)=get black portrait.
druid skill when using pc.

I also checked normal entities and their portraits are displayed normally, so most likely this is some kind of error.

Perhaps it can be fixed somehow / but I’m not sure.
If it was possible to set portraits using scripts (what I’m not sure about) then it would be easy to fix.

Most likely the problem is in the files of the creatures themselves (I mean the drawings of the creatures)
and I guess if you recompile them then most likely they will display portlets.
But unfortunately, most likely incorrect (this is a problem of the developers, they did not fix it / unfortunately I do not know how to fix it)

through scripts, you can probably fix it, but
it needs to be wasted time (there seems to be no such function there / which means it needs to be written / maybe someone knows more)

I have a red dragon shape that displays a portrait.
(crooked portrait)
and you probably also know that with a big creature
at pc
portrait is often displayed incorrectly / too large
and the face (in the sense of the dragon’s muzzle does not fit and its skin is displayed / like dwarves duergar (when using the ability to increase the persona)
I can attach a screenshot

here normal portrait

So you probably shouldn’t worry
even if displayed, it will be replaced with a crooked portrait
I described above / unless you use some kind of workaround)

I think I was misunderstood. E.g druid’s all animal and elemental forms are created from the same blueprint as the summons are.
Whenever you summon lets say air elemental it is created from this blueprint:ex

As you can see it has already custom portrait set in place so whenever you summon this creature it will have this portrait instead of default camera screen.

The problem is that the same blueprint is used whenever you activate druid form transforming you into air elemental however your character doesn’t have any portrait at all. You can see it here:

On the left is pc and on the right summoned one. They’re using the same blueprint which should apply portrait but it doesn’t in case of pc.

This applies to all polymorphed forms, wizard and cleric spells too.
I was wondering if someone know solution to this. The files seem to be alright but game can’t apply those portraits upon transformation however it does apply character custom portrait (if there was set any) when you are going back to your original form.

I already told you everything I know.

scripts install Portraits.
If they weren’t there, you wouldn’t be able to establish the portrait in general.

Attention ! make copies of the original files before you try to change careful.

Causes are here
1)scripts error
then you get a black portrait
To think that Blueprint settings “will help” you, in my opinion, is not correct.(why .Because if your Blueprint settings
correct but scripts don’t work correctly=you get a black portrait)
How to fixed: need find scripts that are responsible for installing the portrait and manually register the portrait / or write your own script.

2)Blueprint error
then you get a black portrait
How to fixed:
you need create new blueprint same creature.
and and replace the old one.

3)and unknown errors
then you get a black portrait

if scripts work correctly
here is an example

if scripts don’t work correctly
you get a black portrait = no portrait
here is an example

I do not know what is causing this problem in your this case.
this is most likely
it’s scripts error or Blueprint error

My portraits=all portraits work for me except
air elemental (and fire sometimes does not have a portrait)

Just for the clarification by custom portrait I mean those you can apply on your character sheet. Not the “camera shots” you’ve just shown on screenshots - those work for me too. Haven’t you noticed that some creatures e.g. summons have set in portrait and not the camera shots?(the same is with companions from MotB) What I’m trying to figure out is how to make those prearranged portraits show up when your character polymorph into something. It seems that script that is responsible for polymorphing doesn’t have a function which would do that because otherwise druid elemental forms would have it already since the same blueprint is used for normal or summoned elementals.

hi mhroczyn
as i said before

where this script i don’t know (also I’m busy)
i tried found script or function ,but but didn’t find.
if i find i will write.

Luck with searching.

I’ve found a solution. Polymorphed forms data are stored in a file polymorph.2da including portrait that each creature uses. However those portraits are referenced only through portrait ID’s which are stored in file portraits.2da. By viewing specific id in that file you can find current portrait name and simply name your new portrait with the same name and put it into override folder (that will work). I couldn’t however simply replace the name itself in the portraits.2da file (when I tried that the game simply didn’t changed portrait at all upon polymorphing) and I have no idea where those default portraits are stored. In case someone would like to find them the naming convention is the same as in NWN1.

1 Like

I found this
I’ll leave it here in case someone needs it

you can set a portrait of a creature with scripts