How to activate the Summoning Circle?

I am trying to draw a Summoning Circle at a location in an area in my module. It shows in the toolset, but when I go to test it, it’s invisible. It’s a placeable object, in the visual effects catagory. The object itself says in the notes the following in the comments:

“NOTE: The circle will not be visible until it is changed to play its ACTIVATE animation either by scripting or setting it from the start in the toolset.”

I looked at the script that is default attached to it, x2_plc_used_act, and it looks like I need to set “X2_L_PLC_ACTIVATED_STATE” equal to 1, then run the script to run the activation animation.

So what I tried was moving the onUsed script to the onHeartbeat, and I set the local variable to 1 on the object. This should set the object to active and then 6 seconds later the animation should trigger. (I know the heartbeat isn’t a very good location to put it, but I only did that to see if I could get it to work). It didn’t work and I don’t know what else to try.

I really only wanted the visual of it, I tried using a regular portal and changing the appearance of it, but that didn’t work also. It is also invisible (and I did make sure to check that it was activated in properties too).

Should just be a matter of unchecking static. Default initial state is Activated.


1 Like

That’s right. In general, placeable activate / deactivate or open / close animations only work when static is unchecked.

In the toolset, once that’s done, you have the Initial State toggle on the Advanced tab of the placeable properties, which you can also access by right-clicking on the rendered placeable in the main window.

In a script, the state can be changed using PlayAnimation.

1 Like

Thanks, that static checkbox was the culprit!