How to disable creature body bag (aka remains) animation?

Is there a way to disable animation of creature remains or at least replace them with different model without animations? I’ve found out they have huge impact on FPS if area has a lot of them even if NWN2 is running on Ryzen 7 5800X and I couldn’t find something relevant in custom content.

EDIT: I’ve tried with changing default bodybag.2da and placing it in override but it has no effect in exsisting saves.

how bout a clean-up script, run manually from the console if/when things get choppy?

or, you could try this. Create an empty textfile called fx_lootbag.sef in /override

1 Like

If this is about loads of random loot then…

open the module with the toolset,
click view then module properties,
click properties, scroll down to variables,
click the 3 dots in a square bit on that line,
click add
type X2_L_NOTRESURE next to name
and put 1 as the Value Int,
OK it, close everything and save the module when you close the toolset.

This wont stop specific loot set as droppable on creatures so it’s unlikely you’ll miss anything vital but you will finish up with less cash when you’re trading.

Actually, I need it for exsisting games in some h&s modules with infinite monster spawning. Placing empty fx_lootbag.sef in override disabled antimation but did’nt increase FPS.
Using modified HerMyT's Area Cleanup Script | The Neverwinter Vault
from override cleaned area and restored FPS to normal.


not sure how you’ve implemented it, but if you’re running it from the console over and over … its possible to set up a small gui screen w/ buttonclick …

Not necessary. I’ve built more enchanted trees (Sean Maxhell Town Simulator | The Neverwinter Vault) so it souldn’t be problem next time I go to surface.