How to download non-zipped hak files?

I found a few custom creature haks that I am interested in using, but the hak files are not zipped. When I click on them to download they open in the browser.

I’m sure this is a common question. I just can’t find anything here in the forums directly related to it. Probably a browser setting…? Any suggestions?

Thanks

Right click => save as?..

Thx! Tried that… only allows me to Save As an HTML file.

Can you give us a link to this file or the page that contains the file?

Sorry, should have thought to include these in the first place…

https://neverwintervault.org/project/nwn2/model/giant-ant

https://neverwintervault.org/project/nwn2/prefab/creature/basilisk

Thanks.

I just left clicked on them and they seemed to work fine?

Well, in any case, try to download them from here.

1 Like

@Clangeddin, thank you! Yes, this worked fine. Also, I tried one more time last night using the old IE. IE actually let me use the “Save As” option and it worked fine too. I just had to select “All Files” from the drop down and manually add the “.hak” extension.

Thanks for the help.

OK, another day another few questions… It seems like every time I work on the module I come away with more questions than answers… I intend on using the ankheg in the mod and have downloaded the required files from here:

https://neverwintervault.org/project/nwn2/model/ankheg-nwn2

Now, I have become moderately adept at building a hak file, associating it with the mod, and importing the .erf. here are the questions I have, there’s no .erf here, so what do I do? Build the hak and change the appearance of an existing creature to that of an ankheg? And what do I do with the scripts? Place them in the override file? Or add them to the hak file?

Next, how do I make it so a wooden balcony or staircase walkable? No matter what I try I can’t get it to work. The PC either runs through the object or it’s just a barrier to them… I’m sure it’s just a simple setting, but I haven’t discovered it yet.

Thanks.

I have the ERF, but I can’t post it here for strange reasons.
Is it possible to do this over here on the forums?
Still you can manually create a blueprint in the toolset for your Ankheg however.

Thanks! Not sure if the .erf can be posted here or not, still a newbie to much of this. How would I go about manually creating a blueprint for the ankheg?

Do you have the scripts that go with it?

This is the one.

https://neverwintervault.org/project/nwn2/model/ankheg-nwn2

Yes, I have the scripts that came with in the .rar file.

Properties.

@raymondsebas, thank you very much! Even with my limited skills I can follow this! I’ll give it a shot when I get home from work tonight. I post later tonight and let you know how it turned out.

@angry_yard_gnome If it doesn’t work let us know.
Maybe other people can help too.
Have a nice day.

I haven’t checked, but Kamal’s Creature Compilation may have blueprints. If it doesn’t then they could be added by some kind soul.

Working on building the ankheg blueprint now. So far going well but cannot figure out how to import the ankeg scripts. And should I use the .NCS or .NSS files when I do? What are the differences btw the two?

Actually, I mostly figured it out. I opened the .nss files with notepad and copied the script into the new script window in the toolset, compiled and saved, then selected from the drop down in the Ankheg properties window. Still can’t figure out how to handle the .DLG file. I know it’s for the conversation, but can’t find a way to open it that gives any useable content.

1 Like

Just wanted to tell you that but you just figured out.
What a good little gnome! :yum:

LOL! Hardly, more the angry part now… still can’t figure out the .dlg file NAD when the ankheg spawns in in an encounter, it appears as a human fighter…! Not sure what I did wrong there. When I place the creature it’s an ankheg, but not when it spawns.