How to make custom dynamic races

I would like to make custom races with changeable body and armor parts instead of using static creature models. Can anyone point me in the right direction? I’ve tried renaming MDL and PTL files (1000 at a time, manually) from “pmhxxxxx” to “pfhxxxxx” only to run into invalid metallic looking male shaped textures on a female character. I can’t seem to find a good application for viewing/editing these files.

There’s a few steps to it but not very complicated. I point you to the Custom Content Guide v3.0 by Eligio_Sacateca, It’s dated but still accurate. You’ll want the section about creating the wemic dynamic model… This will put you on track. Good Luck !

1 Like

I have just started this myself and I’m almost done with the Warforged. On discord Acidchalk has made like 20+ dynamic races if you get stuck you could try asking him. I’ve been bugging him like mad myself.

Also here is a guide:
https://neverwintervault.org/project/nwnee/other/custom-races-sample

2 Likes

One minor update to the Custom Content Guide - renaming models can be even easier using the NWN Model Renamer tool (or, with a trivial element of risk, a good text editor).

It’s not enough to rename the models - you need a tool that changes all the internal references, too.

2 Likes

I was doing the “Body Pieces & Armor Parts Modeling Tutorial by Harliquinn Whiteshadow”, but hit a brick wall during step 8. NWN Viewer won’t open my BIF files.

Use NWN Explorer.

Sounds like a very old tutorial - I don’t think NWN Viewer has been usable for many years.

You’d be better off with the Custom Content Guide.

That does have broken links to the old vault, but you can find the utilities mentioned by searching the new vault.

1 Like

Okay so I took a look at that, and now I can’t get NWNMdlCompiler to work. I found this:

https://neverwintervault.org/forums/neverwinter-nights-1/nwn1-custom-content/solved-anybody-else-having-trouble-nwnmdlcomp-not

So I have to reinstall NWN and run critical rebuild in order to fix my registry keys? Isn’t that not supposed to be used with Enhanced Edition? I guess it’s not clear what the solution is.

I was really puzzled by that thread, as I can’t imagine why a Command Prompt tool like nwnmdlcomp would need registry entries. Did you try the solution I mentioned there?

You’re right - Critical Rebuild is not for use with EE. Perhaps TAD reinstalled and rebuilt 1.69 on the same machine (which is OK) but maybe it was fortuitous that the compiler worked after that?

I found a new version of NWNMDLcompiler here:

This one works having followed the instructions here, but is the broken version:

https://neverwintervault.org/project/nwn1/other/tool/nwnmdlcomp-nwn-model-compiler

That file renamer tool is going to be very handy. My next question is: Is there a way to export multiple files at a time with NWN Explorer?